aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2017-07-31 06:45:50 +0800
committerdbaio <dbaio@FreeBSD.org>2017-07-31 06:45:50 +0800
commit8c147c11948155c12227d9ce5aed6c3e30269090 (patch)
treea7455b2999a12665f77ef79acf7a2abde208fe11
parent2a948c4bff0db955bf3de73084f6a9f15209d9ad (diff)
downloadfreebsd-ports-gnome-8c147c11948155c12227d9ce5aed6c3e30269090.tar.gz
freebsd-ports-gnome-8c147c11948155c12227d9ce5aed6c3e30269090.tar.zst
freebsd-ports-gnome-8c147c11948155c12227d9ce5aed6c3e30269090.zip
net/glusterfs: Update to 3.11.1
- Regenerate patches While here: - Fix Q/A errors (shebangfix) - Update WWW - Use OPSYS with OSVERSION PR: 220674 Submitted by: craig001@lerwick.hopto.org (maintainer) Reviewed by: mat Differential Revision: https://reviews.freebsd.org/D11550
-rw-r--r--net/glusterfs/Makefile32
-rw-r--r--net/glusterfs/distinfo6
-rw-r--r--net/glusterfs/files/patch-configure4
-rw-r--r--net/glusterfs/files/patch-contrib_fuse-lib_mount.c (renamed from net/glusterfs/files/patch-contrib-fuse-lib-mount.c)4
-rw-r--r--net/glusterfs/files/patch-extras_Makefile.in (renamed from net/glusterfs/files/patch-extras-Makefile.in)12
-rw-r--r--net/glusterfs/pkg-descr2
-rw-r--r--net/glusterfs/pkg-plist71
7 files changed, 68 insertions, 63 deletions
diff --git a/net/glusterfs/Makefile b/net/glusterfs/Makefile
index 4ceb9f4130ba..d6db7d49cc81 100644
--- a/net/glusterfs/Makefile
+++ b/net/glusterfs/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= glusterfs
-PORTVERSION= 3.9.0
-PORTREVISION= 3
+PORTVERSION= 3.11.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://bits.gluster.org/pub/gluster/glusterfs/src/
@@ -14,18 +14,26 @@ LICENSE_COMB= dual
LIB_DEPENDS= libargp.so:devel/argp-standalone liburcu-bp.so:sysutils/liburcu
-USE_GCC= any
-
USES= bison gettext libtool pkgconfig python readline shebangfix \
sqlite ssl
BROKEN_SSL= libressl
-SHEBANG_FILES= extras/ganesha/scripts/create-export-ganesha.sh \
- extras/ganesha/scripts/dbus-send.sh \
- extras/ganesha/scripts/ganesha-ha.sh \
- extras/ganesha/scripts/generate-epoch.py \
- extras/peer_add_secret_pub.in \
+SHEBANG_FILES= extras/peer_add_secret_pub.in \
+ events/src/glustereventsd.py \
+ events/src/peer_eventsapi.py \
+ tools/glusterfind/src/nodeagent.py \
+ tools/glusterfind/src/brickfind.py \
+ tools/glusterfind/src/changelog.py \
+ tools/glusterfind/glusterfind.in \
+ tools/gfind_missing_files/gfid_to_path.py \
+ extras/pre-upgrade-script-for-quota.sh \
+ events/tools/eventsdash.py \
+ extras/post-upgrade-script-for-quota.sh \
+ extras/snap_scheduler/gcron.py \
+ extras/snap_scheduler/snap_scheduler.py \
+ events/src/peer_eventsapi.py \
+ events/src/glustereventsd.py \
tools/glusterfind/S57glusterfind-delete-post.py
USE_GNOME= glib20 libxml2
@@ -47,4 +55,10 @@ INSTALL_TARGET= install-strip
PLIST_SUB= GLUSTERLIBDIR="lib/${PORTNAME}/${PORTVERSION}"
KMODDIR?= /boot/modules
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101001
+USE_GCC= yes
+.endif
+
.include <bsd.port.mk>
diff --git a/net/glusterfs/distinfo b/net/glusterfs/distinfo
index 16eab9918288..7572dbce5a79 100644
--- a/net/glusterfs/distinfo
+++ b/net/glusterfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479924003
-SHA256 (glusterfs-3.9.0.tar.gz) = b417c674454b17d1851828a1ca395cb9e7ab198378391da04e2fb8911cc1fb14
-SIZE (glusterfs-3.9.0.tar.gz) = 8709782
+TIMESTAMP = 1499632037
+SHA256 (glusterfs-3.11.1.tar.gz) = c7e0502631c9bc9da05795b666b74ef40a30a0344f5a2e205e65bd2faefe1442
+SIZE (glusterfs-3.11.1.tar.gz) = 9155001
diff --git a/net/glusterfs/files/patch-configure b/net/glusterfs/files/patch-configure
index cd5985d28333..930af26f999f 100644
--- a/net/glusterfs/files/patch-configure
+++ b/net/glusterfs/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2016-11-15 14:54:31 UTC
+--- configure.orig 2017-06-27 15:25:15 UTC
+++ configure
-@@ -13428,6 +13428,9 @@ case $host_os in
+@@ -13475,6 +13475,9 @@ case $host_os in
linux*)
#do nothing
;;
diff --git a/net/glusterfs/files/patch-contrib-fuse-lib-mount.c b/net/glusterfs/files/patch-contrib_fuse-lib_mount.c
index 7723aa55cd3a..1241f34027af 100644
--- a/net/glusterfs/files/patch-contrib-fuse-lib-mount.c
+++ b/net/glusterfs/files/patch-contrib_fuse-lib_mount.c
@@ -1,6 +1,6 @@
---- contrib/fuse-lib/mount.c.orig 2016-11-15 14:54:27 UTC
+--- contrib/fuse-lib/mount.c.orig 2017-06-27 15:25:12 UTC
+++ contrib/fuse-lib/mount.c
-@@ -256,6 +256,7 @@ fuse_mount_sys (const char *mountpoint,
+@@ -382,6 +382,7 @@ fuse_mount_sys (const char *mountpoint,
build_iovec (&iov, &iovlen, "from", "/dev/fuse", -1);
build_iovec (&iov, &iovlen, "volname", source, -1);
build_iovec (&iov, &iovlen, "fd", fdstr, -1);
diff --git a/net/glusterfs/files/patch-extras-Makefile.in b/net/glusterfs/files/patch-extras_Makefile.in
index 40087f4f3344..510b99f53b0e 100644
--- a/net/glusterfs/files/patch-extras-Makefile.in
+++ b/net/glusterfs/files/patch-extras_Makefile.in
@@ -1,6 +1,6 @@
---- extras/Makefile.in.orig 2016-11-15 14:54:33 UTC
+--- extras/Makefile.in.orig 2017-06-27 15:25:17 UTC
+++ extras/Makefile.in
-@@ -635,8 +635,8 @@ install-volDATA: $(vol_DATA)
+@@ -637,8 +637,8 @@ install-volDATA: $(vol_DATA)
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
@@ -11,12 +11,12 @@
done
uninstall-volDATA:
-@@ -935,7 +935,7 @@ install-data-local:
+@@ -937,7 +937,7 @@ install-data-local:
fi
$(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
- $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt.sample
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
+ $(INSTALL_DATA) $(top_srcdir)/extras/group-metadata-cache \
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/metadata-cache
+ $(INSTALL_DATA) $(top_srcdir)/extras/group-gluster-block \
diff --git a/net/glusterfs/pkg-descr b/net/glusterfs/pkg-descr
index 6b523f4ae0dd..28240057bfe8 100644
--- a/net/glusterfs/pkg-descr
+++ b/net/glusterfs/pkg-descr
@@ -6,4 +6,4 @@ resources and managing data in a single global namespace. GlusterFS
is based on a stackable user space design and can deliver exceptional
performance for diverse workloads.
-WWW: http://www.gluster.org
+WWW: https://www.gluster.org
diff --git a/net/glusterfs/pkg-plist b/net/glusterfs/pkg-plist
index 9ce61a669282..87a6e30a1c9b 100644
--- a/net/glusterfs/pkg-plist
+++ b/net/glusterfs/pkg-plist
@@ -1,20 +1,22 @@
bin/glusterfind
-@sample etc/ganesha/ganesha-ha.conf.sample
%%ETCDIR%%/eventsconfig.json
%%ETCDIR%%/gluster-rsyslog-5.8.conf
%%ETCDIR%%/gluster-rsyslog-7.2.conf
@sample %%ETCDIR%%/glusterd.vol.sample
%%ETCDIR%%/glusterfs-georep-logrotate
%%ETCDIR%%/glusterfs-logrotate
+%%ETCDIR%%/group-gluster-block
+%%ETCDIR%%/group-metadata-cache
+%%ETCDIR%%/group-nl-cache
%%ETCDIR%%/group-virt.example
%%ETCDIR%%/logger.conf.example
include/glusterfs/api/glfs-handles.h
include/glusterfs/api/glfs.h
+include/glusterfs/atomic.h
include/glusterfs/byte-order.h
include/glusterfs/call-stub.h
include/glusterfs/checksum.h
include/glusterfs/circ-buff.h
-include/glusterfs/cli1-xdr.h
include/glusterfs/client_t.h
include/glusterfs/cluster-syncop.h
include/glusterfs/common-utils.h
@@ -43,7 +45,6 @@ include/glusterfs/gidcache.h
include/glusterfs/glfs-message-id.h
include/glusterfs/globals.h
include/glusterfs/glusterfs-acl.h
-include/glusterfs/glusterfs-fops.h
include/glusterfs/glusterfs.h
include/glusterfs/graph-utils.h
include/glusterfs/hashfn.h
@@ -84,6 +85,7 @@ include/glusterfs/rpc/rpc-clnt.h
include/glusterfs/rpc/rpc-common-xdr.h
include/glusterfs/rpc/rpc-drc.h
include/glusterfs/rpc/rpc-lib-messages.h
+include/glusterfs/rpc/rpc-pragmas.h
include/glusterfs/rpc/rpc-transport.h
include/glusterfs/rpc/rpcsvc-common.h
include/glusterfs/rpc/rpcsvc.h
@@ -111,7 +113,6 @@ include/glusterfs/throttle-tbf.h
include/glusterfs/timer.h
include/glusterfs/timespec.h
include/glusterfs/trie.h
-include/glusterfs/tw.h
include/glusterfs/upcall-utils.h
include/glusterfs/xlator.h
include/glusterfs/y.tab.h
@@ -124,13 +125,13 @@ include/glusterfs/y.tab.h
%%GLUSTERLIBDIR%%/xlator/cluster/distribute.so
%%GLUSTERLIBDIR%%/xlator/cluster/ec.so
%%GLUSTERLIBDIR%%/xlator/cluster/nufa.so
-%%GLUSTERLIBDIR%%/xlator/cluster/pump.so
%%GLUSTERLIBDIR%%/xlator/cluster/replicate.so
%%GLUSTERLIBDIR%%/xlator/cluster/stripe.so
%%GLUSTERLIBDIR%%/xlator/cluster/switch.so
%%GLUSTERLIBDIR%%/xlator/cluster/tier.so
%%GLUSTERLIBDIR%%/xlator/debug/error-gen.so
%%GLUSTERLIBDIR%%/xlator/debug/io-stats.so
+%%GLUSTERLIBDIR%%/xlator/debug/sink.so
%%GLUSTERLIBDIR%%/xlator/debug/trace.so
%%GLUSTERLIBDIR%%/xlator/encryption/crypt.so
%%GLUSTERLIBDIR%%/xlator/encryption/rot-13.so
@@ -146,26 +147,23 @@ include/glusterfs/y.tab.h
%%GLUSTERLIBDIR%%/xlator/features/glupy.so
%%GLUSTERLIBDIR%%/xlator/features/glupy/debug-trace.py
%%GLUSTERLIBDIR%%/xlator/features/glupy/debug-trace.pyc
-%%GLUSTERLIBDIR%%/xlator/features/glupy/debug-trace.pyo
+%%GLUSTERLIBDIR%%/xlator/features/glupy/debug-trace.%%PYTHON_PYOEXTENSION%%
%%GLUSTERLIBDIR%%/xlator/features/glupy/helloworld.py
%%GLUSTERLIBDIR%%/xlator/features/glupy/helloworld.pyc
-%%GLUSTERLIBDIR%%/xlator/features/glupy/helloworld.pyo
+%%GLUSTERLIBDIR%%/xlator/features/glupy/helloworld.%%PYTHON_PYOEXTENSION%%
%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.py
%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.pyc
-%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.pyo
+%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.%%PYTHON_PYOEXTENSION%%
%%GLUSTERLIBDIR%%/xlator/features/index.so
%%GLUSTERLIBDIR%%/xlator/features/leases.so
%%GLUSTERLIBDIR%%/xlator/features/locks.so
-%%GLUSTERLIBDIR%%/xlator/features/mac-compat.so
%%GLUSTERLIBDIR%%/xlator/features/marker.so
%%GLUSTERLIBDIR%%/xlator/features/posix-locks.so
-%%GLUSTERLIBDIR%%/xlator/features/prot_client.so
-%%GLUSTERLIBDIR%%/xlator/features/prot_dht.so
-%%GLUSTERLIBDIR%%/xlator/features/prot_server.so
%%GLUSTERLIBDIR%%/xlator/features/quiesce.so
%%GLUSTERLIBDIR%%/xlator/features/quota.so
%%GLUSTERLIBDIR%%/xlator/features/quotad.so
%%GLUSTERLIBDIR%%/xlator/features/read-only.so
+%%GLUSTERLIBDIR%%/xlator/features/selinux.so
%%GLUSTERLIBDIR%%/xlator/features/shard.so
%%GLUSTERLIBDIR%%/xlator/features/snapview-client.so
%%GLUSTERLIBDIR%%/xlator/features/snapview-server.so
@@ -176,11 +174,11 @@ include/glusterfs/y.tab.h
%%GLUSTERLIBDIR%%/xlator/mgmt/glusterd.so
%%GLUSTERLIBDIR%%/xlator/mount/api.so
%%GLUSTERLIBDIR%%/xlator/mount/fuse.so
-%%GLUSTERLIBDIR%%/xlator/nfs/server.so
%%GLUSTERLIBDIR%%/xlator/performance/decompounder.so
%%GLUSTERLIBDIR%%/xlator/performance/io-cache.so
%%GLUSTERLIBDIR%%/xlator/performance/io-threads.so
%%GLUSTERLIBDIR%%/xlator/performance/md-cache.so
+%%GLUSTERLIBDIR%%/xlator/performance/nl-cache.so
%%GLUSTERLIBDIR%%/xlator/performance/open-behind.so
%%GLUSTERLIBDIR%%/xlator/performance/quick-read.so
%%GLUSTERLIBDIR%%/xlator/performance/read-ahead.so
@@ -213,47 +211,40 @@ lib/libglusterfs.so.0
lib/libglusterfs.so.0.0.1
lib/ocf/resource.d/glusterfs/glusterd
lib/ocf/resource.d/glusterfs/volume
-lib/ocf/resource.d/heartbeat/ganesha_grace
-lib/ocf/resource.d/heartbeat/ganesha_mon
-lib/ocf/resource.d/heartbeat/ganesha_nfsd
%%PYTHON_SITELIBDIR%%/gluster/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/__init__.pyc
-%%PYTHON_SITELIBDIR%%/gluster/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gluster/__init__.%%PYTHON_PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.pyc
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.%%PYTHON_PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.py
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.pyc
-%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.pyo
+%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.%%PYTHON_PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.pyc
-%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.%%PYTHON_PYOEXTENSION%%
libdata/pkgconfig/glusterfs-api.pc
libdata/pkgconfig/libgfchangelog.pc
libdata/pkgconfig/libgfdb.pc
-libexec/ganesha/create-export-ganesha.sh
-libexec/ganesha/dbus-send.sh
-libexec/ganesha/ganesha-ha.sh
-libexec/ganesha/generate-epoch.py
libexec/glusterfs/events/__init__.py
libexec/glusterfs/events/__init__.pyc
-libexec/glusterfs/events/__init__.pyo
+libexec/glusterfs/events/__init__.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/events/eventsapiconf.py
libexec/glusterfs/events/eventsapiconf.pyc
-libexec/glusterfs/events/eventsapiconf.pyo
+libexec/glusterfs/events/eventsapiconf.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/events/eventtypes.py
libexec/glusterfs/events/eventtypes.pyc
-libexec/glusterfs/events/eventtypes.pyo
+libexec/glusterfs/events/eventtypes.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/events/gf_event.py
libexec/glusterfs/events/gf_event.pyc
-libexec/glusterfs/events/gf_event.pyo
+libexec/glusterfs/events/gf_event.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/events/glustereventsd.py
libexec/glusterfs/events/handlers.py
libexec/glusterfs/events/handlers.pyc
-libexec/glusterfs/events/handlers.pyo
+libexec/glusterfs/events/handlers.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/events/utils.py
libexec/glusterfs/events/utils.pyc
-libexec/glusterfs/events/utils.pyo
+libexec/glusterfs/events/utils.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/gfind_missing_files/gcrawler
libexec/glusterfs/gfind_missing_files/gfid_to_path.py
libexec/glusterfs/gfind_missing_files/gfid_to_path.sh
@@ -261,26 +252,26 @@ libexec/glusterfs/gfind_missing_files/gfind_missing_files.sh
libexec/glusterfs/glusterfind/S57glusterfind-delete-post.py
libexec/glusterfs/glusterfind/__init__.py
libexec/glusterfs/glusterfind/__init__.pyc
-libexec/glusterfs/glusterfind/__init__.pyo
+libexec/glusterfs/glusterfind/__init__.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/glusterfind/brickfind.py
libexec/glusterfs/glusterfind/changelog.py
libexec/glusterfs/glusterfind/changelogdata.py
libexec/glusterfs/glusterfind/changelogdata.pyc
-libexec/glusterfs/glusterfind/changelogdata.pyo
+libexec/glusterfs/glusterfind/changelogdata.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/glusterfind/conf.py
libexec/glusterfs/glusterfind/conf.pyc
-libexec/glusterfs/glusterfind/conf.pyo
+libexec/glusterfs/glusterfind/conf.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/glusterfind/libgfchangelog.py
libexec/glusterfs/glusterfind/libgfchangelog.pyc
-libexec/glusterfs/glusterfind/libgfchangelog.pyo
+libexec/glusterfs/glusterfind/libgfchangelog.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/glusterfind/main.py
libexec/glusterfs/glusterfind/main.pyc
-libexec/glusterfs/glusterfind/main.pyo
+libexec/glusterfs/glusterfind/main.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/glusterfind/nodeagent.py
libexec/glusterfs/glusterfind/tool.conf
libexec/glusterfs/glusterfind/utils.py
libexec/glusterfs/glusterfind/utils.pyc
-libexec/glusterfs/glusterfind/utils.pyo
+libexec/glusterfs/glusterfind/utils.%%PYTHON_PYOEXTENSION%%
libexec/glusterfs/peer_add_secret_pub
libexec/glusterfs/peer_eventsapi.py
man/man8/gluster.8.gz
@@ -290,6 +281,7 @@ man/man8/glusterfsd.8.gz
man/man8/mount.glusterfs.8.gz
sbin/conf.py
sbin/gcron.py
+sbin/gf_attach
sbin/gfind_missing_files
sbin/glfsheal
sbin/gluster
@@ -312,16 +304,17 @@ sbin/umountd
%%DATADIR%%/scripts/post-upgrade-script-for-quota.sh
%%DATADIR%%/scripts/pre-upgrade-script-for-quota.sh
%%DATADIR%%/scripts/stop-all-gluster-processes.sh
+/var/db/glusterd/groups/gluster-block
+/var/db/glusterd/groups/metadata-cache
+/var/db/glusterd/groups/nl-cache
@sample /var/db/glusterd/groups/virt.sample
/var/db/glusterd/hooks/1/add-brick/post/disabled-quota-root-xattr-heal.sh
/var/db/glusterd/hooks/1/add-brick/pre/S28Quota-enable-root-xattr-heal.sh
/var/db/glusterd/hooks/1/delete/post/S57glusterfind-delete-post
-/var/db/glusterd/hooks/1/reset/post/S31ganesha-reset.sh
/var/db/glusterd/hooks/1/set/post/S30samba-set.sh
/var/db/glusterd/hooks/1/set/post/S32gluster_enable_shared_storage.sh
/var/db/glusterd/hooks/1/start/post/S29CTDBsetup.sh
/var/db/glusterd/hooks/1/start/post/S30samba-start.sh
-/var/db/glusterd/hooks/1/start/post/S31ganesha-start.sh
/var/db/glusterd/hooks/1/stop/pre/S29CTDB-teardown.sh
/var/db/glusterd/hooks/1/stop/pre/S30samba-stop.sh
@dir /var/db/glusterd/events
@@ -333,8 +326,6 @@ sbin/umountd
@dir /var/db/glusterd/hooks/1/add-brick
@dir /var/db/glusterd/hooks/1/delete/post
@dir /var/db/glusterd/hooks/1/delete
-@dir /var/db/glusterd/hooks/1/reset/post
-@dir /var/db/glusterd/hooks/1/reset
@dir /var/db/glusterd/hooks/1/set/post
@dir /var/db/glusterd/hooks/1/set
@dir /var/db/glusterd/hooks/1/start/post