aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-19 23:14:47 +0800
committerrafan <rafan@FreeBSD.org>2008-03-19 23:14:47 +0800
commit8e62c7eabf3ac2400c1bcc76b065dfbf453f77d8 (patch)
treede235039f14b0f749fbed690c2aab96c184dd5bb
parent89b3b316cd520719e483d01d7b61db30fb58a2dd (diff)
downloadfreebsd-ports-gnome-8e62c7eabf3ac2400c1bcc76b065dfbf453f77d8.tar.gz
freebsd-ports-gnome-8e62c7eabf3ac2400c1bcc76b065dfbf453f77d8.tar.zst
freebsd-ports-gnome-8e62c7eabf3ac2400c1bcc76b065dfbf453f77d8.zip
Tig is a git repository browser that additionally
can act as a pager for output from various git commands. When browsing repositories, it uses the underlying git commands to present the user with various views, such as summarized revision log and showing the commit with the log message, diffstat, and the diff. Using it as a pager, it will display input from stdin and colorize it. WWW: http://jonas.nitro.dk/tig/ PR: ports/121805 Submitted by: Denise H. G. <darcsis at gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tig/Makefile35
-rw-r--r--devel/tig/distinfo3
-rw-r--r--devel/tig/pkg-descr13
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3b79def84daa..aff18f9b8884 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2348,6 +2348,7 @@
SUBDIR += thistest
SUBDIR += thrift
SUBDIR += tide
+ SUBDIR += tig
SUBDIR += tigcc
SUBDIR += tijmp
SUBDIR += tinylaf
diff --git a/devel/tig/Makefile b/devel/tig/Makefile
new file mode 100644
index 000000000000..c3c8c58d96e3
--- /dev/null
+++ b/devel/tig/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: tig
+# Date created: 18 Mar 2008
+# Whom: Denise H. G. <darcsis@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tig
+PORTVERSION= 0.10
+CATEGORIES= devel
+MASTER_SITES= http://jonas.nitro.dk/tig/releases/
+
+MAINTAINER= darcsis@gmail.com
+COMMENT= Text-mode interface for git
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+MAN1= tig.1
+MAN5= tigrc.5
+MANCOMPRESSED= no
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+
+USE_GMAKE= yes
+USE_ICONV= yes
+
+PLIST_FILES= bin/tig
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}rc.5 ${MANPREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/devel/tig/distinfo b/devel/tig/distinfo
new file mode 100644
index 000000000000..e1610f01d201
--- /dev/null
+++ b/devel/tig/distinfo
@@ -0,0 +1,3 @@
+MD5 (tig-0.10.tar.gz) = cea0c80cfe1575510ceaba81669363ce
+SHA256 (tig-0.10.tar.gz) = bdbb05e4b1c15c0f630f620a75a7fff5c3fb4dc7e8c9fbc780e489f3da77c08b
+SIZE (tig-0.10.tar.gz) = 102920
diff --git a/devel/tig/pkg-descr b/devel/tig/pkg-descr
new file mode 100644
index 000000000000..3690a41f2163
--- /dev/null
+++ b/devel/tig/pkg-descr
@@ -0,0 +1,13 @@
+Tig is a git repository browser that additionally
+can act as a pager for output from various git
+commands.
+
+When browsing repositories, it uses the underlying
+git commands to present the user with various views,
+such as summarized revision log and showing the
+commit with the log message, diffstat, and the diff.
+
+Using it as a pager, it will display input from stdin
+and colorize it.
+
+WWW: http://jonas.nitro.dk/tig/