aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-30 00:41:57 +0800
committerpav <pav@FreeBSD.org>2006-04-30 00:41:57 +0800
commit91a1cec78609132e1180b172531ef737ead16732 (patch)
treef74bbb08ad176f85d1070be78fb4a29168d37131
parentdbdb364d62c87c5613f77a8c223437b2037f4eb8 (diff)
downloadfreebsd-ports-gnome-91a1cec78609132e1180b172531ef737ead16732.tar.gz
freebsd-ports-gnome-91a1cec78609132e1180b172531ef737ead16732.tar.zst
freebsd-ports-gnome-91a1cec78609132e1180b172531ef737ead16732.zip
xmpppy is a Python library that is targeted to provide easy
scripting with Jabber. Similar projects are Twisted Words and jabber.py. This library was not designed from scratch. It inherits some code from jabberpy and have very similar API in many places. Though it is separate project since it have almost completely different architecture and primarily aims to work with jabberd2 - the new Open Source Jabber Server. WWW: http://xmpppy.sourceforge.net/ The IRC transport is a dynamic gateway that allows XMPP/Jabber users to connect to IRC using their Groupchat and MUC clients. It is based on xmpppy and irclib Python libraries. WWW: http://xmpppy.sourceforge.net/irc/ PR: ports/96362 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com>
-rw-r--r--net-im/Makefile2
-rw-r--r--net-im/py-xmpppy-irc/Makefile51
-rw-r--r--net-im/py-xmpppy-irc/distinfo3
-rw-r--r--net-im/py-xmpppy-irc/files/xmpppyirc.in19
-rw-r--r--net-im/py-xmpppy-irc/pkg-descr5
-rw-r--r--net-im/py-xmpppy/Makefile25
-rw-r--r--net-im/py-xmpppy/distinfo3
-rw-r--r--net-im/py-xmpppy/pkg-descr11
-rw-r--r--net-im/py-xmpppy/pkg-plist43
9 files changed, 162 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 9f6a6356fe43..f889aaf4dd5d 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -98,6 +98,8 @@
SUBDIR += psi
SUBDIR += py-jabber
SUBDIR += py-twistedWords
+ SUBDIR += py-xmpppy
+ SUBDIR += py-xmpppy-irc
SUBDIR += ruby-xmpp4r
SUBDIR += sendxmpp
SUBDIR += sim-im-devel
diff --git a/net-im/py-xmpppy-irc/Makefile b/net-im/py-xmpppy-irc/Makefile
new file mode 100644
index 000000000000..831edccf33d5
--- /dev/null
+++ b/net-im/py-xmpppy-irc/Makefile
@@ -0,0 +1,51 @@
+# Ports collection makefile for: py-irc-transport
+# Date created: 21 April 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmpppy-irc
+PORTVERSION= 0.3
+CATEGORIES= net-im python irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xmpppy
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= irc-transport-${PORTVERSION}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= An xmpp to irc transport
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xmpp/__init__.py:${PORTSDIR}/net-im/py-xmpppy \
+ ${PYTHON_SITELIBDIR}/irclib.py:${PORTSDIR}/irc/py-irclib
+
+USE_PYTHON= 2.3+
+NO_BUILD= yes
+FILES= irc.py jep0106.py jep0133.py test_jep0106.py
+PFILES= ${FILES:S.^.%%PYTHON_SITELIBDIR%%/xmpp/irc/.}
+PLIST_FILES= ${PFILES} ${PFILES:S.$.c.} ${PFILES:S.$.o.} etc/${PORTNAME:S.-..}.conf.sample
+PLIST_DIRS= %%PYTHON_SITELIBDIR%%/xmpp/irc
+SUB_LIST= PYTHON_CMD=${PYTHON_CMD} FEXEC=${PYTHON_SITELIBDIR}/xmpp/irc/irc.py
+USE_RC_SUBR= xmpppyirc
+PORTDOCS= ChangeLog IRC-Transport-Howtouse.html README.txt
+DDIR= ${PYTHON_SITELIBDIR}/xmpp/irc
+
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s./usr/bin/python.${PYTHON_CMD}." \
+ -e "s!/etc/jabber/jabber-irc.conf!${PREFIX}/etc/${PORTNAME:S.-..}.conf!"
+
+do-install:
+ @${INSTALL} -d ${DDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/irc.py ${DDIR}/
+ @${INSTALL_DATA} ${FILES:M*jep*:S.^.${WRKSRC}/.} ${DDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/transport.ini ${PREFIX}/etc/${PORTNAME:S.-..}.conf.sample
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DDIR}
+ @${CHMOD} -R a-w ${DDIR}
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}
+ @${INSTALL} ${PORTDOCS:S.^.${WRKSRC}/.} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/py-xmpppy-irc/distinfo b/net-im/py-xmpppy-irc/distinfo
new file mode 100644
index 000000000000..185ce0474b8b
--- /dev/null
+++ b/net-im/py-xmpppy-irc/distinfo
@@ -0,0 +1,3 @@
+MD5 (irc-transport-0.3.tar.gz) = 8ad0190f1b158ef5990290a16eaf8084
+SHA256 (irc-transport-0.3.tar.gz) = 8dc4de9ca0f1445ed9023ee76e64de454f32c7e880f9ac37600fb1f81d2c46a4
+SIZE (irc-transport-0.3.tar.gz) = 22752
diff --git a/net-im/py-xmpppy-irc/files/xmpppyirc.in b/net-im/py-xmpppy-irc/files/xmpppyirc.in
new file mode 100644
index 000000000000..ca3df5e48bd8
--- /dev/null
+++ b/net-im/py-xmpppy-irc/files/xmpppyirc.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# PROVIDE: xmpppyirc
+# REQUIRE: DAEMON
+
+. %%RC_SUBR%%
+
+name="xmpppyirc"
+pidfile="/var/run/$name.pid"
+
+command="%%FEXEC%%"
+command_args="&"
+command_interpreter="%%PYTHON_CMD%%"
+required_files="%%PREFIX%%/etc/$name.conf"
+start_precmd="touch $pidfile && export PID=$pidfile"
+
+load_rc_config $name
+: ${xmpppyirc_enable="NO"}
+run_rc_command "$1"
diff --git a/net-im/py-xmpppy-irc/pkg-descr b/net-im/py-xmpppy-irc/pkg-descr
new file mode 100644
index 000000000000..7611165bf48b
--- /dev/null
+++ b/net-im/py-xmpppy-irc/pkg-descr
@@ -0,0 +1,5 @@
+The IRC transport is a dynamic gateway that allows XMPP/Jabber
+users to connect to IRC using their Groupchat and MUC clients.
+It is based on xmpppy and irclib Python libraries.
+
+WWW: http://xmpppy.sourceforge.net/irc/
diff --git a/net-im/py-xmpppy/Makefile b/net-im/py-xmpppy/Makefile
new file mode 100644
index 000000000000..cb16cfca2edc
--- /dev/null
+++ b/net-im/py-xmpppy/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: py-xmpppy
+# Date created: 21 April 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmpppy
+PORTVERSION= 0.3.1
+CATEGORIES= net-im python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A Python library that provides easy scripting with Jabber
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${GREP} -lr '/usr/bin/python' ${WRKSRC} | \
+ ${XARGS} ${REINPLACE_CMD} -e "s.^#!/usr/bin/python.#!${PYTHON_CMD}."
+
+.include <bsd.port.mk>
diff --git a/net-im/py-xmpppy/distinfo b/net-im/py-xmpppy/distinfo
new file mode 100644
index 000000000000..06f002a29799
--- /dev/null
+++ b/net-im/py-xmpppy/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmpppy-0.3.1.tar.gz) = 56e8df54288e57bd626cb53b31e2b41c
+SHA256 (xmpppy-0.3.1.tar.gz) = 4908197dfe326cef492360b285a9da0a8e0aa27e883bc99a5b076c2076ffc27d
+SIZE (xmpppy-0.3.1.tar.gz) = 252764
diff --git a/net-im/py-xmpppy/pkg-descr b/net-im/py-xmpppy/pkg-descr
new file mode 100644
index 000000000000..6e99d3582a9f
--- /dev/null
+++ b/net-im/py-xmpppy/pkg-descr
@@ -0,0 +1,11 @@
+xmpppy is a Python library that is targeted to provide easy
+scripting with Jabber. Similar projects are Twisted Words
+and jabber.py.
+
+This library was not designed from scratch. It inherits some
+code from jabberpy and have very similar API in many places.
+Though it is separate project since it have almost completely
+different architecture and primarily aims to work with jabberd2
+- the new Open Source Jabber Server.
+
+WWW: http://xmpppy.sourceforge.net/
diff --git a/net-im/py-xmpppy/pkg-plist b/net-im/py-xmpppy/pkg-plist
new file mode 100644
index 000000000000..da9b0dd5c6ed
--- /dev/null
+++ b/net-im/py-xmpppy/pkg-plist
@@ -0,0 +1,43 @@
+%%PYTHON_SITELIBDIR%%/xmpp/__init__.py
+%%PYTHON_SITELIBDIR%%/xmpp/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/__init__.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/auth.py
+%%PYTHON_SITELIBDIR%%/xmpp/auth.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/auth.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/browser.py
+%%PYTHON_SITELIBDIR%%/xmpp/browser.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/browser.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/client.py
+%%PYTHON_SITELIBDIR%%/xmpp/client.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/client.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/commands.py
+%%PYTHON_SITELIBDIR%%/xmpp/commands.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/commands.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/debug.py
+%%PYTHON_SITELIBDIR%%/xmpp/debug.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/debug.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/dispatcher.py
+%%PYTHON_SITELIBDIR%%/xmpp/dispatcher.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/dispatcher.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/features.py
+%%PYTHON_SITELIBDIR%%/xmpp/features.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/features.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/filetransfer.py
+%%PYTHON_SITELIBDIR%%/xmpp/filetransfer.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/filetransfer.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/protocol.py
+%%PYTHON_SITELIBDIR%%/xmpp/protocol.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/protocol.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/roster.py
+%%PYTHON_SITELIBDIR%%/xmpp/roster.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/roster.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/session.py
+%%PYTHON_SITELIBDIR%%/xmpp/session.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/session.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/simplexml.py
+%%PYTHON_SITELIBDIR%%/xmpp/simplexml.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/simplexml.pyo
+%%PYTHON_SITELIBDIR%%/xmpp/transports.py
+%%PYTHON_SITELIBDIR%%/xmpp/transports.pyc
+%%PYTHON_SITELIBDIR%%/xmpp/transports.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/xmpp