aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-23 04:56:52 +0800
committerpav <pav@FreeBSD.org>2004-05-23 04:56:52 +0800
commit953d23df685a736269171832674d59dc1abc3aa2 (patch)
treeb58f341593fb3c8fa403f7438927c6a46b5b77e4
parent474297d8364f2ea9d64d445f4a60e7d009257c61 (diff)
downloadfreebsd-ports-gnome-953d23df685a736269171832674d59dc1abc3aa2.tar.gz
freebsd-ports-gnome-953d23df685a736269171832674d59dc1abc3aa2.tar.zst
freebsd-ports-gnome-953d23df685a736269171832674d59dc1abc3aa2.zip
- Split libgsf port to two standalone ports:
* devel/libgsf is the old port minus gsf-gnome bits * devel/libgsf-gnome contains libgsf-gnome-1 library and it's header files This greatly reduces number of dependencies for ports that was using only non-gnome part of this library. - Point USE_GNOME parameter libgsf to GNOME-less port and create new parameter libgsf_gnome for libgsf-gnome port. - Convert all consumers of libgsf-gnome-1 library to depend on libgsf-gnome port (read all as: Gnumeric) PR: ports/63851 (in the spirit of) Submitted by: Sybolt de Boer <sybolt@xs4all.nl> Prodded by: lofi (KDE team) Reviewed by: marcus (GNOME team)
-rw-r--r--Mk/bsd.gnome.mk12
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libgsf-gnome/Makefile31
-rw-r--r--devel/libgsf-gnome/pkg-descr3
-rw-r--r--devel/libgsf-gnome/pkg-plist10
-rw-r--r--devel/libgsf/Makefile13
-rw-r--r--devel/libgsf/files/patch-gsf-gnome-Makefile.in46
-rw-r--r--devel/libgsf/pkg-plist10
-rw-r--r--math/gnumeric2/Makefile3
9 files changed, 108 insertions, 21 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index e1063c5df2db..014751adb252 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -42,8 +42,8 @@ _USE_GNOME_ALL+=glib20 atk pango gtk20 linc libidl orbit2 \
libgnome libbonoboui libgnomeui atspi libgailgnome \
libgtkhtml gnomedesktop libwnck vte libzvt librsvg2 eel2 \
gnomepanel nautilus2 metacity gal2 gnomecontrolcenter2 libgda2 \
- libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins \
- gtkhtml3 gnomespeech
+ libgnomedb gtksourceview libgsf libgsf_gnome pygtk2 pygnome2 \
+ gstreamerplugins gtkhtml3 gnomespeech
SCROLLKEEPER_DIR= /var/db/scrollkeeper
gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -381,8 +381,12 @@ pkgconfig_BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
pkgconfig_RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
libgsf_LIB_DEPENDS= gsf-1.10:${PORTSDIR}/devel/libgsf
-libgsf_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-gnome-1.pc
-libgsf_USE_GNOME_IMPL= gnomevfs2 libbonobo
+libgsf_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-1.pc
+libgsf_USE_GNOME_IMPL= glib10 libxml2
+
+libgsf_gnome_LIB_DEPENDS= gsf-gnome-1.10:${PORTSDIR}/devel/libgsf-gnome
+libgsf_gnome_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-gnome-1.pc
+libgsf_gnome_USE_GNOME_IMPL= gnomevfs2 libbonobo
pygtk2_DETECT= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py
pygtk2_BUILD_DEPENDS= ${pygtk2_DETECT}:${PORTSDIR}/x11-toolkits/py-gtk2
diff --git a/devel/Makefile b/devel/Makefile
index f8d77425b7b0..3f4def16b08c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -399,6 +399,7 @@
SUBDIR += libglademm
SUBDIR += libgnugetopt
SUBDIR += libgsf
+ SUBDIR += libgsf-gnome
SUBDIR += libgtop2
SUBDIR += libhash
SUBDIR += libhoard
diff --git a/devel/libgsf-gnome/Makefile b/devel/libgsf-gnome/Makefile
new file mode 100644
index 000000000000..226e3d388364
--- /dev/null
+++ b/devel/libgsf-gnome/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libgsf
+# Date created: 11 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel gnome
+PKGNAMESUFFIX= -gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME wrapper for libgsf
+
+MASTERDIR= ${.CURDIR}/../libgsf
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack libgsf gnomevfs2
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc/gsf \
+ --disable-gtk-doc --with-bz2 --with-gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgsf-1"
+
+do-build:
+ @cd ${WRKSRC}/gsf-gnome && ${MAKE}
+
+do-install:
+ @cd ${WRKSRC}/gsf-gnome && ${MAKE} install
+ @${INSTALL_DATA} ${WRKSRC}/libgsf-gnome-1.pc ${PREFIX}/libdata/pkgconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/libgsf-gnome/pkg-descr b/devel/libgsf-gnome/pkg-descr
new file mode 100644
index 000000000000..0252aadf0f92
--- /dev/null
+++ b/devel/libgsf-gnome/pkg-descr
@@ -0,0 +1,3 @@
+The library is a bonobo and gnomevfs wrapper for libgsf, providing a high level
+API for GNOME applications to access and exchange various structured file
+formats.
diff --git a/devel/libgsf-gnome/pkg-plist b/devel/libgsf-gnome/pkg-plist
new file mode 100644
index 000000000000..a51dfcc8744e
--- /dev/null
+++ b/devel/libgsf-gnome/pkg-plist
@@ -0,0 +1,10 @@
+include/libgsf-1/gsf-gnome/gsf-input-bonobo.h
+include/libgsf-1/gsf-gnome/gsf-input-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-output-bonobo.h
+include/libgsf-1/gsf-gnome/gsf-output-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-shared-bonobo-stream.h
+lib/libgsf-gnome-1.a
+lib/libgsf-gnome-1.so
+lib/libgsf-gnome-1.so.10
+libdata/pkgconfig/libgsf-gnome-1.pc
+@dirrm include/libgsf-1/gsf-gnome
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index f6a8485a000d..55fa4cbb751e 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -7,13 +7,14 @@
PORTNAME= libgsf
PORTVERSION= 1.9.1
-CATEGORIES= devel gnome
+PORTREVISION= 1
+CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An extensible i/o abstraction for dealing with structured file formats
+COMMENT?= An extensible i/o abstraction for dealing with structured file formats
.if !exists(/usr/lib/libbz2.so.1)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
@@ -22,11 +23,11 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack libbonobo gnomevfs2
+USE_GNOME?= gnomehack glib20 libxml2
USE_LIBTOOL_VER= 13
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc --with-gnome --with-bz2
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ARGS?= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc --without-gnome --with-bz2
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/devel/libgsf/files/patch-gsf-gnome-Makefile.in b/devel/libgsf/files/patch-gsf-gnome-Makefile.in
new file mode 100644
index 000000000000..4051a60c2310
--- /dev/null
+++ b/devel/libgsf/files/patch-gsf-gnome-Makefile.in
@@ -0,0 +1,46 @@
+--- gsf-gnome/Makefile.in.orig Sat May 22 18:56:24 2004
++++ gsf-gnome/Makefile.in Sat May 22 18:57:23 2004
+@@ -170,7 +170,7 @@
+
+ lib_LTLIBRARIES = $(target_libgsf_gnome)
+
+-libgsf_gnome_1_la_LIBADD = $(top_builddir)/gsf/libgsf-1.la $(LIBGSF_GNOME_LIBS)
++libgsf_gnome_1_la_LIBADD = $(LIBGSF_GNOME_LIBS)
+ libgsf_gnome_1_la_LDFLAGS = -version-info $(VERSION_INFO)
+ libgsf_gnome_1_la_SOURCES = \
+ gsf-input-gnomevfs.c \
+@@ -199,7 +199,7 @@
+ CONFIG_CLEAN_FILES =
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+
+-libgsf_gnome_1_la_DEPENDENCIES = $(top_builddir)/gsf/libgsf-1.la
++libgsf_gnome_1_la_DEPENDENCIES =
+ am_libgsf_gnome_1_la_OBJECTS = gsf-input-gnomevfs.lo \
+ gsf-output-gnomevfs.lo gsf-input-bonobo.lo gsf-output-bonobo.lo \
+ gsf-shared-bonobo-stream.lo
+--- gsf-gnome/Makefile.in.orig Sat May 22 19:26:16 2004
++++ gsf-gnome/Makefile.in Sat May 22 19:30:30 2004
+@@ -179,14 +179,15 @@
+ gsf-output-bonobo.c \
+ gsf-shared-bonobo-stream.c
+
+-
+-libgsf_gnome_1_includedir = $(includedir)/libgsf-1/gsf-gnome
+-libgsf_gnome_1_include_HEADERS = \
+- gsf-input-gnomevfs.h \
+- gsf-output-gnomevfs.h \
+- gsf-input-bonobo.h \
+- gsf-output-bonobo.h \
+- gsf-shared-bonobo-stream.h
++@WITH_LIBGSF_GNOME_FALSE@libgsf_gnome_1_includedir =
++@WITH_LIBGSF_GNOME_FALSE@libgsf_gnome_1_include_HEADERS =
++@WITH_LIBGSF_GNOME_TRUE@libgsf_gnome_1_includedir = $(includedir)/libgsf-1/gsf-gnome
++@WITH_LIBGSF_GNOME_TRUE@libgsf_gnome_1_include_HEADERS = \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-input-gnomevfs.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-output-gnomevfs.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-input-bonobo.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-output-bonobo.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-shared-bonobo-stream.h
+
+
+ # include these just in case we are building a tarball without
diff --git a/devel/libgsf/pkg-plist b/devel/libgsf/pkg-plist
index 335520ea105b..1b59f7c061e5 100644
--- a/devel/libgsf/pkg-plist
+++ b/devel/libgsf/pkg-plist
@@ -1,8 +1,3 @@
-include/libgsf-1/gsf-gnome/gsf-input-bonobo.h
-include/libgsf-1/gsf-gnome/gsf-input-gnomevfs.h
-include/libgsf-1/gsf-gnome/gsf-output-bonobo.h
-include/libgsf-1/gsf-gnome/gsf-output-gnomevfs.h
-include/libgsf-1/gsf-gnome/gsf-shared-bonobo-stream.h
include/libgsf-1/gsf-win32/gsf-input-win32.h
include/libgsf-1/gsf-win32/gsf-output-win32.h
include/libgsf-1/gsf/gsf-doc-meta-data.h
@@ -41,11 +36,7 @@ include/libgsf-1/gsf/gsf.h
lib/libgsf-1.a
lib/libgsf-1.so
lib/libgsf-1.so.10
-lib/libgsf-gnome-1.a
-lib/libgsf-gnome-1.so
-lib/libgsf-gnome-1.so.10
libdata/pkgconfig/libgsf-1.pc
-libdata/pkgconfig/libgsf-gnome-1.pc
share/doc/gsf/api.html
share/doc/gsf/gsf-Bononbo.html
share/doc/gsf/gsf-Compression.html
@@ -80,6 +71,5 @@ share/doc/gsf/style.css
share/doc/gsf/up.png
@dirrm share/doc/gsf
@dirrm include/libgsf-1/gsf-win32
-@dirrm include/libgsf-1/gsf-gnome
@dirrm include/libgsf-1/gsf
@dirrm include/libgsf-1
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 097ed2fc528d..4d20f217129b 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnumeric2
PORTVERSION= 1.2.12
+PORTREVISION= 1
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:R}
@@ -24,7 +25,7 @@ USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier libgnomeprintui libgnomedb \
- libgsf
+ libgsf_gnome
USE_PYTHON= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=13