aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-24 20:12:32 +0800
committerantoine <antoine@FreeBSD.org>2014-12-24 20:12:32 +0800
commit975071711f5c3f865c26a92986b615eddcbc24db (patch)
tree02dad5ce07403a28bb0288772beee3b592666922
parentc631181aa437c17d2337e080f06557a816fab837 (diff)
downloadfreebsd-ports-gnome-975071711f5c3f865c26a92986b615eddcbc24db.tar.gz
freebsd-ports-gnome-975071711f5c3f865c26a92986b615eddcbc24db.tar.zst
freebsd-ports-gnome-975071711f5c3f865c26a92986b615eddcbc24db.zip
Properly support png 1.5
-rw-r--r--games/ppracer/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/ppracer/Makefile b/games/ppracer/Makefile
index 572373f853f0..e08a47cfc86b 100644
--- a/games/ppracer/Makefile
+++ b/games/ppracer/Makefile
@@ -13,7 +13,7 @@ COMMENT= 3D downhill racing game... kind of like TuxRacer Improved
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USES= gmake pkgconfig dos2unix desktop-file-utils tar:bzip2
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
- -e 's|libpng12|libpng15|g' ${WRKSRC}/configure
+ -e 's|libpng12|libpng|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|RacingMode::||' ${WRKSRC}/src/racingmode.h
@${REINPLACE_CMD} -e 's|int SQHash|long SQHash|' \
${WRKSRC}/src/squirrel/squirrel.h