aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-16 02:31:10 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-16 02:31:10 +0800
commit9b661ff57f8cb93ca2ded6d85f5d3848935354f3 (patch)
tree42cbfc5e5221647ee67ba520eed1860758524c79
parent004f2a47f70474c2d86b9f2ed6fd271129aab514 (diff)
downloadfreebsd-ports-gnome-9b661ff57f8cb93ca2ded6d85f5d3848935354f3.tar.gz
freebsd-ports-gnome-9b661ff57f8cb93ca2ded6d85f5d3848935354f3.tar.zst
freebsd-ports-gnome-9b661ff57f8cb93ca2ded6d85f5d3848935354f3.zip
- Depend on bash and replace /bin/bash in the script
- Depend on gawk - Depend on wdiff PR: ports/82265, ports/82284 Submitted by: Bengt Ahlgren <bengta@sics.se>, maintainer
-rw-r--r--textproc/rfcdiff/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/textproc/rfcdiff/Makefile b/textproc/rfcdiff/Makefile
index e03e16bd2656..aaf99e88f2fc 100644
--- a/textproc/rfcdiff/Makefile
+++ b/textproc/rfcdiff/Makefile
@@ -6,6 +6,7 @@
PORTNAME= rfcdiff
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://ietf.levkowetz.com/tools/${PORTNAME}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -14,14 +15,23 @@ EXTRACT_SUFX=
MAINTAINER= lars.eggert@gmx.net
COMMENT= Compare two versions of an Internet Draft and produce a diff
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ gawk:${PORTSDIR}/lang/gawk \
+ wdiff:${PORTSDIR}/textproc/wdiff
+
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKSRC}
NO_WRKSUBDIR= YES
NO_BUILD= YES
+USE_REINPLACE= YES
PLIST_FILES= bin/rfcdiff
+post-patch:
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/${DISTNAME}
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}