aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-04-01 13:09:13 +0800
committerasami <asami@FreeBSD.org>1996-04-01 13:09:13 +0800
commit9bd66dcad6127117db423461456105def63ad22c (patch)
tree42285085b9f360b5455586bbf57ebbb087c0a2dd
parent236849ece6e2a262f33513c053e6b90f91037ea3 (diff)
downloadfreebsd-ports-gnome-9bd66dcad6127117db423461456105def63ad22c.tar.gz
freebsd-ports-gnome-9bd66dcad6127117db423461456105def63ad22c.tar.zst
freebsd-ports-gnome-9bd66dcad6127117db423461456105def63ad22c.zip
Use RUN_DEPENDS instead of EXEC_DEPENDS, as it is not (technicall) necessary
to have /usr/local/bin/gm4 just to build this port. However, the configure script would find /usr/bin/m4 if /usr/local/bin/gm4 isn't there, so tell it to use tha latter via CONFIGURE_ENV.
-rw-r--r--devel/autoconf/Makefile5
-rw-r--r--devel/autoconf213/Makefile5
-rw-r--r--devel/autoconf253/Makefile5
-rw-r--r--devel/autoconf254/Makefile5
-rw-r--r--devel/autoconf257/Makefile5
-rw-r--r--devel/autoconf259/Makefile5
-rw-r--r--devel/autoconf26/Makefile5
-rw-r--r--devel/autoconf261/Makefile5
-rw-r--r--devel/autoconf262/Makefile5
-rw-r--r--devel/autoconf267/Makefile5
-rw-r--r--devel/autoconf268/Makefile5
-rw-r--r--devel/gnu-autoconf/Makefile5
12 files changed, 36 insertions, 24 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf213/Makefile b/devel/autoconf213/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf213/Makefile
+++ b/devel/autoconf213/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf253/Makefile b/devel/autoconf253/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf253/Makefile
+++ b/devel/autoconf253/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf254/Makefile b/devel/autoconf254/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf254/Makefile
+++ b/devel/autoconf254/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf257/Makefile b/devel/autoconf257/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf257/Makefile
+++ b/devel/autoconf257/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf259/Makefile b/devel/autoconf259/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf259/Makefile
+++ b/devel/autoconf259/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf26/Makefile b/devel/autoconf26/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf26/Makefile
+++ b/devel/autoconf26/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf261/Makefile b/devel/autoconf261/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf261/Makefile
+++ b/devel/autoconf261/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf262/Makefile b/devel/autoconf262/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf262/Makefile
+++ b/devel/autoconf262/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf267/Makefile b/devel/autoconf267/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf267/Makefile
+++ b/devel/autoconf267/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/autoconf268/Makefile b/devel/autoconf268/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/autoconf268/Makefile
+++ b/devel/autoconf268/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>
diff --git a/devel/gnu-autoconf/Makefile b/devel/gnu-autoconf/Makefile
index bc47efdc3562..05b8533a1b38 100644
--- a/devel/gnu-autoconf/Makefile
+++ b/devel/gnu-autoconf/Makefile
@@ -3,17 +3,18 @@
# Date created: 7 October 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1995/12/26 00:51:47 ats Exp $
+# $Id: Makefile,v 1.6 1996/03/27 20:19:08 markm Exp $
#
DISTNAME= autoconf-2.9
CATEGORIES= devel
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
-EXEC_DEPENDS= gm4:${PORTSDIR}/devel/m4
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
MAINTAINER= torstenb@FreeBSD.ORG
GNU_CONFIGURE= yes
+CONFIGURE_ENV= M4=${PREFIX}/bin/gm4
.include <bsd.port.mk>