aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-08-03 15:26:08 +0800
committermaho <maho@FreeBSD.org>2003-08-03 15:26:08 +0800
commit9c25b790f8560d7125649095a140334e6226947c (patch)
tree68d9c5e8af01c046ddfd9678842b543e2405b0a0
parenta0b354a1b99310dd93795a163f5401d47082e07d (diff)
downloadfreebsd-ports-gnome-9c25b790f8560d7125649095a140334e6226947c.tar.gz
freebsd-ports-gnome-9c25b790f8560d7125649095a140334e6226947c.tar.zst
freebsd-ports-gnome-9c25b790f8560d7125649095a140334e6226947c.zip
an open source implementation of the SGI InventorXt library, which
Xis a GUI binding for using Open Inventor with Xt/Motif. PR: 51351 Submitted by: Roland Jesse <roland.jesse@gmx.net>
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/SoXt/Makefile28
-rw-r--r--x11-toolkits/SoXt/distinfo1
-rw-r--r--x11-toolkits/SoXt/pkg-descr13
-rw-r--r--x11-toolkits/SoXt/pkg-plist43
5 files changed, 86 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index d625fc0e9abf..356f80b0bb2c 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
#
+ SUBDIR += SoXt
SUBDIR += Xaw3d
SUBDIR += at-spi
SUBDIR += bakery
diff --git a/x11-toolkits/SoXt/Makefile b/x11-toolkits/SoXt/Makefile
new file mode 100644
index 000000000000..a8a5276aeb5c
--- /dev/null
+++ b/x11-toolkits/SoXt/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: SoXt
+# Date created: 24 April 2003
+# Whom: roland.jesse@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= SoXt
+PORTVERSION= 1.1.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.coin3d.org/pub/coin/src/
+
+MAINTAINER= roland.jesse@gmx.net
+COMMENT= GUI binding for using Open Inventor with Xt/Motif
+
+LIB_DEPENDS= Coin:${PORTSDIR}/graphics/Coin
+
+USE_MESA= yes
+USE_MOTIF= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ARGS+= --with-pthread=yes --with-coin=${X11BASE}
+# avoid renaming of soxt-config and soxt-config.1
+CONFIGURE_TARGET= --target=""
+INSTALLS_SHLIB= yes
+MAN1= soxt-config.1
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/SoXt/distinfo b/x11-toolkits/SoXt/distinfo
new file mode 100644
index 000000000000..585dbc63b3c4
--- /dev/null
+++ b/x11-toolkits/SoXt/distinfo
@@ -0,0 +1 @@
+MD5 (SoXt-1.1.0.tar.gz) = 34948e30fe4e9e6efb01c0bec75cabcb
diff --git a/x11-toolkits/SoXt/pkg-descr b/x11-toolkits/SoXt/pkg-descr
new file mode 100644
index 000000000000..d9d7ad098f9e
--- /dev/null
+++ b/x11-toolkits/SoXt/pkg-descr
@@ -0,0 +1,13 @@
+From the README:
+
+SoXt is an open source implementation of the SGI InventorXt library, which
+is a GUI binding for using Open Inventor with Xt/Motif. While SoXt has
+been developed for use with Coin, it is also possible to compile it against
+Open Inventor from SGI or TGS. A goal is to eventually become 100% source
+code compatible with the InventorXt library, which is still way off,
+especially when it comes to creating derived classes.
+
+When using SoXt, bear in mind that SoXt is in its alpha release phase,
+so expect the worst...
+
+WWW: http://www.coin3d.org/
diff --git a/x11-toolkits/SoXt/pkg-plist b/x11-toolkits/SoXt/pkg-plist
new file mode 100644
index 000000000000..d86c55d37a72
--- /dev/null
+++ b/x11-toolkits/SoXt/pkg-plist
@@ -0,0 +1,43 @@
+bin/soxt-config
+include/Inventor/Xt/devices/SoXtDevice.h
+include/Inventor/Xt/devices/SoXtKeyboard.h
+include/Inventor/Xt/devices/SoXtMouse.h
+include/Inventor/Xt/devices/SoXtSpaceball.h
+include/Inventor/Xt/devices/SoXtLinuxJoystick.h
+include/Inventor/Xt/editors/SoXtColorEditor.h
+include/Inventor/Xt/editors/SoXtMaterialEditor.h
+include/Inventor/Xt/nodes/SoGuiColorEditor.h
+include/Inventor/Xt/nodes/SoGuiMaterialEditor.h
+include/Inventor/Xt/widgets/SoXtPopupMenu.h
+include/Inventor/Xt/viewers/SoXtViewer.h
+include/Inventor/Xt/viewers/SoXtConstrainedViewer.h
+include/Inventor/Xt/viewers/SoXtFullViewer.h
+include/Inventor/Xt/viewers/SoXtExaminerViewer.h
+include/Inventor/Xt/viewers/SoXtFlyViewer.h
+include/Inventor/Xt/viewers/SoXtPlaneViewer.h
+include/Inventor/Xt/SoXtColorEditor.h
+include/Inventor/Xt/SoXtMaterialEditor.h
+include/Inventor/Xt/SoXtResource.h
+include/Inventor/Xt/SoXt.h
+include/Inventor/Xt/SoXtBasic.h
+include/Inventor/Xt/SoXtObject.h
+include/Inventor/Xt/SoXtCursor.h
+include/Inventor/Xt/SoXtComponent.h
+include/Inventor/Xt/SoXtGLWidget.h
+include/Inventor/Xt/SoXtRenderArea.h
+@dirrm include/Inventor/Xt/devices
+@dirrm include/Inventor/Xt/editors
+@dirrm include/Inventor/Xt/engines
+@dirrm include/Inventor/Xt/nodes
+@dirrm include/Inventor/Xt/viewers
+@dirrm include/Inventor/Xt/widgets
+@dirrm include/Inventor/Xt
+@dirrm include/Inventor
+lib/libSoXt.so.0
+lib/libSoXt.so
+lib/libSoXt.la
+share/aclocal/soxt.m4
+share/Coin/conf/soxt-default.cfg
+@dirrm share/Coin/conf
+@dirrm share/Coin
+