aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-10-17 23:15:07 +0800
committermarino <marino@FreeBSD.org>2016-10-17 23:15:07 +0800
commita0583c176ade13cae6cbfaea05d2f0abaab8b0eb (patch)
treeee1f4180241ebb35362eebe80259a1bbaf6133df
parentf5e29749d67a8d22e98e4d068208ef316ba769b0 (diff)
downloadfreebsd-ports-gnome-a0583c176ade13cae6cbfaea05d2f0abaab8b0eb.tar.gz
freebsd-ports-gnome-a0583c176ade13cae6cbfaea05d2f0abaab8b0eb.tar.zst
freebsd-ports-gnome-a0583c176ade13cae6cbfaea05d2f0abaab8b0eb.zip
deskutils/(py-)spice-gtk: Fix build including with gold linker
These ports starting failing on gold linker with messages like: ./.libs/libspice-client-gtk-3.0.so: error: undefined reference to 'XGetPointerControl' ./.libs/libspice-client-gtk-3.0.so: error: undefined reference to 'XChangePointerControl' The problem and fix was already described here: https://bugs.freedesktop.org/show_bug.cgi?id=97383 Apparently USES=pathfix and USES=autoreconf can't be used together, so the pkgconfig directory is now passed via MAKE_ARGS While here, fix py-spice-gtk install error by removing non-installed file from the pkg-list. Approved by: just-fix-it
-rw-r--r--deskutils/py-spice-gtk/Makefile1
-rw-r--r--deskutils/spice-gtk/Makefile8
-rw-r--r--deskutils/spice-gtk/files/patch-configure11
-rw-r--r--deskutils/spice-gtk/files/patch-configure.ac22
-rw-r--r--deskutils/spice-gtk/files/patch-src_Makefile.am18
5 files changed, 47 insertions, 13 deletions
diff --git a/deskutils/py-spice-gtk/Makefile b/deskutils/py-spice-gtk/Makefile
index 83a968f0cf13..c9dba88795dd 100644
--- a/deskutils/py-spice-gtk/Makefile
+++ b/deskutils/py-spice-gtk/Makefile
@@ -1,6 +1,7 @@
# Created by: olevole@olevole.ru
# $FreeBSD$
+PORTREVISION= 1
COMMENT= Python bindings for SPICE remote desktop servers
MASTERDIR= ${.CURDIR}/../spice-gtk
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index 0d66f9418759..9232d95225ba 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spice-gtk
PORTVERSION= 0.32
+PORTREVISION?= 0
CATEGORIES?= deskutils gnome
MASTER_SITES= http://www.spice-space.org/download/gtk/
@@ -13,7 +14,8 @@ LICENSE= GPLv2
USE_XORG= pixman
USE_GNOME= gnomeprefix gtk20 gtk30 intltool introspection:build
-USES= cpe gmake jpeg libtool pkgconfig tar:bzip2 pathfix python ssl localbase
+USES= autoreconf cpe gmake jpeg libtool pkgconfig tar:bzip2 \
+ python ssl localbase:ldflags
CPE_VENDOR= redhat
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
@@ -27,7 +29,6 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
CONFIGURE_ARGS+= --with-python
-PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
.endif
SPICE_SSL_CFLAGS= -I${OPENSSLINC}
@@ -38,6 +39,9 @@ CONFIGURE_ENV+= SSL_CFLAGS="${SPICE_SSL_CFLAGS}" SSL_LIBS="${SPICE_SSL_LIBS}" \
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+# we can't use pathfix with USES=autoreconf
+MAKE_ARGS= pkgconfigdir="$(PREFIX)/libdata/pkgconfig"
+
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= NLS DOCS SASL
diff --git a/deskutils/spice-gtk/files/patch-configure b/deskutils/spice-gtk/files/patch-configure
deleted file mode 100644
index 842a64391e8f..000000000000
--- a/deskutils/spice-gtk/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2016-02-03 17:27:02.495339000 +0100
-+++ configure 2016-02-03 17:27:23.048743000 +0100
-@@ -16074,7 +16074,7 @@
- fi
-
-
--SPICE_GLIB_REQUIRES="${SPICE_GLIB_REQUIRES} openssl"
-+#SPICE_GLIB_REQUIRES="${SPICE_GLIB_REQUIRES} openssl"
-
-
- # Check whether --with-sasl was given.
diff --git a/deskutils/spice-gtk/files/patch-configure.ac b/deskutils/spice-gtk/files/patch-configure.ac
new file mode 100644
index 000000000000..ff13861ccfd0
--- /dev/null
+++ b/deskutils/spice-gtk/files/patch-configure.ac
@@ -0,0 +1,22 @@
+--- configure.ac.orig 2016-06-16 11:34:31 UTC
++++ configure.ac
+@@ -108,7 +108,7 @@ SPICE_GLIB_REQUIRES="${SPICE_GLIB_REQUIR
+ PKG_CHECK_MODULES(SSL, openssl)
+ AC_SUBST(SSL_CFLAGS)
+ AC_SUBST(SSL_LIBS)
+-SPICE_GLIB_REQUIRES="${SPICE_GLIB_REQUIRES} openssl"
++#SPICE_GLIB_REQUIRES="${SPICE_GLIB_REQUIRES} openssl"
+
+ SPICE_CHECK_SASL
+
+@@ -163,6 +163,10 @@ AS_IF([test "x$have_win32" = "xyes"], [A
+ AM_CONDITIONAL([WITH_DISPLAY_WINDOWS], [test "x$have_win32" = "xyes"])
+
+ AC_CHECK_HEADERS([X11/XKBlib.h])
++AS_IF([test "x$have_quartz" != "xyes" && test "x$have_win32" != "xyes"],
++ [PKG_CHECK_MODULES(X11,x11)])
++AC_SUBST(X11_CFLAGS)
++AC_SUBST(X11_LIBS)
+
+ AC_ARG_WITH([pnp-ids-path],
+ AC_HELP_STRING([--with-pnp-ids-path],
diff --git a/deskutils/spice-gtk/files/patch-src_Makefile.am b/deskutils/spice-gtk/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..63850b169113
--- /dev/null
+++ b/deskutils/spice-gtk/files/patch-src_Makefile.am
@@ -0,0 +1,18 @@
+--- src/Makefile.am.orig 2016-06-20 16:42:39 UTC
++++ src/Makefile.am
+@@ -100,6 +100,7 @@ SPICE_COMMON_CPPFLAGS = \
+ $(GUDEV_CFLAGS) \
+ $(SOUP_CFLAGS) \
+ $(PHODAV_CFLAGS) \
++ $(X11_CFLAGS) \
+ $(LZ4_CFLAGS) \
+ $(NULL)
+
+@@ -119,6 +120,7 @@ SPICE_GTK_LIBADD_COMMON = \
+ libspice-client-glib-2.0.la \
+ $(GTK_LIBS) \
+ $(CAIRO_LIBS) \
++ $(X11_LIBS) \
+ $(LIBM) \
+ $(NULL)
+