aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-07 18:17:34 +0800
committerbapt <bapt@FreeBSD.org>2014-10-07 18:17:34 +0800
commita19fd302fe66dc9d321d49238301cbb63c8ad1b3 (patch)
treeda1d5eb5080bf13f727c47525d53ba6d36462ef5
parent56757cc51ccde810e44e6831e3182deed96c6500 (diff)
downloadfreebsd-ports-gnome-a19fd302fe66dc9d321d49238301cbb63c8ad1b3.tar.gz
freebsd-ports-gnome-a19fd302fe66dc9d321d49238301cbb63c8ad1b3.tar.zst
freebsd-ports-gnome-a19fd302fe66dc9d321d49238301cbb63c8ad1b3.zip
Import libodfgen01
Allow libodfgen to use c++11 shared pointed instead of boost
-rw-r--r--textproc/libodfgen/Makefile23
-rw-r--r--textproc/libodfgen/pkg-plist2
-rw-r--r--textproc/libodfgen01/Makefile35
-rw-r--r--textproc/libodfgen01/distinfo2
-rw-r--r--textproc/libodfgen01/pkg-descr11
-rw-r--r--textproc/libodfgen01/pkg-plist11
6 files changed, 72 insertions, 12 deletions
diff --git a/textproc/libodfgen/Makefile b/textproc/libodfgen/Makefile
index 1707172ffa6f..f6af408d3c8e 100644
--- a/textproc/libodfgen/Makefile
+++ b/textproc/libodfgen/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libodfgen
PORTVERSION= 0.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= SF/libwpd/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,22 +12,25 @@ COMMENT= Library for generating documents in Open Document Format (ODF)
LICENSE= LGPL21 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libetonyek-0.0.so:${PORTSDIR}/graphics/libetonyek \
libwpg-0.2.so:${PORTSDIR}/graphics/libwpg \
libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
-OPTIONS_DEFINE= DOCS
-
-CONFIGURE_ARGS= --disable-werror
+CONFIGURE_ARGS= --disable-werror --without-docs
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USES= libtool:keepla pathfix pkgconfig tar:xz
+USES= compiler:features libtool:keepla pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
-PORTDOCS= *
-DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
-DOCS_CONFIGURE_OFF= --without-docs
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS+= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+= --with-sharedptr=boost
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/libodfgen/pkg-plist b/textproc/libodfgen/pkg-plist
index f70919aa6828..a6bc83584cd0 100644
--- a/textproc/libodfgen/pkg-plist
+++ b/textproc/libodfgen/pkg-plist
@@ -8,5 +8,3 @@ lib/libodfgen-0.0.so
lib/libodfgen-0.0.so.0
lib/libodfgen-0.0.so.0.0.4
libdata/pkgconfig/libodfgen-0.0.pc
-@dirrm include/libodfgen-0.0/libodfgen
-@dirrm include/libodfgen-0.0
diff --git a/textproc/libodfgen01/Makefile b/textproc/libodfgen01/Makefile
new file mode 100644
index 000000000000..1c6242cb7b83
--- /dev/null
+++ b/textproc/libodfgen01/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= libodfgen
+PORTVERSION= 0.1.1
+CATEGORIES= textproc
+MASTER_SITES= SF/libwpd/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMESUFFIX= 01
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library for generating documents in Open Document Format (ODF)
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libetonyek-0.1.so:${PORTSDIR}/graphics/libetonyek01 \
+ librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+
+GNU_CONFIGURE= yes
+USES= compiler:features gperf libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS+= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+= --with-sharedptr=boost
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libodfgen01/distinfo b/textproc/libodfgen01/distinfo
new file mode 100644
index 000000000000..21b670f367f4
--- /dev/null
+++ b/textproc/libodfgen01/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libodfgen-0.1.1.tar.xz) = 9521e2c9aa13d84799ce476e97a6549eb9de4acd190cad357d87a540452d63dc
+SIZE (libodfgen-0.1.1.tar.xz) = 325872
diff --git a/textproc/libodfgen01/pkg-descr b/textproc/libodfgen01/pkg-descr
new file mode 100644
index 000000000000..1a74f84da3cc
--- /dev/null
+++ b/textproc/libodfgen01/pkg-descr
@@ -0,0 +1,11 @@
+libodfgen is a library for generating documents in Open Document Format
+(ODF). It provides generator implementation for the following libraries:
+
+* libwpd (::WPXDocumentInterface): text documents
+* libwpg (libwpg::WPGPaintInterface): vector drawings
+* libetonyek (libetonyek::KEYPresentationInterface): presentations
+
+As these APIs are used by multiple libraries, libodfgen can be used to
+generate ODF from many sources.
+
+WWW: http://libwpd.sourceforge.net/
diff --git a/textproc/libodfgen01/pkg-plist b/textproc/libodfgen01/pkg-plist
new file mode 100644
index 000000000000..4fd9f9944cda
--- /dev/null
+++ b/textproc/libodfgen01/pkg-plist
@@ -0,0 +1,11 @@
+include/libodfgen-0.1/libodfgen/OdfDocumentHandler.hxx
+include/libodfgen-0.1/libodfgen/OdgGenerator.hxx
+include/libodfgen-0.1/libodfgen/OdpGenerator.hxx
+include/libodfgen-0.1/libodfgen/OdtGenerator.hxx
+include/libodfgen-0.1/libodfgen/libodfgen.hxx
+include/libodfgen-0.1/libodfgen/OdsGenerator.hxx
+include/libodfgen-0.1/libodfgen/libodfgen-api.hxx
+lib/libodfgen-0.1.so
+lib/libodfgen-0.1.so.1
+lib/libodfgen-0.1.so.1.0.1
+libdata/pkgconfig/libodfgen-0.1.pc