aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-02-08 03:17:55 +0800
committerlippe <lippe@FreeBSD.org>2013-02-08 03:17:55 +0800
commita8c6b123ba76a52e0b693c9b67b3a9489af585c3 (patch)
tree8e2f20cb542f2e1940aa2d67ae26a87b16ac2e63
parent2b111ee40803e823042880178d15c383b40b0eb1 (diff)
downloadfreebsd-ports-gnome-a8c6b123ba76a52e0b693c9b67b3a9489af585c3.tar.gz
freebsd-ports-gnome-a8c6b123ba76a52e0b693c9b67b3a9489af585c3.tar.zst
freebsd-ports-gnome-a8c6b123ba76a52e0b693c9b67b3a9489af585c3.zip
- Fix Makefile to install event module recently added
- Make portlint happy PR: ports/162602, ports/173447 Submitted by: Mark Delany <z2n@delta.emu.st>, Kevin Day <kevin@your.org>
-rw-r--r--devel/st/Makefile10
-rw-r--r--devel/st/files/Makefile.main2
2 files changed, 6 insertions, 6 deletions
diff --git a/devel/st/Makefile b/devel/st/Makefile
index db9da075350e..05413f20654b 100644
--- a/devel/st/Makefile
+++ b/devel/st/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: st
-# Date created: Sun Feb 18 2001
-# Whom: tobez@tobez.org
-#
+# Created by: tobez
# $FreeBSD$
#
PORTNAME= st
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}ate-threads/${PORTNAME}ate-threads/${PORTVERSION}
@@ -30,9 +28,11 @@ post-patch:
post-install:
@${CP} ${WRKSRC}/public.h ${PREFIX}/include/st.h
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/docs/,} ${DOCSDIR}/
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/examples/,} ${EXAMPLESDIR}/
.endif
diff --git a/devel/st/files/Makefile.main b/devel/st/files/Makefile.main
index 0fe52a313489..d20460abea3a 100644
--- a/devel/st/files/Makefile.main
+++ b/devel/st/files/Makefile.main
@@ -8,7 +8,7 @@ SHLIB_MINOR= 1
LIB= st
NO_PROFILE= yes
-SRCS= io.c key.c sched.c stk.c sync.c
+SRCS= io.c key.c sched.c stk.c sync.c event.c
CFLAGS+= -DFREEBSD
.include <bsd.lib.mk>