aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-07-24 04:56:44 +0800
committermakc <makc@FreeBSD.org>2010-07-24 04:56:44 +0800
commitabacfdef7b601b5ff76d3609bc07a39a9680c3f3 (patch)
tree23a933447d18d2d3567a4d9795a2734e877db2fe
parent092a59bd405aab489a03f39a591d0aa741a14f9f (diff)
downloadfreebsd-ports-gnome-abacfdef7b601b5ff76d3609bc07a39a9680c3f3.tar.gz
freebsd-ports-gnome-abacfdef7b601b5ff76d3609bc07a39a9680c3f3.tar.zst
freebsd-ports-gnome-abacfdef7b601b5ff76d3609bc07a39a9680c3f3.zip
Avoid use of @ and Unicode in options
PR: ports/148826 Reported by: Anatoly Borodin <anatoly.borodin at gmail.com>
-rw-r--r--editors/calligra-l10n/Makefile15
-rw-r--r--editors/koffice-kde4-l10n/Makefile15
2 files changed, 14 insertions, 16 deletions
diff --git a/editors/calligra-l10n/Makefile b/editors/calligra-l10n/Makefile
index d5352591eeb1..0613cd377aba 100644
--- a/editors/calligra-l10n/Makefile
+++ b/editors/calligra-l10n/Makefile
@@ -34,22 +34,21 @@ zh_CN_PORT= chinese/koffice-kde4-l10n-zh_CN
zh_TW_PORT= chinese/koffice-kde4-l10n-zh_TW
.include <${.CURDIR}/../../misc/kde4-l10n/files/kde4-lang-names>
+nb_NAME= Norwegian Bokmal
+OPTIONS= ALL "All localizations" on
.for lang in ${KOFFICE2_LANG_ALL}
${lang}_DETECT?= ${KDE4_PREFIX}/share/locale/${lang}/LC_MESSAGES/koffice.mo
${lang}_PORT?= editors/koffice-kde4-l10n-${lang}
${lang}_NAME?= ${lang}
+${lang}_OPTION= ${lang:S/@/_/}
+OPTIONS+= ${${lang}_OPTION} "${${lang}_NAME} localization" off
.endfor
-OPTIONS= ALL "All localizations" on
-.for lang in ${KOFFICE2_LANG_ALL}
-OPTIONS+= ${lang} "${${lang}_NAME} localization" off
-.endfor
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for lang in ${KOFFICE2_LANG_ALL}
-.if defined(WITH_ALL) || defined(WITH_${lang})
+.if defined(WITH_ALL) || defined(WITH_${${lang}_OPTION})
RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
.endif
.endfor
@@ -57,4 +56,4 @@ RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
do-install:
${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/koffice-kde4-l10n/Makefile b/editors/koffice-kde4-l10n/Makefile
index d5352591eeb1..0613cd377aba 100644
--- a/editors/koffice-kde4-l10n/Makefile
+++ b/editors/koffice-kde4-l10n/Makefile
@@ -34,22 +34,21 @@ zh_CN_PORT= chinese/koffice-kde4-l10n-zh_CN
zh_TW_PORT= chinese/koffice-kde4-l10n-zh_TW
.include <${.CURDIR}/../../misc/kde4-l10n/files/kde4-lang-names>
+nb_NAME= Norwegian Bokmal
+OPTIONS= ALL "All localizations" on
.for lang in ${KOFFICE2_LANG_ALL}
${lang}_DETECT?= ${KDE4_PREFIX}/share/locale/${lang}/LC_MESSAGES/koffice.mo
${lang}_PORT?= editors/koffice-kde4-l10n-${lang}
${lang}_NAME?= ${lang}
+${lang}_OPTION= ${lang:S/@/_/}
+OPTIONS+= ${${lang}_OPTION} "${${lang}_NAME} localization" off
.endfor
-OPTIONS= ALL "All localizations" on
-.for lang in ${KOFFICE2_LANG_ALL}
-OPTIONS+= ${lang} "${${lang}_NAME} localization" off
-.endfor
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for lang in ${KOFFICE2_LANG_ALL}
-.if defined(WITH_ALL) || defined(WITH_${lang})
+.if defined(WITH_ALL) || defined(WITH_${${lang}_OPTION})
RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
.endif
.endfor
@@ -57,4 +56,4 @@ RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
do-install:
${DO_NADA}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>