aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2016-06-25 19:11:13 +0800
committerume <ume@FreeBSD.org>2016-06-25 19:11:13 +0800
commitacf17a1e5b8ffedb156ce90acfcf66963e798733 (patch)
tree885e5c74d91294e03d2a5698ada019db6baa0e55
parent8fe221d039d5b84e69eb826510e8d497fd395ba7 (diff)
downloadfreebsd-ports-gnome-acf17a1e5b8ffedb156ce90acfcf66963e798733.tar.gz
freebsd-ports-gnome-acf17a1e5b8ffedb156ce90acfcf66963e798733.tar.zst
freebsd-ports-gnome-acf17a1e5b8ffedb156ce90acfcf66963e798733.zip
Add new port -- Yubico PIV tool
The Yubico PIV tool is used for interacting with the Privilege and Identification Card (PIV) application on a YubiKey. With it you may generate keys on the device, importing keys and certificates, and create certificate requests, and other operations. A shared library and a command-line tool is included.
-rw-r--r--security/Makefile1
-rw-r--r--security/yubico-piv-tool/Makefile41
-rw-r--r--security/yubico-piv-tool/distinfo3
-rw-r--r--security/yubico-piv-tool/pkg-descr8
4 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3bb68f656dfa..c38949f20c77 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1154,6 +1154,7 @@
SUBDIR += yersinia
SUBDIR += ykclient
SUBDIR += ykpers
+ SUBDIR += yubico-piv-tool
SUBDIR += yubikey-personalization-gui
SUBDIR += zebedee
SUBDIR += zenmap
diff --git a/security/yubico-piv-tool/Makefile b/security/yubico-piv-tool/Makefile
new file mode 100644
index 000000000000..7798218b0cce
--- /dev/null
+++ b/security/yubico-piv-tool/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= yubico-piv-tool
+PORTVERSION= 1.4.0
+#PORTREVISION= 0
+CATEGORIES= security
+MASTER_SITES= https://developers.yubico.com/yubico-piv-tool/Releases/
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= Yubico PIV tool
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
+
+USES= libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= OPENSSL_CFLAGS="$(OPENSSL_CFLAGS)" \
+ OPENSSL_LIBS="-L$(OPENSSLLIB) -lcrypto"
+OPENSSL_CFLAGS=-I$(OPENSSLINC)
+
+PLIST_FILES= bin/yubico-piv-tool \
+ include/ykcs11/ykcs11-version.h \
+ include/ykpiv/ykpiv-version.h \
+ include/ykpiv/ykpiv.h \
+ lib/libykcs11.a \
+ lib/libykcs11.so \
+ lib/libykcs11.so.1 \
+ lib/libykcs11.so.1.3.2 \
+ lib/libykpiv.a \
+ lib/libykpiv.so \
+ lib/libykpiv.so.1 \
+ lib/libykpiv.so.1.3.2 \
+ libdata/pkgconfig/ykcs11.pc \
+ libdata/pkgconfig/ykpiv.pc \
+ man/man1/yubico-piv-tool.1.gz
+
+.include <bsd.port.mk>
diff --git a/security/yubico-piv-tool/distinfo b/security/yubico-piv-tool/distinfo
new file mode 100644
index 000000000000..1646d3112723
--- /dev/null
+++ b/security/yubico-piv-tool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466749908
+SHA256 (yubico-piv-tool-1.4.0.tar.gz) = 009dbea4256a7a49820962da22eb872e8d21b9126f92787a50bc896dd5d477df
+SIZE (yubico-piv-tool-1.4.0.tar.gz) = 516045
diff --git a/security/yubico-piv-tool/pkg-descr b/security/yubico-piv-tool/pkg-descr
new file mode 100644
index 000000000000..6a4983119725
--- /dev/null
+++ b/security/yubico-piv-tool/pkg-descr
@@ -0,0 +1,8 @@
+The Yubico PIV tool is used for interacting with the Privilege and
+Identification Card (PIV) application on a YubiKey.
+
+With it you may generate keys on the device, importing keys and
+certificates, and create certificate requests, and other operations. A
+shared library and a command-line tool is included.
+
+WWW: https://developers.yubico.com/yubico-piv-tool/