aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-06-19 22:20:34 +0800
committernaddy <naddy@FreeBSD.org>2003-06-19 22:20:34 +0800
commitaf7af4b9f5ee723fb0f16aa6290ed96138313aa5 (patch)
tree9f8e9658d87585392f3bed3156266334528498d5
parentc4345402e48173fd96e1e99b8e74c0631e265e42 (diff)
downloadfreebsd-ports-gnome-af7af4b9f5ee723fb0f16aa6290ed96138313aa5.tar.gz
freebsd-ports-gnome-af7af4b9f5ee723fb0f16aa6290ed96138313aa5.tar.zst
freebsd-ports-gnome-af7af4b9f5ee723fb0f16aa6290ed96138313aa5.zip
Remove check for obsolete "bs" termcap attribute which is disappearing
from new termcap entries. Reported by: Guy Middleton <guy@obstruction.com>
-rw-r--r--games/nethack34/Makefile1
-rw-r--r--games/nethack34/files/patch-ah16
2 files changed, 17 insertions, 0 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 0bd9c820320c..09ddee2c4757 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nethack
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES?= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/nethack34/files/patch-ah b/games/nethack34/files/patch-ah
new file mode 100644
index 000000000000..767df586d172
--- /dev/null
+++ b/games/nethack34/files/patch-ah
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- win/tty/termcap.c.orig Thu Jun 19 16:12:47 2003
++++ win/tty/termcap.c Thu Jun 19 16:13:00 2003
+@@ -217,10 +217,6 @@
+ error("Terminal must backspace.");
+ # else
+ if(!(BC = Tgetstr("bc"))) { /* termcap also uses bc/bs */
+-# ifndef MINIMAL_TERM
+- if(!tgetflag("bs"))
+- error("Terminal must backspace.");
+-# endif
+ BC = tbufptr;
+ tbufptr += 2;
+ *BC = '\b';