aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-11-08 03:07:07 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-11-08 03:07:07 +0800
commitb5fc7368f9c0c741d6b14e4b4e8979bb1e19b90c (patch)
tree468a0020a062d83bff8bda037b595c765744c75c
parenta7db4876ff9eaf3fcea62ef684b1b5d3771d5957 (diff)
downloadfreebsd-ports-gnome-b5fc7368f9c0c741d6b14e4b4e8979bb1e19b90c.tar.gz
freebsd-ports-gnome-b5fc7368f9c0c741d6b14e4b4e8979bb1e19b90c.tar.zst
freebsd-ports-gnome-b5fc7368f9c0c741d6b14e4b4e8979bb1e19b90c.zip
This project is an implementation of the JSON-RPC v2.0 specification
(backwards-compatible) as a client library. This version is a fork of jsonrpclib by Josh Marshall, usable with Pelix remote services. WWW: https://pypi.python.org/pypi/jsonrpclib-pelix/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jsonrpclib-pelix/Makefile18
-rw-r--r--devel/py-jsonrpclib-pelix/distinfo3
-rw-r--r--devel/py-jsonrpclib-pelix/pkg-descr5
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 395ea8cd5147..b130c0da02d6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4507,6 +4507,7 @@
SUBDIR += py-jsonpointer
SUBDIR += py-jsonref
SUBDIR += py-jsonrpclib
+ SUBDIR += py-jsonrpclib-pelix
SUBDIR += py-jsonschema
SUBDIR += py-jupyter_client
SUBDIR += py-jupyter_console
diff --git a/devel/py-jsonrpclib-pelix/Makefile b/devel/py-jsonrpclib-pelix/Makefile
new file mode 100644
index 000000000000..71d8df67d858
--- /dev/null
+++ b/devel/py-jsonrpclib-pelix/Makefile
@@ -0,0 +1,18 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jsonrpclib-pelix
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= JSON-RPC over HTTP that mirrors xmlrpclib syntax
+
+LICENSE= APACHE20
+
+USES= python:3
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-jsonrpclib-pelix/distinfo b/devel/py-jsonrpclib-pelix/distinfo
new file mode 100644
index 000000000000..491f323cfa2f
--- /dev/null
+++ b/devel/py-jsonrpclib-pelix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510069220
+SHA256 (jsonrpclib-pelix-0.3.1.tar.gz) = 5417b1508d5a50ec64f6e5b88907f111155d52607b218ff3ba9a777afb2e49e3
+SIZE (jsonrpclib-pelix-0.3.1.tar.gz) = 29997
diff --git a/devel/py-jsonrpclib-pelix/pkg-descr b/devel/py-jsonrpclib-pelix/pkg-descr
new file mode 100644
index 000000000000..a5cdcdbdefd5
--- /dev/null
+++ b/devel/py-jsonrpclib-pelix/pkg-descr
@@ -0,0 +1,5 @@
+This project is an implementation of the JSON-RPC v2.0 specification
+(backwards-compatible) as a client library. This version is a fork of jsonrpclib
+by Josh Marshall, usable with Pelix remote services.
+
+WWW: https://pypi.python.org/pypi/jsonrpclib-pelix/