aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2003-11-09 21:05:57 +0800
committerjeh <jeh@FreeBSD.org>2003-11-09 21:05:57 +0800
commitb69b94150afb27576a4b06b22ca56d37c6d796fa (patch)
treed3a8abd1c9b07e45e67b19ad9f394b78bed268c2
parent4f2af0980b232892dbdc88b53c06c24ea9a80edb (diff)
downloadfreebsd-ports-gnome-b69b94150afb27576a4b06b22ca56d37c6d796fa.tar.gz
freebsd-ports-gnome-b69b94150afb27576a4b06b22ca56d37c6d796fa.tar.zst
freebsd-ports-gnome-b69b94150afb27576a4b06b22ca56d37c6d796fa.zip
Maintainer update of port www/smarty to version Smarty-2.6.0-RC2
PR: 58684 Submitted By: MAINTAINER
-rw-r--r--www/smarty/Makefile9
-rw-r--r--www/smarty/distinfo2
-rw-r--r--www/smarty/pkg-plist24
3 files changed, 30 insertions, 5 deletions
diff --git a/www/smarty/Makefile b/www/smarty/Makefile
index bee24749dad1..b23ab21b9c10 100644
--- a/www/smarty/Makefile
+++ b/www/smarty/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= smarty
-PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTVERSION= 2.6.0.r2
CATEGORIES= www
MASTER_SITES= http://smarty.php.net/distributions/ \
http://smarty.php.net/distributions/manual/en/:manual
-DISTFILES= Smarty-${PORTVERSION}${EXTRACT_SUFX}
+DISTFILES= Smarty-${PORTVERSION:S/.r2/-RC2/}${EXTRACT_SUFX}
.if !defined(NOPORTDOCS)
DISTFILES+= Smarty-2.5.0-docs${EXTRACT_SUFX}:manual
.endif
@@ -21,7 +20,7 @@ COMMENT= The PHP compiling template engine
RUN_DEPENDS= php-config:${PORTSDIR}/www/mod_php4
-WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION}
+WRKSRC= ${WRKDIR}/Smarty-${PORTVERSION:S/.r2/-RC2/}
NO_BUILD= yes
@@ -37,6 +36,8 @@ do-install:
.for f in Config_File.class.php Smarty.class.php Smarty_Compiler.class.php debug.tpl
@${INSTALL_DATA} ${WRKSRC}/libs/$f ${DATADIR}
.endfor
+ @${MKDIR} ${DATADIR}/core
+ @${INSTALL_DATA} ${WRKSRC}/libs/core/* ${DATADIR}/core
@${MKDIR} ${DATADIR}/plugins
@${INSTALL_DATA} ${WRKSRC}/libs/plugins/* ${DATADIR}/plugins
.if !defined(NOPORTDOCS)
diff --git a/www/smarty/distinfo b/www/smarty/distinfo
index 651dda5331f9..28636d0cc8af 100644
--- a/www/smarty/distinfo
+++ b/www/smarty/distinfo
@@ -1,2 +1,2 @@
-MD5 (Smarty-2.5.0.tar.gz) = 9acb557dc4e344fadc2ab2270c74dfa2
+MD5 (Smarty-2.6.0-RC2.tar.gz) = 57e8c475d553b8128247148e0fd78cce
MD5 (Smarty-2.5.0-docs.tar.gz) = 22bd33a9b9cf497e80eb21659b4c2163
diff --git a/www/smarty/pkg-plist b/www/smarty/pkg-plist
index 3345d38f7191..0df5c45e7906 100644
--- a/www/smarty/pkg-plist
+++ b/www/smarty/pkg-plist
@@ -222,9 +222,32 @@
%%DATADIR%%/Smarty.class.php
%%DATADIR%%/Smarty_Compiler.class.php
%%DATADIR%%/debug.tpl
+%%DATADIR%%/core/core.assemble_plugin_filepath.php
+%%DATADIR%%/core/core.assign_smarty_interface.php
+%%DATADIR%%/core/core.create_dir_structure.php
+%%DATADIR%%/core/core.display_debug_console.php
+%%DATADIR%%/core/core.get_include_path.php
+%%DATADIR%%/core/core.get_microtime.php
+%%DATADIR%%/core/core.get_php_resource.php
+%%DATADIR%%/core/core.is_secure.php
+%%DATADIR%%/core/core.is_trusted.php
+%%DATADIR%%/core/core.load_plugins.php
+%%DATADIR%%/core/core.load_resource_plugin.php
+%%DATADIR%%/core/core.process_cached_inserts.php
+%%DATADIR%%/core/core.process_compiled_include.php
+%%DATADIR%%/core/core.read_cache_file.php
+%%DATADIR%%/core/core.rm_auto.php
+%%DATADIR%%/core/core.rmdir.php
+%%DATADIR%%/core/core.run_insert_handler.php
+%%DATADIR%%/core/core.smarty_include_php.php
+%%DATADIR%%/core/core.write_cache_file.php
+%%DATADIR%%/core/core.write_compiled_include.php
+%%DATADIR%%/core/core.write_compiled_resource.php
+%%DATADIR%%/core/core.write_file.php
%%DATADIR%%/plugins/block.textformat.php
%%DATADIR%%/plugins/function.assign.php
%%DATADIR%%/plugins/function.assign_debug_info.php
+%%DATADIR%%/plugins/function.config_load.php
%%DATADIR%%/plugins/function.counter.php
%%DATADIR%%/plugins/function.cycle.php
%%DATADIR%%/plugins/function.debug.php
@@ -274,5 +297,6 @@
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/templates
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/templates_c
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%/core
@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%