aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-08 04:23:56 +0800
committermm <mm@FreeBSD.org>2011-07-08 04:23:56 +0800
commitb89976e1ff5e32f3c9a0a8d3fe6d06a2767ef891 (patch)
tree4445798122d15d8b29c1c3c9da810f2503a7782a
parentcdda120ea2647fc0adfaccd0520f64df249467a9 (diff)
downloadfreebsd-ports-gnome-b89976e1ff5e32f3c9a0a8d3fe6d06a2767ef891.tar.gz
freebsd-ports-gnome-b89976e1ff5e32f3c9a0a8d3fe6d06a2767ef891.tar.zst
freebsd-ports-gnome-b89976e1ff5e32f3c9a0a8d3fe6d06a2767ef891.zip
This Horde package provides an abstracted API interface to various
IMAP4rev1 (RFC 3501) backend drivers. WWW: http://pear.horde.org
-rw-r--r--mail/Makefile1
-rw-r--r--mail/pear-Horde_Imap_Client/Makefile37
-rw-r--r--mail/pear-Horde_Imap_Client/distinfo2
-rw-r--r--mail/pear-Horde_Imap_Client/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 63c6824e3f74..c10fc0c04dfe 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -464,6 +464,7 @@
SUBDIR += pathalias
SUBDIR += pear-Contact_Vcard_Build
SUBDIR += pear-Contact_Vcard_Parse
+ SUBDIR += pear-Horde_Imap_Client
SUBDIR += pear-Horde_Mail
SUBDIR += pear-Horde_Mime
SUBDIR += pear-Horde_Mime_Viewer
diff --git a/mail/pear-Horde_Imap_Client/Makefile b/mail/pear-Horde_Imap_Client/Makefile
new file mode 100644
index 000000000000..4440d39a7ab4
--- /dev/null
+++ b/mail/pear-Horde_Imap_Client/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-Horde_Imap_Client
+# Date created: 6 July 2011
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= Horde_Imap_Client
+PORTVERSION= 1.0.9
+CATEGORIES= mail www pear
+PKGNAMEPREFIX= pear-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Horde IMAP abstraction interface
+
+OPTIONS= IMAP "Require PHP imap extension" On \
+ MBSTRING "Require PHP mbstring extension" On \
+ SASL "Support SASL Authentication" On
+
+USE_PHP= hash
+USE_HORDE_RUN= Horde_Exception Horde_Mime Horde_Util
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IMAP)
+USE_PHP+= imap
+.endif
+
+.if !defined(WITHOUT_MBSTRING)
+USE_PHP+= mbstring
+.endif
+
+.if !defined(WITHOUT_SASL)
+RUN_DEPENDS+= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/pear-Horde_Imap_Client/distinfo b/mail/pear-Horde_Imap_Client/distinfo
new file mode 100644
index 000000000000..d837022f614b
--- /dev/null
+++ b/mail/pear-Horde_Imap_Client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde/Horde_Imap_Client-1.0.9.tgz) = 1bd57f686feab63267881c59989bc4a6afeb125526b4913956c170d42e7e1638
+SIZE (Horde/Horde_Imap_Client-1.0.9.tgz) = 116680
diff --git a/mail/pear-Horde_Imap_Client/pkg-descr b/mail/pear-Horde_Imap_Client/pkg-descr
new file mode 100644
index 000000000000..70b80a3f30d1
--- /dev/null
+++ b/mail/pear-Horde_Imap_Client/pkg-descr
@@ -0,0 +1,4 @@
+This Horde package provides an abstracted API interface to various
+IMAP4rev1 (RFC 3501) backend drivers.
+
+WWW: http://pear.horde.org