aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2018-03-16 00:19:20 +0800
committeradridg <adridg@FreeBSD.org>2018-03-16 00:19:20 +0800
commitb89b23586c8044b08c2dcdc1f1d9d41f7ac9b4e8 (patch)
tree05823e92a8b8401fefb2db49db028fc143506109
parent69e5b7821b56f6e6ffb864b5953dd47d85bface5 (diff)
downloadfreebsd-ports-gnome-b89b23586c8044b08c2dcdc1f1d9d41f7ac9b4e8.tar.gz
freebsd-ports-gnome-b89b23586c8044b08c2dcdc1f1d9d41f7ac9b4e8.tar.zst
freebsd-ports-gnome-b89b23586c8044b08c2dcdc1f1d9d41f7ac9b4e8.zip
Switch qmmp to USES=libarchive
The LIB_DEPENDS line can also be satisfied by base libarchive, which then leads to problems at configure time because the CMake code looks for ports libarchive. This is hidden as long as CMake depends on the ports version of libarchive. PR: 226538 Approved by: tcberner (mentor), liangtai.s16@gmail.com (maintainer) Differential Revision: https://reviews.freebsd.org/D14655
-rw-r--r--multimedia/qmmp-qt5/Makefile3
-rw-r--r--multimedia/qmmp/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/multimedia/qmmp-qt5/Makefile b/multimedia/qmmp-qt5/Makefile
index 8493763b8491..ae698c468466 100644
--- a/multimedia/qmmp-qt5/Makefile
+++ b/multimedia/qmmp-qt5/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qmmp
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://qmmp.ylsoftware.com/files/ \
SF/qmmp-dev/${PORTNAME}/
@@ -209,7 +210,7 @@ ANALYZER_DESC= Support spectrum analyzer visualization
ANALYZER_CMAKE_BOOL= USE_ANALYZER
ARCHIVE_DESC= Read archived media file
-ARCHIVE_LIB_DEPENDS= libarchive.so:archivers/libarchive
+ARCHIVE_USES= libarchive
ARCHIVE_CMAKE_BOOL= USE_ARCHIVE
CONVERTER_DESC= Support file type converter
diff --git a/multimedia/qmmp/Makefile b/multimedia/qmmp/Makefile
index e1515f69a459..34b9c490fc75 100644
--- a/multimedia/qmmp/Makefile
+++ b/multimedia/qmmp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qmmp
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://qmmp.ylsoftware.com/files/ \
SF/qmmp-dev/${PORTNAME}/
@@ -209,7 +210,7 @@ ANALYZER_DESC= Support spectrum analyzer visualization
ANALYZER_CMAKE_BOOL= USE_ANALYZER
ARCHIVE_DESC= Read archived media file
-ARCHIVE_LIB_DEPENDS= libarchive.so:archivers/libarchive
+ARCHIVE_USES= libarchive
ARCHIVE_CMAKE_BOOL= USE_ARCHIVE
CONVERTER_DESC= Support file type converter