aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-18 18:05:48 +0800
committermarino <marino@FreeBSD.org>2013-11-18 18:05:48 +0800
commitbafcc30083fe045425dfd975f3782d3d83e37cf9 (patch)
treee8cf8263a20479b04402bbdf767eaa519a264463
parent95b13f95247445bd0d8655f5fda198968b9c9c71 (diff)
downloadfreebsd-ports-gnome-bafcc30083fe045425dfd975f3782d3d83e37cf9.tar.gz
freebsd-ports-gnome-bafcc30083fe045425dfd975f3782d3d83e37cf9.tar.zst
freebsd-ports-gnome-bafcc30083fe045425dfd975f3782d3d83e37cf9.zip
graphics/zbar: Unbreak on F10 and DragonFly
PR: ports/183572 Submitted by: marino Approved by: Oliver Heesakkers (maintainer, modified)
-rw-r--r--graphics/zbar/Makefile11
-rw-r--r--graphics/zbar/files/patch-configure10
2 files changed, 14 insertions, 7 deletions
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index 8ac2cc142e1a..3d682c1b7730 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -12,10 +12,14 @@ COMMENT= ZBar barcode reader
LICENSE= LGPL21
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= iconv gmake pkgconfig
+CONFIGURE_ARGS= --with-jpeg=yes
+
OPTIONS_DEFINE= X11 IMAGEMAGICK V4L PYTHON GTK2 QT4
OPTIONS_DEFAULT= X11 IMAGEMAGICK
V4L_DESC= Build zbarcam video scanner
@@ -23,13 +27,6 @@ V4L_DESC= Build zbarcam video scanner
NO_STAGE= yes
.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/lib/libjpeg.so)
-CONFIGURE_ARGS+= --with-jpeg=yes
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
-.else
-CONFIGURE_ARGS+= --with-jpeg=no
-.endif
-
.if ${PORT_OPTIONS:MX11}
USE_XORG= ice sm x11 xau xcb xdmcp xext xv
CONFIGURE_ARGS+= --with-x=yes
diff --git a/graphics/zbar/files/patch-configure b/graphics/zbar/files/patch-configure
new file mode 100644
index 000000000000..506e478abe9e
--- /dev/null
+++ b/graphics/zbar/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2009-10-23 18:17:24.000000000 +0000
++++ configure
+@@ -21369,6 +21369,7 @@ if test "x$ac_cv_lib_jpeg_jpeg_read_head
+ #define HAVE_LIBJPEG 1
+ _ACEOF
+
++ have_jpeg="yes"
+ LIBS="-ljpeg $LIBS"
+
+ else