aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-31 19:56:17 +0800
committeraz <az@FreeBSD.org>2013-07-31 19:56:17 +0800
commitbdf441a301bf87d593e86acea1f474e6232479c1 (patch)
tree44a97c66747f24c5fab92020a97ab60bb4e93db7
parentfc92a75e275451c4dc21ae4719d43e87ecca2d85 (diff)
downloadfreebsd-ports-gnome-bdf441a301bf87d593e86acea1f474e6232479c1.tar.gz
freebsd-ports-gnome-bdf441a301bf87d593e86acea1f474e6232479c1.tar.zst
freebsd-ports-gnome-bdf441a301bf87d593e86acea1f474e6232479c1.zip
- Convert to new perl framework
- Trim Makefile header
-rw-r--r--french/facturier/Makefile9
-rw-r--r--ftp/p5-File-Fetch/Makefile3
-rw-r--r--ftp/p5-Net-FTPSSL/Makefile9
-rw-r--r--ftp/p5-Net-FTPServer/Makefile3
-rw-r--r--ftp/p5-POE-Component-Client-FTP/Makefile3
-rw-r--r--ftp/paraget/Makefile10
-rw-r--r--ftp/profxp/Makefile4
-rw-r--r--ftp/wzdftpd/Makefile2
-rw-r--r--korean/baekmukfonts-bdf/Makefile3
-rw-r--r--korean/eterm/Makefile3
-rw-r--r--korean/gtkcomm/Makefile3
-rw-r--r--news/grn/Makefile3
-rw-r--r--news/nzbperl/Makefile9
-rw-r--r--news/p5-News-Article/Makefile3
-rw-r--r--news/p5-News-Newsrc/Makefile3
-rw-r--r--news/p5-POE-Component-Client-NNTP/Makefile9
-rw-r--r--news/p5-POE-Component-Server-NNTP/Makefile3
-rw-r--r--news/plor/Makefile8
18 files changed, 38 insertions, 52 deletions
diff --git a/french/facturier/Makefile b/french/facturier/Makefile
index 09a5eed64c11..357936d63094 100644
--- a/french/facturier/Makefile
+++ b/french/facturier/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: facturier
-# Date created: 30 January 2003
-# Whom: Thierry Thomas <thierry@pompo.net>
-#
+# Created by: Thierry Thomas <thierry@pompo.net>
# $FreeBSD$
-#
PORTNAME= facturier
PORTVERSION= 2.1.2
@@ -23,8 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/htmldoc:${PORTSDIR}/textproc/htmldoc \
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
+USES= perl5
USE_APACHE_RUN= 22+
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_MYSQL= yes
SUB_FILES= pkg-deinstall
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 34c829280272..830d3ed79c6e 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -13,7 +13,8 @@ COMMENT= Generic file fetching mechanism
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Fetch.3
diff --git a/ftp/p5-Net-FTPSSL/Makefile b/ftp/p5-Net-FTPSSL/Makefile
index 19fc9400af56..1530ee40ff96 100644
--- a/ftp/p5-Net-FTPSSL/Makefile
+++ b/ftp/p5-Net-FTPSSL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-FTPSSL
-# Date created: 1st Dec, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-FTPSSL
PORTVERSION= 0.22
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-IO-Socket-SSL>=1.08:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTPSSL.3
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index b0f9d1ef8cfd..da1981a6fafa 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
BUILD_DEPENDS:= ${RUN_DEPENDS}
MAKE_ENV+= NOCONF=1
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
SUB_FILES= pkg-message
diff --git a/ftp/p5-POE-Component-Client-FTP/Makefile b/ftp/p5-POE-Component-Client-FTP/Makefile
index 2e1366a3d87e..c76a2a83bc05 100644
--- a/ftp/p5-POE-Component-Client-FTP/Makefile
+++ b/ftp/p5-POE-Component-Client-FTP/Makefile
@@ -13,7 +13,8 @@ COMMENT= Implements an FTP client POE Component
BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV= PERL_MM_USE_DEFAULT=yes
MAN3= POE::Component::Client::FTP.3
diff --git a/ftp/paraget/Makefile b/ftp/paraget/Makefile
index 6aeabe81a4e9..ea6efc3c2169 100644
--- a/ftp/paraget/Makefile
+++ b/ftp/paraget/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: paraget
-# Date created: Apr 18, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= paraget
PORTVERSION= 0.3.0
@@ -20,7 +15,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= paraget.1
diff --git a/ftp/profxp/Makefile b/ftp/profxp/Makefile
index 9206db9334e0..96484f76353d 100644
--- a/ftp/profxp/Makefile
+++ b/ftp/profxp/Makefile
@@ -11,15 +11,13 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:S/p/-pre/}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= FXP (server-to-server FTP) client
-USE_PERL5= yes
-
RUN_DEPENDS= p5-SOCKS>=0:${PORTSDIR}/net/p5-Socks \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= profxpv3.pl
perl_OLD_CMD= /home/tom/ActivePerl-5.6/bin/perl
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 86a71c330b27..9768578de99e 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -70,7 +70,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
MAN3+= wzdftpd.3
PLIST_SUB+= PERL=""
diff --git a/korean/baekmukfonts-bdf/Makefile b/korean/baekmukfonts-bdf/Makefile
index fa78215de323..f25799b297e2 100644
--- a/korean/baekmukfonts-bdf/Makefile
+++ b/korean/baekmukfonts-bdf/Makefile
@@ -37,7 +37,8 @@ CHARSETSUB= s/ksx1001.1997/ksc5601.1987/g
FONTSDIR= lib/X11/fonts/local
MAKE_ENV= FONTSDIR=${FONTSDIR}
PLIST_SUB= FONTSDIR=${FONTSDIR}
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
# manually install hinted fonts
do-configure:
diff --git a/korean/eterm/Makefile b/korean/eterm/Makefile
index a462b84a2f4e..031b655e6a3c 100644
--- a/korean/eterm/Makefile
+++ b/korean/eterm/Makefile
@@ -14,12 +14,13 @@ COMMENT= X11 terminal emulator based on rxvt/xterm that supports korean
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/local/hmm12.pcf.gz:${PORTSDIR}/korean/hanyangfonts
+USES= perl5
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_XORG= x11 xext ice sm xt
USE_GNOME= imlib
USE_LDCONFIG= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" LOCALBASE="${LOCALBASE}"
MAN1= Eterm.1
diff --git a/korean/gtkcomm/Makefile b/korean/gtkcomm/Makefile
index 82ed99cacc61..d10a4d13ecd2 100644
--- a/korean/gtkcomm/Makefile
+++ b/korean/gtkcomm/Makefile
@@ -14,7 +14,8 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/local/gulim12.pcf.gz:${PORTSDIR}/korean/baekmukfonts-bdf
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
USE_GNOME= glib20 gtk20
GNU_CONFIGURE= yes
diff --git a/news/grn/Makefile b/news/grn/Makefile
index c5d370410b05..394c0caabec9 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A NNTP client for Gnome
USE_BZIP2= yes
-USE_PERL5= yes
-USES= pathfix
+USES= pathfix perl5
USE_GNOME= gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/news/nzbperl/Makefile b/news/nzbperl/Makefile
index 7432448c2cce..f858a40d12cf 100644
--- a/news/nzbperl/Makefile
+++ b/news/nzbperl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nzbperl
-# Date created: 20 May 2006
-# Whom: Tim Welch <ports@thepentagon.org>
-#
+# Created by: Tim Welch <ports@thepentagon.org>
# $FreeBSD$
-#
PORTNAME= nzbperl
PORTVERSION= 0.6.8
@@ -24,7 +20,8 @@ RUN_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
PLIST_FILES= bin/nzbperl
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.if defined(WITH_SSL)
RUN_DEPENDS+= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
diff --git a/news/p5-News-Article/Makefile b/news/p5-News-Article/Makefile
index 3dced38218cf..1a7478e7deba 100644
--- a/news/p5-News-Article/Makefile
+++ b/news/p5-News-Article/Makefile
@@ -14,7 +14,8 @@ COMMENT= Object for handling Usenet articles in mail or news form
BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Article.3 News::AutoReply.3 News::FormArticle.3 \
News::FormReply.3
diff --git a/news/p5-News-Newsrc/Makefile b/news/p5-News-Newsrc/Makefile
index aab2e332d1ef..22f66d8fbe73 100644
--- a/news/p5-News-Newsrc/Makefile
+++ b/news/p5-News-Newsrc/Makefile
@@ -13,7 +13,8 @@ COMMENT= Manage newsrc files
BUILD_DEPENDS= p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= News::Newsrc.3
diff --git a/news/p5-POE-Component-Client-NNTP/Makefile b/news/p5-POE-Component-Client-NNTP/Makefile
index ec4c784fc6fa..ac5fa3deadaf 100644
--- a/news/p5-POE-Component-Client-NNTP/Makefile
+++ b/news/p5-POE-Component-Client-NNTP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: POE-Component-Client-NNTP
-# Date created: 17 October 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= POE-Component-Client-NNTP
PORTVERSION= 2.22
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-POE>=0.999.9:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS= p5-POE>=0.999.9:${PORTSDIR}/devel/p5-POE \
p5-POE-Component-Pluggable>=0.03:${PORTSDIR}/devel/p5-POE-Component-Pluggable
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Client::NNTP.3 \
POE::Component::Client::NNTP::Constants.3
diff --git a/news/p5-POE-Component-Server-NNTP/Makefile b/news/p5-POE-Component-Server-NNTP/Makefile
index 81c26cd437cc..c8824e44d06a 100644
--- a/news/p5-POE-Component-Server-NNTP/Makefile
+++ b/news/p5-POE-Component-Server-NNTP/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-POE>=0.38:${PORTSDIR}/devel/p5-POE \
p5-POE-Component-Pluggable>=0.03:${PORTSDIR}/devel/p5-POE-Component-Pluggable \
p5-POE-Component-Client-NNTP>=1.05:${PORTSDIR}/news/p5-POE-Component-Client-NNTP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Server::NNTP.3 \
POE::Component::Server::NNTP::Constants.3
diff --git a/news/plor/Makefile b/news/plor/Makefile
index 5a1ffbb93432..5ec650f86de9 100644
--- a/news/plor/Makefile
+++ b/news/plor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plor
-# Date Created: 30 Dec 1996
-# Whom: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
-#
+# Created by: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
# $FreeBSD$
-#
PORTNAME= plor
PORTVERSION= 0.3.3
@@ -19,7 +15,7 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= plor.1