aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2002-11-04 02:28:40 +0800
committervanilla <vanilla@FreeBSD.org>2002-11-04 02:28:40 +0800
commitbe0ce6a5cbb26d31171208e64e41825f4b24dcff (patch)
treea99812105b1dda640e1e0e31070973de97588a69
parentce2cd75646fe64f9ea1c10e5cdce876dad65cb69 (diff)
downloadfreebsd-ports-gnome-be0ce6a5cbb26d31171208e64e41825f4b24dcff.tar.gz
freebsd-ports-gnome-be0ce6a5cbb26d31171208e64e41825f4b24dcff.tar.zst
freebsd-ports-gnome-be0ce6a5cbb26d31171208e64e41825f4b24dcff.zip
fix ${PERL} on -current.
Submitted by: bento
-rw-r--r--security/xinetd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index a7d87a8372d0..92f1f097f09d 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://www.xinetd.org/
MAINTAINER= vanilla@FreeBSD.org
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= build
@@ -29,7 +30,7 @@ EXTRA_PATCHES!= ${ECHO_CMD} ${PKGDIR}/files.5/patch-*
post-patch:
${FIND} ${WRKSRC}/libs/src -name Makefile.in | ${XARGS} \
- ${PERL} -pi -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
+ ${REINPLACE_CMD} -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
@${SED} 's|%%PREFIX%%|${PREFIX}|g' < ${WRKSRC}/xinetd/xconfig.h \
> ${WRKSRC}/xinetd/xconfig.h.new
@${MV} ${WRKSRC}/xinetd/xconfig.h.new ${WRKSRC}/xinetd/xconfig.h