aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-06-24 23:41:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-06-24 23:41:52 +0800
commitbfc8209b19014aea0620458ab9aa4fd55c117aa6 (patch)
tree836b57ec8a2175b0bb6004dedc98dc6ceeae5605
parent4d3fc3a6ab436b28c202da4ab6874d7b80376c3e (diff)
downloadfreebsd-ports-gnome-bfc8209b19014aea0620458ab9aa4fd55c117aa6.tar.gz
freebsd-ports-gnome-bfc8209b19014aea0620458ab9aa4fd55c117aa6.tar.zst
freebsd-ports-gnome-bfc8209b19014aea0620458ab9aa4fd55c117aa6.zip
Fix build of slave port databases/luasql-firebird
-rw-r--r--databases/luasql-mysql/Makefile3
-rw-r--r--databases/luasql-mysql/files/patch-src_ls__firebird.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/databases/luasql-mysql/Makefile b/databases/luasql-mysql/Makefile
index a3b08cc7911e..dcf2d325050b 100644
--- a/databases/luasql-mysql/Makefile
+++ b/databases/luasql-mysql/Makefile
@@ -16,7 +16,8 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= keplerproject
-USES= lua gmake
+USES= lua gmake dos2unix
+DOS2UNIX_FILES= src/*.c
ALL_TARGET= ${LUASQL_DRIVER}
LUASQL_DRIVER?= mysql
diff --git a/databases/luasql-mysql/files/patch-src_ls__firebird.c b/databases/luasql-mysql/files/patch-src_ls__firebird.c
new file mode 100644
index 000000000000..39c9a40712fe
--- /dev/null
+++ b/databases/luasql-mysql/files/patch-src_ls__firebird.c
@@ -0,0 +1,11 @@
+--- src/ls_firebird.c.orig 2016-06-24 14:06:19 UTC
++++ src/ls_firebird.c
+@@ -6,7 +6,7 @@
+
+ #include <ibase.h> /* The Firebird API*/
+ #include <time.h> /* For managing time values */
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ /* Lua API */