diff options
author | dvl <dvl@FreeBSD.org> | 2017-05-20 10:27:45 +0800 |
---|---|---|
committer | dvl <dvl@FreeBSD.org> | 2017-05-20 10:27:45 +0800 |
commit | c060476057a87f214117c6c9b04088e8cda97abe (patch) | |
tree | 84357ac2d921b45cd5cf844c1c973cd46511cf5c | |
parent | 1114323720189f94693f9d3452b3431160fa3636 (diff) | |
download | freebsd-ports-gnome-c060476057a87f214117c6c9b04088e8cda97abe.tar.gz freebsd-ports-gnome-c060476057a87f214117c6c9b04088e8cda97abe.tar.zst freebsd-ports-gnome-c060476057a87f214117c6c9b04088e8cda97abe.zip |
A pure Unix shell script implementing ACME client protocol
Differential Revision: https://reviews.freebsd.org/D10308
-rw-r--r-- | GIDs | 2 | ||||
-rw-r--r-- | UIDs | 2 | ||||
-rw-r--r-- | security/Makefile | 1 | ||||
-rw-r--r-- | security/acme.sh/Makefile | 42 | ||||
-rw-r--r-- | security/acme.sh/distinfo | 3 | ||||
-rw-r--r-- | security/acme.sh/pkg-descr | 13 |
6 files changed, 61 insertions, 2 deletions
@@ -110,7 +110,7 @@ uwsgi:*:165: yule:*:166: ceph:*:167: # free: 168 -# free: 169 +acme:*:169: tile38:*:170: sfs:*:171: agk:*:172: @@ -115,7 +115,7 @@ uwsgi:*:165:165::0:0:uwsgi Daemon:/nonexistent:/usr/sbin/nologin yule:*:166:166::0:0:Samhain Daemon:/nonexistent:/usr/sbin/nologin ceph:*:167:167::0:0:Ceph Daemons:/var/lib/ceph:/usr/sbin/nologin # free: 168 -# free: 169 +acme:*:169:169::0:0:ACME protocol client:/var/db/acme:/bin/sh tile38:*:170:170::0:0:Tile38 User:/var/db/tile38:/usr/sbin/nologin sfs:*:171:171::0:0:Self-Certifying File System:/nonexistent:/usr/sbin/nologin agk:*:172:172::0:0:AquaGateKeeper:/nonexistent:/nonexistent diff --git a/security/Makefile b/security/Makefile index 1efe9c9eb631..2beec4eab124 100644 --- a/security/Makefile +++ b/security/Makefile @@ -9,6 +9,7 @@ SUBDIR += R-cran-ROAuth SUBDIR += R-cran-digest SUBDIR += R-cran-openssl + SUBDIR += acme.sh SUBDIR += acmetool SUBDIR += acme-client SUBDIR += aescrypt diff --git a/security/acme.sh/Makefile b/security/acme.sh/Makefile new file mode 100644 index 000000000000..fdd87af4848c --- /dev/null +++ b/security/acme.sh/Makefile @@ -0,0 +1,42 @@ +# $FreeBSD$ + +PORTNAME= acme.sh +PORTVERSION= 2.6.9 +DISTVERSIONPREFIX= v +CATEGORIES= security + +MAINTAINER= dvl@FreeBSD.org +COMMENT= ACME protocol client written in shell + +LICENSE= GPLv3+ + +RUN_DEPENDS= curl:ftp/curl + +USE_GITHUB= yes +GH_ACCOUNT= Neilpang + +USERS= acme +GROUPS= acme + +OPTIONS_DEFINE= CURL DOCS WGET +OPTIONS_DEFAULT= CURL +CURL_DESC= Add ftp/curl as a run-time dependency +WGET_DESC= Add ftp/wget as a run-time dependency + +NO_ARCH= yes +NO_BUILD= yes + +CURL_RUN_DEPENDS= curl:ftp/curl +WGET_RUN_DEPENDS= wget:ftp/wget + +PLIST_FILES= sbin/${PORTNAME} +PORTDOCS= README.md + +do-install: + ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/${PORTNAME} + +do-install-DOCS-on: + ${MKDIR} ${STAGEDIR}${DOCSDIR} + ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR} + +.include <bsd.port.mk> diff --git a/security/acme.sh/distinfo b/security/acme.sh/distinfo new file mode 100644 index 000000000000..4003f834ca30 --- /dev/null +++ b/security/acme.sh/distinfo @@ -0,0 +1,3 @@ +TIMESTAMP = 1495240079 +SHA256 (Neilpang-acme.sh-v2.6.9_GH0.tar.gz) = 7e366872c716af42dbeaaf6fcec46e2bffb5af90ecaebd812ddeb253113a93c9 +SIZE (Neilpang-acme.sh-v2.6.9_GH0.tar.gz) = 74338 diff --git a/security/acme.sh/pkg-descr b/security/acme.sh/pkg-descr new file mode 100644 index 000000000000..c5e83e96eb72 --- /dev/null +++ b/security/acme.sh/pkg-descr @@ -0,0 +1,13 @@ +ACME protocol client written in shell + +- Full ACME protocol implementation. +- Simple, powerful and very easy to use. You only need 3 minutes to learn it. +- Bash, dash and sh compatible. +- Simplest shell script for Let's Encrypt free certificate client. +- Purely written in Shell with no dependencies on python or the official Let's + Encrypt client. +- Just one script to issue, renew and install your certificates automatically. +- DOES NOT require root/sudoer access. +- Docker friendly. + +WWW: https://github.com/Neilpang/acme.sh/ |