aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:27:22 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:27:22 +0800
commitc320816067bbebb0b0f197bcee87ac7785eb832c (patch)
tree6944177e8ac080f07e5d737a57d86ca726dbcee4
parent594dc7cfdcd72c68fe2f15d879e78ef30d7cc814 (diff)
downloadfreebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.tar.gz
freebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.tar.zst
freebsd-ports-gnome-c320816067bbebb0b0f197bcee87ac7785eb832c.zip
- adoption of optionsNG
- trim historical headers Approved by: portmgr (miwi)
-rw-r--r--devel/librcc/Makefile29
-rw-r--r--devel/poco-ssl/Makefile40
-rw-r--r--devel/poco/Makefile17
3 files changed, 40 insertions, 46 deletions
diff --git a/devel/librcc/Makefile b/devel/librcc/Makefile
index 32f9966d05bf..d510d4fae003 100644
--- a/devel/librcc/Makefile
+++ b/devel/librcc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: librcc
-# Date created: 30-12-2007
-# Whom: Ulrich Spoerlein <uspoerlein@gmail.com>
-#
+# Created by: Ulrich Spoerlein <uspoerlein@gmail.com>
# $FreeBSD$
-#
PORTNAME= librcc
PORTVERSION= 0.2.9
@@ -35,15 +31,16 @@ LIBS= -L${LOCALBASE}/lib
CONFIGURE_ENV= LIBS="${LIBS}"
-OPTIONS= BDB "Translation database support" off \
- TRANSLATE "Online translation support" off \
- TOOLS "Install recode configuration utility" on \
- GTK1 "Use Gtk1 library/frontend" on \
- GTK2 "Use Gtk2 library/frontend" on
+OPTIONS_DEFINE= BDB TRANSLATE TOOLS GTK1 GTK2
+BDB_DESC= Translation database support
+TRANSLATE_DESC= Online translation support
+TOOLS_DESC= Recode configuration utility
+
+OPTIONS_DEFAULT= TOOLS GTK1 GTK2
.include <bsd.port.options.mk>
-.if defined(WITH_BDB)
+.if ${PORT_OPTIONS:MBDB}
USE_BDB= 41+
CPPFLAGS+= -I${BDB_INCLUDE_DIR}
LIBS+= -L${BDB_LIB_DIR}
@@ -52,14 +49,14 @@ CONFIGURE_ARGS+=--enable-bdb
CONFIGURE_ARGS+=--disable-bdb
.endif
-.if defined(WITH_TRANSLATE)
+.if ${PORT_OPTIONS:MTRANSLATE}
LIB_DEPENDS+= translate.0:${PORTSDIR}/textproc/libtranslate
CONFIGURE_ARGS+=--enable-libtranslate
.else
CONFIGURE_ARGS+=--disable-libtranslate
.endif
-.if defined(WITH_GTK1)
+.if ${PORT_OPTIONS:MGTK1}
USE_GNOME+= glib12 gtk12
PLIST_SUB+= WITH_GTK1=""
.else
@@ -67,7 +64,7 @@ CONFIGURE_ENV+= ac_cv_path_GTK_CONFIG=no GTK_CONFIG=no
PLIST_SUB+= WITH_GTK1="@comment "
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
PLIST_SUB+= WITH_GTK2=""
.else
@@ -75,7 +72,7 @@ CONFIGURE_ARGS+=--disable-glib2 --disable-gtk2
PLIST_SUB+= WITH_GTK2="@comment "
.endif
-.if defined(WITH_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-rcc-config
PLIST_SUB+= TOOLS=""
.else
@@ -84,7 +81,7 @@ PLIST_SUB+= TOOLS="@comment "
pre-everything::
.if ${ARCH} == "i386"
-.if defined(WITH_BDB) || defined (WITH_TRANSLATE)
+.if ${PORT_OPTIONS:MBDB) || ${PORT_OPTIONS:MTRANSLATE}
@${ECHO} 'BDB/LibTranslate support may cause breakages in depended apps on ${ARCH}'
@${ECHO} 'Use it with caution'
.endif
diff --git a/devel/poco-ssl/Makefile b/devel/poco-ssl/Makefile
index 2bcf479e49b8..2587720094fb 100644
--- a/devel/poco-ssl/Makefile
+++ b/devel/poco-ssl/Makefile
@@ -1,7 +1,4 @@
-# ex:ts=8
-# New ports collection makefile for: poco-ssl
-# Date created: Jan 28, 2007
-# Whom: wes
+# Created by: wes@FreeBSD.org
#
# $FreeBSD$
#
@@ -19,49 +16,52 @@ COMMENT= C++ Portable Components library with NetSSL and Database libraries
CONFLICTS= poco-[0-9]*
-OPTIONS= TESTS "Build testsuites" off \
- SAMPLES "Build sample programs" off \
- MYSQL "Build MySQL driver" on \
- UODBC "Build with ODBC driver" off \
- IODBC "Build with iODBC driver" on \
- SQLITE "Build SQLite driver" on
+OPTIONS_DEFINE= TEST SAMPLES MYSQL SQLITE
+SAMPLES_DESC= Build sample programs
+UODBC_DESC= Build with ODBC driver
+IODBC_DESC= Build with iODBC driver
+
+OPTIONS_RADIO= ODBC
+OPTIONS_RADIO_ODBC= UODBC IODBC
+ODBC_DESC= ODBC Driver
+
+OPTIONS_DEFAULT= MYSQL IODBC SQLITE
CONFIGURE_ARGS= --config=FreeBSD
-.if !defined(WITH_TESTS)
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MTEST}
CONFIGURE_ARGS+= --no-tests
.endif
-.if !defined(WITH_SAMPLES)
+.if ! ${PORT_OPTIONS:MSAMPLES}
CONFIGURE_ARGS+= --no-samples
.endif
#
# ODBC
#
-.if defined(WITH_UODBC) && defined(WITH_IODBC)
-IGNORE= please select either UODBC or IODBC, but not both
-.endif
-.if !defined(WITH_UODBC) && !defined(WITH_IODBC)
+.if ! ${PORT_OPTIONS:MUODBC) && ! ${PORT_OPTIONS:MIODBC}
CONFIGURE_ARGS+= --omit=Data/ODBC
.endif
-.if defined(WITH_UODBC) && !defined(WITH_IODBC)
+.if ${PORT_OPTIONS:MUODBC) && ! ${PORT_OPTIONS:MIODBC}
LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
.endif
-.if defined(WITH_IODBC) && !defined(WITH_UODBC)
+.if ${PORT_OPTIONS:MIODBC) && ! ${PORT_OPTIONS:MUODBC}
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
.else
CONFIGURE_ARGS+= --omit=Data/MySQL
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_SQLITE= yes
.else
CONFIGURE_ARGS+= --omit=Data/SQLite
diff --git a/devel/poco/Makefile b/devel/poco/Makefile
index 57ce9cce4246..aac9195c6093 100644
--- a/devel/poco/Makefile
+++ b/devel/poco/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: poco
-# Date created: Nov 30, 2006
-# Whom: wes
-#
+# Created by: wes@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= poco
PORTVERSION= 1.4.3
@@ -17,16 +12,18 @@ COMMENT= C++ Portable Components library
CONFLICTS= poco-ssl-[0-9]*
-OPTIONS= TESTS "Build testsuites" off \
- SAMPLES "Build sample programs" off
+OPTIONS_DEFINE= TEST SAMPLES
+SAMPLES_DESC= Build sample programs
CONFIGURE_ARGS= --config=FreeBSD
-.if !defined(WITH_TESTS)
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MTEST}
CONFIGURE_ARGS+= --no-tests
.endif
-.if !defined(WITH_SAMPLES)
+.if ! ${PORT_OPTIONS:MSAMPLES}
CONFIGURE_ARGS+= --no-samples
.endif