aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2007-11-03 06:55:27 +0800
committernox <nox@FreeBSD.org>2007-11-03 06:55:27 +0800
commitc35ad23e964bf1c43170cfccd3a53d6124733d60 (patch)
treea1fa19f5168dfedd349f26f99744996f5fe7370b
parent9dce8c16bfc62489a044a1a6c4d4bf2414e8a149 (diff)
downloadfreebsd-ports-gnome-c35ad23e964bf1c43170cfccd3a53d6124733d60.tar.gz
freebsd-ports-gnome-c35ad23e964bf1c43170cfccd3a53d6124733d60.tar.zst
freebsd-ports-gnome-c35ad23e964bf1c43170cfccd3a53d6124733d60.zip
Fix build with GCC 4.2
PR: ports/117576 Submitted by: nox Approved by: portmgr (linimon, pav)
-rw-r--r--net/tac_plus-libradius/Makefile4
-rw-r--r--net/tac_plus-libradius/files/patch-ab40
2 files changed, 23 insertions, 21 deletions
diff --git a/net/tac_plus-libradius/Makefile b/net/tac_plus-libradius/Makefile
index 8435367f5cfe..f2ec2ce1deb9 100644
--- a/net/tac_plus-libradius/Makefile
+++ b/net/tac_plus-libradius/Makefile
@@ -25,10 +25,6 @@ MAN1= tac_plus.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tac_plus ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/tac_plus.1 ${PREFIX}/man/man1/tac_plus.1
diff --git a/net/tac_plus-libradius/files/patch-ab b/net/tac_plus-libradius/files/patch-ab
index b8b7730892fa..1ddb87ba27df 100644
--- a/net/tac_plus-libradius/files/patch-ab
+++ b/net/tac_plus-libradius/files/patch-ab
@@ -1,17 +1,23 @@
-*** config.c Fri Mar 16 10:04:27 2001
---- ../../tac_plus.F5.0.0.alpha/config.c Sun Jan 20 19:49:48 2002
-***************
-*** 603,608 ****
---- 603,614 ----
- authen_default_method = sym_code;
- break;
- #endif
-+ #ifdef USE_RADIUS
-+ case S_radius:
-+ fprintf(stderr,"sym_code=%i, radius\n",sym_code);
-+ authen_default_method = sym_code;
-+ break;
-+ #endif
-
-
- default:
+Index: config.c
+@@ -109,7 +109,7 @@
+ static int no_user_dflt = 0; /* default if user doesn't exist */
+ static char *authen_default = NULL; /* top level authentication default */
+ static int authen_default_method = 0; /*For method check */
+-static char *nopasswd_str = "nopassword";
++char *nopasswd_str = "nopassword";
+
+ /* A host definition structure. Currently unused, but when we start
+ configuring host-specific information e.g. per-host keys, this is
+@@ -602,6 +602,12 @@
+ fprintf(stderr,"sym_code=%i, ldap\n",sym_code);
+ authen_default_method = sym_code;
+ break;
++#endif
++#ifdef USE_RADIUS
++ case S_radius:
++ fprintf(stderr,"sym_code=%i, radius\n",sym_code);
++ authen_default_method = sym_code;
++ break;
+ #endif
+
+