aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-05-27 17:04:20 +0800
committermat <mat@FreeBSD.org>2016-05-27 17:04:20 +0800
commitce581f8e32e186efb25f038575ea4b340acde0e3 (patch)
tree124f8b05f5e3e66d4f75bf7fd227ae314bfb2f16
parent87736c3b6c7f12558af5053516b06fcd3d4858ff (diff)
downloadfreebsd-ports-gnome-ce581f8e32e186efb25f038575ea4b340acde0e3.tar.gz
freebsd-ports-gnome-ce581f8e32e186efb25f038575ea4b340acde0e3.tar.zst
freebsd-ports-gnome-ce581f8e32e186efb25f038575ea4b340acde0e3.zip
Fix building with Perl 5.25.
Unescaped left brace in regex is illegal in regex. Sponsored by: Absolight
-rw-r--r--net/p5-Net-Address-Ethernet/files/patch-Makefile.PL16
-rw-r--r--net/p5-Socket-Class/files/patch-xs_sc__ssl_Makefile.PL11
-rw-r--r--www/p5-WWW-Search/files/patch-Makefile.PL16
-rw-r--r--x11-toolkits/p5-Wx/files/patch-build_Wx_build_Utils.pm11
4 files changed, 54 insertions, 0 deletions
diff --git a/net/p5-Net-Address-Ethernet/files/patch-Makefile.PL b/net/p5-Net-Address-Ethernet/files/patch-Makefile.PL
new file mode 100644
index 000000000000..3aed542d3a3c
--- /dev/null
+++ b/net/p5-Net-Address-Ethernet/files/patch-Makefile.PL
@@ -0,0 +1,16 @@
+--- Makefile.PL.orig 2016-05-26 14:56:06 UTC
++++ Makefile.PL
+@@ -33,11 +33,11 @@ if ($ENV{MTHURN_PERL_DEV})
+ {
+ warn " EEE did not find DIRFILESEP in Makefile\n";
+ } # if
+- if ($s !~ s/(pm_to_blib\(){{\@ARGV}}/$1 . '{@ARGV}'/e)
++ if ($s !~ s/(pm_to_blib\()\{\{\@ARGV\}\}/$1 . '{@ARGV}'/e)
+ {
+ warn " EEE did not find pm_to_blib@ARGV in Makefile\n";
+ } # if
+- if ($s !~ s/(from_to\s+=>\s+){{\@ARGV}}/$1 . '{@ARGV}'/e)
++ if ($s !~ s/(from_to\s+=>\s+)\{\{\@ARGV\}\}/$1 . '{@ARGV}'/e)
+ {
+ warn " EEE did not find from_to@ARGV in Makefile\n";
+ } # if
diff --git a/net/p5-Socket-Class/files/patch-xs_sc__ssl_Makefile.PL b/net/p5-Socket-Class/files/patch-xs_sc__ssl_Makefile.PL
new file mode 100644
index 000000000000..492114f22911
--- /dev/null
+++ b/net/p5-Socket-Class/files/patch-xs_sc__ssl_Makefile.PL
@@ -0,0 +1,11 @@
+--- xs/sc_ssl/Makefile.PL.orig 2012-01-20 00:08:58 UTC
++++ xs/sc_ssl/Makefile.PL
+@@ -171,7 +171,7 @@ sub build_cmodule {
+ $step = 0;
+ foreach( <$fh> ) {
+ if( $step == 0 ) {
+- if( /\s*struct st_mod_sc {/ ) {
++ if( /\s*struct st_mod_sc \{/ ) {
+ $ct1 = index( $ct, '/* !include st_mod_sc */' );
+ $ct2 = substr( $ct, $ct1 + 25 );
+ $ct1 = substr( $ct, 0, $ct1 );
diff --git a/www/p5-WWW-Search/files/patch-Makefile.PL b/www/p5-WWW-Search/files/patch-Makefile.PL
new file mode 100644
index 000000000000..9863a3655531
--- /dev/null
+++ b/www/p5-WWW-Search/files/patch-Makefile.PL
@@ -0,0 +1,16 @@
+--- Makefile.PL.orig 2015-11-28 15:17:09 UTC
++++ Makefile.PL
+@@ -116,11 +116,11 @@ if (0 && $ENV{MTHURN_PERL_DEV})
+ {
+ print " EEE did not find DIRFILESEP in Makefile\n";
+ } # if
+- if ($s !~ s/(pm_to_blib\(){{\@ARGV}}/$1 . '{@ARGV}'/e)
++ if ($s !~ s/(pm_to_blib\()\{\{\@ARGV\}\}/$1 . '{@ARGV}'/e)
+ {
+ print " EEE did not find pm_to_blib@ARGV in Makefile\n";
+ } # if
+- if ($s !~ s/(from_to\s+=>\s+){{\@ARGV}}/$1 . '{@ARGV}'/e)
++ if ($s !~ s/(from_to\s+=>\s+)\{\{\@ARGV\}\}/$1 . '{@ARGV}'/e)
+ {
+ print " EEE did not find from_to@ARGV in Makefile\n";
+ } # if
diff --git a/x11-toolkits/p5-Wx/files/patch-build_Wx_build_Utils.pm b/x11-toolkits/p5-Wx/files/patch-build_Wx_build_Utils.pm
new file mode 100644
index 000000000000..1918546da646
--- /dev/null
+++ b/x11-toolkits/p5-Wx/files/patch-build_Wx_build_Utils.pm
@@ -0,0 +1,11 @@
+--- build/Wx/build/Utils.pm.orig 2014-03-08 13:01:15 UTC
++++ build/Wx/build/Utils.pm
+@@ -107,7 +107,7 @@ sub scan_xs($$$) {
+ m/^\s*INCLUDE:\s+(.*)$/ and $file = $1 and $arr = \@xsinclude;
+ m/^\s*INCLUDE_COMMAND:\s+.*\s(\S+\.(?:xsp?|h))\s*/ and $file = $1 and
+ $arr = \@xsinclude;
+- m/^\s*\%include{([^}]+)}\s*;\s*$/ and $file = $1 and $arr = \@xsinclude;
++ m/^\s*\%include\{([^}]+)\}\s*;\s*$/ and $file = $1 and $arr = \@xsinclude;
+
+ if( defined $file ) {
+ $file = catfile( split '/', $file );