aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2009-05-17 02:21:28 +0800
committerleeym <leeym@FreeBSD.org>2009-05-17 02:21:28 +0800
commitceca475c3140c58a7fe8ce821a4a15841e2c26bc (patch)
treeb0c40fa664c0204672e6a4446b2dca5e43ae309d
parentec6fb3042d0da2d60708c9f5a2eee991e6ec6c5b (diff)
downloadfreebsd-ports-gnome-ceca475c3140c58a7fe8ce821a4a15841e2c26bc.tar.gz
freebsd-ports-gnome-ceca475c3140c58a7fe8ce821a4a15841e2c26bc.tar.zst
freebsd-ports-gnome-ceca475c3140c58a7fe8ce821a4a15841e2c26bc.zip
- update dependency
- bump PORTREVISION PR: 133845 Submitted by: leeym Approved by: maintainer timeout
-rw-r--r--devel/p5-Inline/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/p5-Inline/Makefile b/devel/p5-Inline/Makefile
index 9f05e942a5ed..1a74563dbc79 100644
--- a/devel/p5-Inline/Makefile
+++ b/devel/p5-Inline/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Inline
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Write Perl subroutines in other programming languages
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Parse-RecDescent>=1.8:${PORTSDIR}/devel/p5-Parse-RecDescent
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,4 +24,10 @@ MAN3= Inline-API.3 Inline-FAQ.3 Inline-Support.3 Inline.3 \
Inline::C-Cookbook.3 Inline::C.3 \
Inline::C::ParseRecDescent.3 Inline::C::ParseRegExp.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.09:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>