aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-10-20 23:50:12 +0800
committertj <tj@FreeBSD.org>2016-10-20 23:50:12 +0800
commitd13c01f2af44a7ec461f695132cce13daa8ae7c8 (patch)
tree7508560817b5800421cb5c741388f137403a1851
parentf308a6088e46ae79df7cb9c28a33e13eb6aceef1 (diff)
downloadfreebsd-ports-gnome-d13c01f2af44a7ec461f695132cce13daa8ae7c8.tar.gz
freebsd-ports-gnome-d13c01f2af44a7ec461f695132cce13daa8ae7c8.tar.zst
freebsd-ports-gnome-d13c01f2af44a7ec461f695132cce13daa8ae7c8.zip
New port devel/py-voluptuous
WWW: https://github.com/alecthomas/voluptuous
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-voluptuous/Makefile19
-rw-r--r--devel/py-voluptuous/distinfo3
-rw-r--r--devel/py-voluptuous/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3e5166ce7675..a775cf9ee7d5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4626,6 +4626,7 @@
SUBDIR += py-virtualenv
SUBDIR += py-virtualenv-clone
SUBDIR += py-virtualenvwrapper
+ SUBDIR += py-voluptuous
SUBDIR += py-warlock
SUBDIR += py-watchdog
SUBDIR += py-wcwidth
diff --git a/devel/py-voluptuous/Makefile b/devel/py-voluptuous/Makefile
new file mode 100644
index 000000000000..921f4e345dee
--- /dev/null
+++ b/devel/py-voluptuous/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= voluptuous
+PORTVERSION= 0.9.3
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Python data validation library
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= alecthomas
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-voluptuous/distinfo b/devel/py-voluptuous/distinfo
new file mode 100644
index 000000000000..2fa83ab5d2c3
--- /dev/null
+++ b/devel/py-voluptuous/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476978288
+SHA256 (alecthomas-voluptuous-0.9.3_GH0.tar.gz) = 8a2387caf2dc17910c3427277dfd9c2e641287c6bb8c0b9b54d814f11a8bd224
+SIZE (alecthomas-voluptuous-0.9.3_GH0.tar.gz) = 25677
diff --git a/devel/py-voluptuous/pkg-descr b/devel/py-voluptuous/pkg-descr
new file mode 100644
index 000000000000..252c4cd1ae0d
--- /dev/null
+++ b/devel/py-voluptuous/pkg-descr
@@ -0,0 +1,8 @@
+Voluptuous, despite the name, is a Python data validation library. It is
+primarily intended for validating data coming into Python as JSON, YAML, etc.
+
+It has three goals:
+
+ 1. Simplicity.
+ 2. Support for complex data structures.
+ 3. Provide useful error messages.