aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-01-20 21:11:42 +0800
committerwg <wg@FreeBSD.org>2014-01-20 21:11:42 +0800
commitd4694c5490b78421b9d2e70facb4374f39129690 (patch)
tree0c8be0f6e6ec4a1e3a98da45cbaa21eef250d164
parentc62ee63ea6f727cad052d396d44c0090e5cbf8dd (diff)
downloadfreebsd-ports-gnome-d4694c5490b78421b9d2e70facb4374f39129690.tar.gz
freebsd-ports-gnome-d4694c5490b78421b9d2e70facb4374f39129690.tar.zst
freebsd-ports-gnome-d4694c5490b78421b9d2e70facb4374f39129690.zip
devel/libgit2: fix pkgconfig file and missing dependency
PR: ports/185892 Submitted by: amdmi3
-rw-r--r--devel/libgit2/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 5fc6cfc29b9d..a499cfd12d7b 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libgit2
PORTVERSION= 0.20.0
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= wg@FreeBSD.org
@@ -17,9 +18,18 @@ GH_COMMIT= 43cb8b3
USES= cmake
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
+USE_OPENSSL= yes
PLIST_SUB= SHLIB_VER=${PORTVERSION}
+OPTIONS_DEFINE= SSH
+OPTIONS_DEFAULT=SSH
+SSH_DESC= Enable SSH support through libssh2
+
+SSH_LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
+SSH_CMAKE_ON= -DUSE_SSH=ON
+SSH_CMAKE_OFF= -DUSE_SSH=OFF
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -27,6 +37,11 @@ BROKEN= Does not install on sparc64: thread-local storage not supported
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|/pkgconfig|/../libdata/pkgconfig|" ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e "s|/pkgconfig|/../libdata/pkgconfig|; \
+ /LIBGIT2_PC_REQUIRES.*zlib/ d" ${WRKSRC}/CMakeLists.txt
+.if defined(WITH_OPENSSL_BASE)
+ @${REINPLACE_CMD} -e "/LIBGIT2_PC_REQUIRES.*openssl/ d" \
+ ${WRKSRC}/CMakeLists.txt
+.endif
.include <bsd.port.post.mk>