aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-15 02:17:14 +0800
committerpav <pav@FreeBSD.org>2005-09-15 02:17:14 +0800
commitd51ca4d908cdd3344ecff0c774dd9060c3eba0a0 (patch)
treed3a3f763b8a8e74b06a87c8f7090dc6446a69ad8
parent5ce5a267ce4292337a9cf4ff6a0554757516bceb (diff)
downloadfreebsd-ports-gnome-d51ca4d908cdd3344ecff0c774dd9060c3eba0a0.tar.gz
freebsd-ports-gnome-d51ca4d908cdd3344ecff0c774dd9060c3eba0a0.tar.zst
freebsd-ports-gnome-d51ca4d908cdd3344ecff0c774dd9060c3eba0a0.zip
- Update to 0.10.2
PR: ports/86129 Submitted by: Xavier Beaudouin <kiwi@oav.net> (maintainer)
-rw-r--r--mail/lmtpd/Makefile2
-rw-r--r--mail/lmtpd/distinfo4
-rw-r--r--mail/lmtpd/files/patch-sieve-sievelex.c22
3 files changed, 25 insertions, 3 deletions
diff --git a/mail/lmtpd/Makefile b/mail/lmtpd/Makefile
index 7b0e4e63191a..03502fba7cf8 100644
--- a/mail/lmtpd/Makefile
+++ b/mail/lmtpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lmtpd
-PORTVERSION= 0.10.1
+PORTVERSION= 0.10.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} ftp://ftp.oav.net/pll/
MASTER_SITE_SUBDIR= pll
diff --git a/mail/lmtpd/distinfo b/mail/lmtpd/distinfo
index 3979dba65417..bffd0659e8b1 100644
--- a/mail/lmtpd/distinfo
+++ b/mail/lmtpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (lmtpd-0.10.1.tar.gz) = 039b60781a16ab13a8d0029b49d31ae6
-SIZE (lmtpd-0.10.1.tar.gz) = 486199
+MD5 (lmtpd-0.10.2.tar.gz) = 6d8b8556756c820d35102755e3913639
+SIZE (lmtpd-0.10.2.tar.gz) = 486769
diff --git a/mail/lmtpd/files/patch-sieve-sievelex.c b/mail/lmtpd/files/patch-sieve-sievelex.c
new file mode 100644
index 000000000000..ff03d247d7f5
--- /dev/null
+++ b/mail/lmtpd/files/patch-sieve-sievelex.c
@@ -0,0 +1,22 @@
+--- sieve/sievelex.c.orig Mon Sep 12 10:59:53 2005
++++ sieve/sievelex.c Wed Sep 14 20:12:03 2005
+@@ -24,6 +24,8 @@
+ static char const rcsid[] UNUSED =
+ "$Id: sievelex.c,v 1.10 2005/09/12 08:59:53 lwa Exp $";
+
++#include <sys/types.h>
++
+ #define WITH_SIEVE_REGEX
+
+ #ifdef WITH_SIEVE_REGEX
+@@ -1727,8 +1729,9 @@
+
+ LOCAL int sieve_handle_test_list(struct sieve_state *state, int doit, int type) {
+ struct token Pt;
++ int value;
+ sieve_lex(state, &Pt, 0);
+- int value = (type == SIEVE_ALLOF);
++ value = (type == SIEVE_ALLOF);
+ if (Pt.op == '(') {
+ do {
+ int test = sieve_test(state, doit);