aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgpalmer <gpalmer@FreeBSD.org>1995-01-17 07:33:08 +0800
committergpalmer <gpalmer@FreeBSD.org>1995-01-17 07:33:08 +0800
commitdc54426ded3399ad3b5794465040b34eff023b24 (patch)
tree9257adef729b4dd17bacbd83eeb654577146055b
parent7a5d6b2f1b77b21ca1e47c75a421c749c3e77789 (diff)
downloadfreebsd-ports-gnome-dc54426ded3399ad3b5794465040b34eff023b24.tar.gz
freebsd-ports-gnome-dc54426ded3399ad3b5794465040b34eff023b24.tar.zst
freebsd-ports-gnome-dc54426ded3399ad3b5794465040b34eff023b24.zip
Correct a small problem in that when there isn't a checksum for that
particular file, but there is a files/md5, it reports that it failed the checksum
-rw-r--r--Mk/bsd.port.mk15
1 files changed, 11 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1a000ce78c47..7a1d1cfd1830 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.101 1995/01/11 08:53:28 asami Exp $
+# $Id: bsd.port.mk,v 1.102 1995/01/12 02:29:42 ache Exp $
#
# Please view me with 4 column tabs!
@@ -517,16 +517,23 @@ checksum: fetch
@if [ ! -f ${MD5_FILE} ]; then \
echo ">> No MD5 checksum file."; \
else \
- (cd ${DISTDIR}; \
+ (cd ${DISTDIR}; OK="true"; \
for file in ${DISTFILES}; do \
CKSUM=`${MD5} $$file | awk '{print $$4}'`; \
CKSUM2=`grep "($$file)" ${MD5_FILE} | awk '{print $$4}'`; \
- if [ "$$CKSUM" != "$$CKSUM2" ]; then \
+ if [ "$$CKSUM2" = "" ]; then \
+ echo ">> No checksum recorded for $$file"; \
+ OK="false"; \
+ elif [ "$$CKSUM" != "$$CKSUM2" ]; then \
echo ">> Checksum mismatch for $$file"; \
exit 1; \
fi; \
done); \
- echo "Checksums OK."; \
+ if [ "$$OK" = "true" ]; then \
+ echo "Checksums OK."; \
+ else \
+ echo "Checksums OK for files that have them."; \
+ fi; \
fi
.endif