aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2014-01-22 02:43:56 +0800
committerdanilo <danilo@FreeBSD.org>2014-01-22 02:43:56 +0800
commitdda74ad8461ec47c6d74d79aee44e30263729c92 (patch)
tree707724e9a347c5febd5106a671588f7a5f5205f0
parent15bc73e9c5835232b82d6c6bc98b393373d6bc9f (diff)
downloadfreebsd-ports-gnome-dda74ad8461ec47c6d74d79aee44e30263729c92.tar.gz
freebsd-ports-gnome-dda74ad8461ec47c6d74d79aee44e30263729c92.tar.zst
freebsd-ports-gnome-dda74ad8461ec47c6d74d79aee44e30263729c92.zip
- Add new port devel/jsoncpp
jsoncpp is an implementation of a JSON reader and writer in C++. PR: ports/185592 Submitted by: Johan Str?m <johan@stromnet.se>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jsoncpp/Makefile34
-rw-r--r--devel/jsoncpp/distinfo2
-rw-r--r--devel/jsoncpp/files/patch-SConstruct11
-rw-r--r--devel/jsoncpp/pkg-descr6
-rw-r--r--devel/jsoncpp/pkg-plist13
6 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5094bcc4e11b..5cc093b42bf3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -888,6 +888,7 @@
SUBDIR += jsmin
SUBDIR += json-c
SUBDIR += json-glib
+ SUBDIR += jsoncpp
SUBDIR += jtag
SUBDIR += judy
SUBDIR += jwasm
diff --git a/devel/jsoncpp/Makefile b/devel/jsoncpp/Makefile
new file mode 100644
index 000000000000..6d2d59c5b5f1
--- /dev/null
+++ b/devel/jsoncpp/Makefile
@@ -0,0 +1,34 @@
+# Created by: Johan Str??m <johna@stromnet.se>
+# $FreeBSD$
+
+PORTNAME= jsoncpp
+DISTVERSION= 0.6.0-rc2
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/jsoncpp/${DISTVERSION}
+DISTNAME= jsoncpp-src-${DISTVERSION}
+
+MAINTAINER= johan@stromnet.se
+COMMENT= JSON reader and writer library for C++
+
+LICENSE= MIT
+
+USES= dos2unix scons
+USE_LDCONFIG= yes
+
+MAKE_ARGS= platform=linux-gcc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/SConstruct
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/jsoncpp
+ (cd ${WRKSRC}/include/ && ${COPYTREE_SHARE} json/ ${STAGEDIR}${PREFIX}/include/jsoncpp/)
+ (cd ${WRKSRC}/libs/linux-gcc-FreeBSD/ && \
+ ${INSTALL_LIB} libjson_linux-gcc-FreeBSD_libmt.a \
+ ${STAGEDIR}${PREFIX}/lib/libjsoncpp.a)
+ (cd ${WRKSRC}/libs/linux-gcc-FreeBSD/ && \
+ ${INSTALL_LIB} libjson_linux-gcc-FreeBSD_libmt.so \
+ ${STAGEDIR}${PREFIX}/lib/libjsoncpp.so.0)
+ (cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -s libjsoncpp.so.0 libjsoncpp.so )
+
+.include <bsd.port.mk>
diff --git a/devel/jsoncpp/distinfo b/devel/jsoncpp/distinfo
new file mode 100644
index 000000000000..491df3d4045e
--- /dev/null
+++ b/devel/jsoncpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jsoncpp-src-0.6.0-rc2.tar.gz) = d4d193d163f520b08b9155cba978615892ca1359d77e3fb261fce2f86d09b283
+SIZE (jsoncpp-src-0.6.0-rc2.tar.gz) = 117661
diff --git a/devel/jsoncpp/files/patch-SConstruct b/devel/jsoncpp/files/patch-SConstruct
new file mode 100644
index 000000000000..4b93cd5f6bf1
--- /dev/null
+++ b/devel/jsoncpp/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- ./SConstruct.orig 2014-01-21 02:29:19.000000000 -0200
++++ ./SConstruct 2014-01-21 02:29:28.000000000 -0200
+@@ -26,7 +26,7 @@
+ if platform == 'linux-gcc':
+ CXX = 'g++' # not quite right, but env is not yet available.
+ import commands
+- version = commands.getoutput('%s -dumpversion' %CXX)
++ version = 'FreeBSD'
+ platform = 'linux-gcc-%s' %version
+ print "Using platform '%s'" %platform
+ LD_LIBRARY_PATH = os.environ.get('LD_LIBRARY_PATH', '')
diff --git a/devel/jsoncpp/pkg-descr b/devel/jsoncpp/pkg-descr
new file mode 100644
index 000000000000..c119ab31721b
--- /dev/null
+++ b/devel/jsoncpp/pkg-descr
@@ -0,0 +1,6 @@
+jsoncpp is an implementation of a JSON reader and writer in C++.
+JSON (JavaScript Object Notation) is a lightweight data-interchange format.
+It is easy for humans to read and write.
+It is easy for machines to parse and generate.
+
+WWW: http://jsoncpp.sourceforge.net/
diff --git a/devel/jsoncpp/pkg-plist b/devel/jsoncpp/pkg-plist
new file mode 100644
index 000000000000..7b1b9c31eeea
--- /dev/null
+++ b/devel/jsoncpp/pkg-plist
@@ -0,0 +1,13 @@
+lib/libjsoncpp.so.0
+lib/libjsoncpp.so
+lib/libjsoncpp.a
+include/jsoncpp/json/writer.h
+include/jsoncpp/json/json.h
+include/jsoncpp/json/forwards.h
+include/jsoncpp/json/config.h
+include/jsoncpp/json/value.h
+include/jsoncpp/json/reader.h
+include/jsoncpp/json/features.h
+include/jsoncpp/json/autolink.h
+@dirrm include/jsoncpp/json
+@dirrm include/jsoncpp