aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjacula <jacula@FreeBSD.org>2010-06-26 00:49:48 +0800
committerjacula <jacula@FreeBSD.org>2010-06-26 00:49:48 +0800
commite26e18eef5ae80016144f98f1d9312c4e70c60ea (patch)
treea5db76cab526892f3953717211f5bdab8a0eb39f
parent9d1445a4a10a65f2e0da44195a4f52c4f36eff71 (diff)
downloadfreebsd-ports-gnome-e26e18eef5ae80016144f98f1d9312c4e70c60ea.tar.gz
freebsd-ports-gnome-e26e18eef5ae80016144f98f1d9312c4e70c60ea.tar.zst
freebsd-ports-gnome-e26e18eef5ae80016144f98f1d9312c4e70c60ea.zip
LuaFileSystem is a Lua library developed to complement the
set of functions related to file systems offered by the standard Lua distribution. LuaFileSystem offers a portable way to access the underlying directory structure and file attributes. WWW: http://www.keplerproject.org/luafilesystem/index.html PR: ports/145154 Submitted by: Kelly Hays <kelly.hays@jkhfamily.org> Approved by: tabthorpe (mentor) Feature safe: yes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/luafilesystem/Makefile41
-rw-r--r--devel/luafilesystem/distinfo3
-rw-r--r--devel/luafilesystem/pkg-descr8
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 81c4e197fc47..55242853828e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -930,6 +930,7 @@
SUBDIR += lua50-posix
SUBDIR += lua50-pty
SUBDIR += luabind
+ SUBDIR += luafilesystem
SUBDIR += luajava
SUBDIR += lwp
SUBDIR += lxr
diff --git a/devel/luafilesystem/Makefile b/devel/luafilesystem/Makefile
new file mode 100644
index 000000000000..ecca22934a7b
--- /dev/null
+++ b/devel/luafilesystem/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: luafilesystem
+# Date created: 28 Mar 2010
+# Whom: Kelly Hays <kelly.hays@jkhfamily.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= luafilesystem
+PORTVERSION= 1.4.2
+CATEGORIES= devel
+MASTER_SITES= http://luaforge.net/frs/download.php/3931/
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= kelly.hays@jkhfamily.org
+COMMENT= A library to access directory structure and file attributes.
+
+LICENSE= MIT
+
+USE_LUA= 5.1
+
+PLIST_FILES= %%LUA_MODLIBDIR%%/lfs.so
+PORTDOCS= *
+
+do-build:
+ cd ${WRKSRC}/src && \
+ ${CC} -O2 -Wall -fPIC -W -Waggregate-return \
+ -Wcast-align -Wmissing-prototypes -Wnested-externs \
+ -Wshadow -Wwrite-strings -pedantic -shared \
+ -o lfs.so lfs.c -I${LUA_INCDIR}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/lfs.so ${LUA_MODLIBDIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc/us/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
+
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/luafilesystem/distinfo b/devel/luafilesystem/distinfo
new file mode 100644
index 000000000000..edd93b731946
--- /dev/null
+++ b/devel/luafilesystem/distinfo
@@ -0,0 +1,3 @@
+MD5 (luafilesystem-1.4.2.tar.gz) = 8e7b2a9b899d669280456d0f95afd961
+SHA256 (luafilesystem-1.4.2.tar.gz) = 954d19f16d5f97cbd7b09893cbad7f42af44770930f5c1caec80d0b04547121a
+SIZE (luafilesystem-1.4.2.tar.gz) = 25408
diff --git a/devel/luafilesystem/pkg-descr b/devel/luafilesystem/pkg-descr
new file mode 100644
index 000000000000..eb991eac55bb
--- /dev/null
+++ b/devel/luafilesystem/pkg-descr
@@ -0,0 +1,8 @@
+LuaFileSystem is a Lua library developed to complement the
+set of functions related to file systems offered by the
+standard Lua distribution.
+
+LuaFileSystem offers a portable way to access the underlying
+directory structure and file attributes.
+
+WWW: http://www.keplerproject.org/luafilesystem/index.html