aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-09 23:06:07 +0800
committerflz <flz@FreeBSD.org>2005-03-09 23:06:07 +0800
commite2cd298af88ad55cd8f12f204c9c85bec8527243 (patch)
tree51913c66d85d74f0d6c5ab1595b2af62b59c6a3a
parent97440f6832857c0e417292891b49150e5a75e257 (diff)
downloadfreebsd-ports-gnome-e2cd298af88ad55cd8f12f204c9c85bec8527243.tar.gz
freebsd-ports-gnome-e2cd298af88ad55cd8f12f204c9c85bec8527243.tar.zst
freebsd-ports-gnome-e2cd298af88ad55cd8f12f204c9c85bec8527243.zip
- Add vqcc-gtk 0.4.1, a LAN chat client compatible with quickChat and Vypress Chat.
PR: ports/71461 Submitted by: Saulius Menkevicius <bob@nulis.lt> Approved by: pav (mentor)
-rw-r--r--net-im/vqcc-gtk/Makefile27
-rw-r--r--net-im/vqcc-gtk/distinfo2
-rw-r--r--net-im/vqcc-gtk/pkg-descr12
-rw-r--r--net-im/vqcc-gtk/pkg-plist4
-rw-r--r--net/Makefile1
-rw-r--r--net/vqcc-gtk/Makefile27
-rw-r--r--net/vqcc-gtk/distinfo2
-rw-r--r--net/vqcc-gtk/pkg-descr12
-rw-r--r--net/vqcc-gtk/pkg-plist4
9 files changed, 91 insertions, 0 deletions
diff --git a/net-im/vqcc-gtk/Makefile b/net-im/vqcc-gtk/Makefile
new file mode 100644
index 000000000000..eaf3292df0b5
--- /dev/null
+++ b/net-im/vqcc-gtk/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: vqcc-gtk
+# Date created: 07 Sep 2004
+# Whom: Saulius Menkevicius <bob@nulis.lt>
+# $FreeBSD$
+#
+
+PORTNAME= vqcc-gtk
+PORTVERSION= 0.4.1
+CATEGORIES?= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER?= bob@nulis.lt
+COMMENT= LAN chat client compatible with quickChat and Vypress Chat (TM)
+
+LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 gnomeprefix
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}" \
+ PTHREAD_LIB="${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/net-im/vqcc-gtk/distinfo b/net-im/vqcc-gtk/distinfo
new file mode 100644
index 000000000000..5daeb4c19b1a
--- /dev/null
+++ b/net-im/vqcc-gtk/distinfo
@@ -0,0 +1,2 @@
+MD5 (vqcc-gtk-0.4.1.tar.gz) = 4205b8112281443832a381b6411bfc31
+SIZE (vqcc-gtk-0.4.1.tar.gz) = 224969
diff --git a/net-im/vqcc-gtk/pkg-descr b/net-im/vqcc-gtk/pkg-descr
new file mode 100644
index 000000000000..b6790c33104c
--- /dev/null
+++ b/net-im/vqcc-gtk/pkg-descr
@@ -0,0 +1,12 @@
+vqcc-gtk is a chat application written in C for the GTK+ toolkit, primarily
+used in small LAN's. It is based on quickChat/Vypress Chat (TM) for Windows
+(from Vypress Research) and is licensed under the GPL.
+
+The application supports both quickChat and Vypress Chat(TM) protocols and
+hopefully is compatible enough to substitute those applications when using
+Linux, FreeBSD or another *NIX desktop. You need no server to run, however
+it is not possible to communicate outside your LAN (or subnet).
+
+(From the About page)
+
+WWW: http://vqcc-gtk.sourceforge.net/
diff --git a/net-im/vqcc-gtk/pkg-plist b/net-im/vqcc-gtk/pkg-plist
new file mode 100644
index 000000000000..970b61cd0228
--- /dev/null
+++ b/net-im/vqcc-gtk/pkg-plist
@@ -0,0 +1,4 @@
+bin/vqcc-gtk
+share/gnome/applications/vqcc-gtk.desktop
+share/gnome/pixmaps/vqcc-gtk.png
+share/locale/lt/LC_MESSAGES/vqcc-gtk.mo
diff --git a/net/Makefile b/net/Makefile
index 195d89f59a32..d0e1d4cec6e0 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -807,6 +807,7 @@
SUBDIR += vnc2swf
SUBDIR += vncreflector
SUBDIR += vomit
+ SUBDIR += vqcc-gtk
SUBDIR += vtun
SUBDIR += wais
SUBDIR += wakeonlan
diff --git a/net/vqcc-gtk/Makefile b/net/vqcc-gtk/Makefile
new file mode 100644
index 000000000000..eaf3292df0b5
--- /dev/null
+++ b/net/vqcc-gtk/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: vqcc-gtk
+# Date created: 07 Sep 2004
+# Whom: Saulius Menkevicius <bob@nulis.lt>
+# $FreeBSD$
+#
+
+PORTNAME= vqcc-gtk
+PORTVERSION= 0.4.1
+CATEGORIES?= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER?= bob@nulis.lt
+COMMENT= LAN chat client compatible with quickChat and Vypress Chat (TM)
+
+LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 gnomeprefix
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}" \
+ PTHREAD_LIB="${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/net/vqcc-gtk/distinfo b/net/vqcc-gtk/distinfo
new file mode 100644
index 000000000000..5daeb4c19b1a
--- /dev/null
+++ b/net/vqcc-gtk/distinfo
@@ -0,0 +1,2 @@
+MD5 (vqcc-gtk-0.4.1.tar.gz) = 4205b8112281443832a381b6411bfc31
+SIZE (vqcc-gtk-0.4.1.tar.gz) = 224969
diff --git a/net/vqcc-gtk/pkg-descr b/net/vqcc-gtk/pkg-descr
new file mode 100644
index 000000000000..b6790c33104c
--- /dev/null
+++ b/net/vqcc-gtk/pkg-descr
@@ -0,0 +1,12 @@
+vqcc-gtk is a chat application written in C for the GTK+ toolkit, primarily
+used in small LAN's. It is based on quickChat/Vypress Chat (TM) for Windows
+(from Vypress Research) and is licensed under the GPL.
+
+The application supports both quickChat and Vypress Chat(TM) protocols and
+hopefully is compatible enough to substitute those applications when using
+Linux, FreeBSD or another *NIX desktop. You need no server to run, however
+it is not possible to communicate outside your LAN (or subnet).
+
+(From the About page)
+
+WWW: http://vqcc-gtk.sourceforge.net/
diff --git a/net/vqcc-gtk/pkg-plist b/net/vqcc-gtk/pkg-plist
new file mode 100644
index 000000000000..970b61cd0228
--- /dev/null
+++ b/net/vqcc-gtk/pkg-plist
@@ -0,0 +1,4 @@
+bin/vqcc-gtk
+share/gnome/applications/vqcc-gtk.desktop
+share/gnome/pixmaps/vqcc-gtk.png
+share/locale/lt/LC_MESSAGES/vqcc-gtk.mo