aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-18 15:13:32 +0800
committermarino <marino@FreeBSD.org>2014-10-18 15:13:32 +0800
commite3d038be72c0a57de4fa8f980c0b626b281aaaad (patch)
treec5859c866d6664551453d671a52dc7a842618208
parentb7dc436d595d7f42bbb7fcc77f5c2941124d5299 (diff)
downloadfreebsd-ports-gnome-e3d038be72c0a57de4fa8f980c0b626b281aaaad.tar.gz
freebsd-ports-gnome-e3d038be72c0a57de4fa8f980c0b626b281aaaad.tar.zst
freebsd-ports-gnome-e3d038be72c0a57de4fa8f980c0b626b281aaaad.zip
japanese/ebnetd: Remove @dirrm, use @sample, use @dir()
The stage-qa checks said 5 files needed perl shebang fixed, but USE=shebangfix won't fix it. The value of PERL was defined for the configure target to fix it. However, a run depends on perl was not added as the affected files are probably optional scripts. PR: 194367 Submitted by: maintainer (Yasuhiro KIMURA)
-rw-r--r--japanese/ebnetd/Makefile6
-rw-r--r--japanese/ebnetd/pkg-plist5
2 files changed, 7 insertions, 4 deletions
diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile
index 94f6275e4e82..ca241b18ac8a 100644
--- a/japanese/ebnetd/Makefile
+++ b/japanese/ebnetd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ebnetd
PORTVERSION= 1.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= japanese ipv6
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/
@@ -16,6 +16,7 @@ LIB_DEPENDS= libeb.so:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${RUNDIR} --with-logdir=${LOGDIR}
+CONFIGURE_ENV= PERL=${PREFIX}/bin/perl
# Local variables
LOGDIR= /var/log
@@ -27,4 +28,7 @@ PLIST_SUB= EBNETD_RUNDIR=${RUNDIR}/${PORTNAME}
INFO= ebnetd ebnetd-ja
+post-stage:
+ ${MKDIR} -m 0755 ${STAGEDIR}${RUNDIR}/${PORTNAME}
+
.include <bsd.port.mk>
diff --git a/japanese/ebnetd/pkg-plist b/japanese/ebnetd/pkg-plist
index a945439e8993..ec663f4cdc29 100644
--- a/japanese/ebnetd/pkg-plist
+++ b/japanese/ebnetd/pkg-plist
@@ -1,4 +1,4 @@
-etc/ebnetd.conf.sample
+@sample etc/ebnetd.conf.sample
libexec/ebhtstat
libexec/ebnstat
libexec/ndtpstat
@@ -13,5 +13,4 @@ sbin/ebnupgrade
sbin/ndtpcheck
sbin/ndtpcontrol
sbin/ndtpd
-@exec mkdir -m 0755 -p %%EBNETD_RUNDIR%%
-@dirrmtry %%EBNETD_RUNDIR%%
+@dir(,,0755) %%EBNETD_RUNDIR%%