aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-21 17:05:40 +0800
committerbapt <bapt@FreeBSD.org>2014-01-21 17:05:40 +0800
commite6c5662b8f7e3a0d3e11611bb8d038c772ee9aca (patch)
tree7ff1497247e25e6244aff41118ab53089f5c7dfc
parent2a07894c42d3117f3f2e9365055b6318fc716807 (diff)
downloadfreebsd-ports-gnome-e6c5662b8f7e3a0d3e11611bb8d038c772ee9aca.tar.gz
freebsd-ports-gnome-e6c5662b8f7e3a0d3e11611bb8d038c772ee9aca.tar.zst
freebsd-ports-gnome-e6c5662b8f7e3a0d3e11611bb8d038c772ee9aca.zip
Support stage
-rw-r--r--devel/tinylaf/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/devel/tinylaf/Makefile b/devel/tinylaf/Makefile
index dcf64a121e42..d9233804c619 100644
--- a/devel/tinylaf/Makefile
+++ b/devel/tinylaf/Makefile
@@ -6,11 +6,13 @@ PORTVERSION= 1.4.0
CATEGORIES= devel java
MASTER_SITES= http://www.muntjak.de/hans/java/tinylaf/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .zip
MAINTAINER= ayu@commun.jp
-COMMENT= A pluggable Look and Feel for Java
+COMMENT= Pluggable Look and Feel for Java
+
+OPTIONS_DEFINE= DOCS
-USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
@@ -19,15 +21,11 @@ JARFILE= ${PORTNAME}.jar tinycp.jar
PORTDOCS= readme.html gpl.txt lgpl.txt
PLIST_FILES= ${JARFILE:S|^|%%JAVAJARDIR%%/|}
-NO_STAGE= yes
do-install:
- ${INSTALL_DATA} ${JARFILE:S|^|${WRKSRC}/|} ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${JARFILE:S|^|${WRKSRC}/|} ${STAGEDIR}${JAVAJARDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in readme.html license/gpl.txt license/lgpl.txt
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
.include <bsd.port.mk>