aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-02-22 22:29:19 +0800
committermat <mat@FreeBSD.org>2018-02-22 22:29:19 +0800
commite93e727825580f3592821f348f43713ecb944a43 (patch)
tree51d908db8b188773415710f50470599dda06c3ad
parent57815ad50071d4c58d3252b0c8d027d9a05dd020 (diff)
downloadfreebsd-ports-gnome-e93e727825580f3592821f348f43713ecb944a43.tar.gz
freebsd-ports-gnome-e93e727825580f3592821f348f43713ecb944a43.tar.zst
freebsd-ports-gnome-e93e727825580f3592821f348f43713ecb944a43.zip
As all the acme/certbot have the same version, store it in one place.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
-rw-r--r--security/py-acme/Makefile3
-rw-r--r--security/py-acme/version.mk1
-rw-r--r--security/py-certbot/Makefile5
3 files changed, 6 insertions, 3 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index 18b831a32bf0..e4c7bbb07618 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= acme
-PORTVERSION= 0.21.1
+PORTVERSION= ${ACME_VERSION}
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -33,4 +33,5 @@ NO_ARCH= yes
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+.include "version.mk"
.include <bsd.port.mk>
diff --git a/security/py-acme/version.mk b/security/py-acme/version.mk
new file mode 100644
index 000000000000..30cb982414d3
--- /dev/null
+++ b/security/py-acme/version.mk
@@ -0,0 +1 @@
+ACME_VERSION= 0.21.1
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 40ce1e3feed5..afd118499d80 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= certbot
-PORTVERSION= 0.21.1
+PORTVERSION= ${ACME_VERSION}
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -14,7 +14,7 @@ COMMENT= Let's Encrypt client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${PORTVERSION}:security/py-acme@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=1.2:security/py-cryptography@${FLAVOR} \
@@ -42,4 +42,5 @@ post-patch:
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+.include "${.CURDIR}/../py-acme/version.mk"
.include <bsd.port.mk>