aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-09-20 02:33:02 +0800
committerpi <pi@FreeBSD.org>2014-09-20 02:33:02 +0800
commite9b2560aa32aa670b42ddf2050bae3b170003480 (patch)
tree5265b08820024b95dafd3edb66cfe1ea71cbc35f
parent029267087f9f853214d545f32e776d14af2c9488 (diff)
downloadfreebsd-ports-gnome-e9b2560aa32aa670b42ddf2050bae3b170003480.tar.gz
freebsd-ports-gnome-e9b2560aa32aa670b42ddf2050bae3b170003480.tar.zst
freebsd-ports-gnome-e9b2560aa32aa670b42ddf2050bae3b170003480.zip
www/jdresolve: fix use of p5-Net-DNS in jdresolve
PR: 192500 Submitted by: Dave Stoddard <dgs@accelix.net> Approved by: christophe@labouisse.org (maintainer timeout)
-rw-r--r--www/jdresolve/Makefile5
-rw-r--r--www/jdresolve/files/patch-jdresolve11
-rw-r--r--www/jdresolve/pkg-descr2
3 files changed, 15 insertions, 3 deletions
diff --git a/www/jdresolve/Makefile b/www/jdresolve/Makefile
index 12c5d9b7782d..6f6869a1965d 100644
--- a/www/jdresolve/Makefile
+++ b/www/jdresolve/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jdresolve
PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.jdrowell.com/projects/jdresolve/
PATCH_SITES= ${MASTER_SITES}
@@ -15,8 +15,9 @@ COMMENT= IP addresse to hostname program for httpd log files
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
+SHEBANG_FILES= jdresolve
DOC1= AUTHORS BUGS CHANGELOG COPYING CREDITS INSTALL README TODO
diff --git a/www/jdresolve/files/patch-jdresolve b/www/jdresolve/files/patch-jdresolve
new file mode 100644
index 000000000000..1f9fb96d3763
--- /dev/null
+++ b/www/jdresolve/files/patch-jdresolve
@@ -0,0 +1,11 @@
+--- jdresolve.orig 2014-09-04 21:09:39 UTC
++++ jdresolve
+@@ -857,7 +857,7 @@
+ # For each DNS answer, check the data received
+ if ($type eq 'H') {
+ if (defined $_->{ptrdname}) {
+- $hosts{$query}{NAME} = $_->{ptrdname};
++ $hosts{$query}{NAME} = join(".",@{$_->{ptrdname}->{label}});
+ $hosts{$query}{RESOLVED} = 'N';
+
+ $resolved = 1;
diff --git a/www/jdresolve/pkg-descr b/www/jdresolve/pkg-descr
index 4fc80ea668e7..f8a10218da61 100644
--- a/www/jdresolve/pkg-descr
+++ b/www/jdresolve/pkg-descr
@@ -13,4 +13,4 @@ Included is a tiny shell script called rhost to interface with
jdresolve when resolving a single IP address. Think of it as a smart
replacement for the 'host' utility that comes with bind-utils.
-WWW: http://www.jdrowell.com/archives/projects/jdresolve/index.html
+WWW: https://github.com/jdrowell/jdresolve