aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2017-02-17 14:18:55 +0800
committerrea <rea@FreeBSD.org>2017-02-17 14:18:55 +0800
commitec460568ffd32931e48ce471fbde24e6128db588 (patch)
tree2529a6dfad6a975b782e95d3c7aafcfb0559db5a
parent883a669e781ffdd19ac203684876e931da08d97b (diff)
downloadfreebsd-ports-gnome-ec460568ffd32931e48ce471fbde24e6128db588.tar.gz
freebsd-ports-gnome-ec460568ffd32931e48ce471fbde24e6128db588.tar.zst
freebsd-ports-gnome-ec460568ffd32931e48ce471fbde24e6128db588.zip
Ruby: introduce dependency on modern Doxygen
Otherwise (found with Doxygen 1.8.10) packaging list will be broken with missing entries like dir_<hexdigits>.html. Reviewed by: swills@ (part of ruby@)
-rw-r--r--lang/ruby21/Makefile2
-rw-r--r--lang/ruby22/Makefile2
-rw-r--r--lang/ruby23/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index fb340443744c..a15b6efae1e5 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -56,7 +56,7 @@ RDOC_DESC= Build and install Rdoc indexes
EDIT_DESC= Which line editing lib to use
LIBEDIT_DESC= Use libedit
READLINE_DESC= Use libreadline
-CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
+CAPIDOCS_BUILD_DEPENDS= doxygen>1.8.12,2:devel/doxygen \
dot:graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 7de9bf3c0e1c..3e3263cbeff1 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -57,7 +57,7 @@ RDOC_DESC= Build and install Rdoc indexes
EDIT_DESC= Which line editing lib to use
LIBEDIT_DESC= Use libedit
READLINE_DESC= Use libreadline
-CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
+CAPIDOCS_BUILD_DEPENDS= doxygen>1.8.12,2:devel/doxygen \
dot:graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 412babdf5925..4fb6590cfc52 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -55,7 +55,7 @@ RDOC_DESC= Build and install Rdoc indexes
EDIT_DESC= Which line editing lib to use
LIBEDIT_DESC= Use libedit
READLINE_DESC= Use libreadline
-CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
+CAPIDOCS_BUILD_DEPENDS= doxygen>1.8.12,2:devel/doxygen \
dot:graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp