aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-04-16 23:39:43 +0800
committerantoine <antoine@FreeBSD.org>2015-04-16 23:39:43 +0800
commitef603b2427ae225f62a725e7c6853bd3353257b0 (patch)
treee78d035a49b881a742558e1d2b7f6eaf6250c806
parent78321de1db6c31d250881431338cf0ccca364fa5 (diff)
downloadfreebsd-ports-gnome-ef603b2427ae225f62a725e7c6853bd3353257b0.tar.gz
freebsd-ports-gnome-ef603b2427ae225f62a725e7c6853bd3353257b0.tar.zst
freebsd-ports-gnome-ef603b2427ae225f62a725e7c6853bd3353257b0.zip
Fix build with GCC on recent head kernel by disabling PCH for GCC
With hat: portmgr
-rw-r--r--lang/phantomjs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index a3595fae0f34..46c3e68c5a89 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -25,7 +25,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/phantomjs
do-build:
- cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} OSTYPE=freebsd MAKEFLAGS= PATH=${PATH} bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm
+ cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} OSTYPE=freebsd MAKEFLAGS= PATH=${PATH} bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm \
+ --qt-config '-no-pch'
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} bin/phantomjs ${STAGEDIR}${PREFIX}/bin/