aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-01-07 21:02:01 +0800
committerwjv <wjv@FreeBSD.org>2002-01-07 21:02:01 +0800
commitefa40ffc641d2568a871ae4ba840575b6598014e (patch)
treeb727b83fe702e23b780eda2a37dce8f7ef83d902
parent3ed059169bcfde39eb4a9e24a3986831c08f83cd (diff)
downloadfreebsd-ports-gnome-efa40ffc641d2568a871ae4ba840575b6598014e.tar.gz
freebsd-ports-gnome-efa40ffc641d2568a871ae4ba840575b6598014e.tar.zst
freebsd-ports-gnome-efa40ffc641d2568a871ae4ba840575b6598014e.zip
- Add a patch for a small typo(?) which results in half the bits of a
generated UUID being trown away - Bumped PORTREVISION PR: 31508 Submitted by: Alan Eldridge <alane@geeksrus.net>
-rw-r--r--textproc/py-4suite/Makefile1
-rw-r--r--textproc/py-4suite/files/patch-Lib-Uuid.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/py-4suite/Makefile b/textproc/py-4suite/Makefile
index 4834a31ce296..f0a6276d69e4 100644
--- a/textproc/py-4suite/Makefile
+++ b/textproc/py-4suite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= 4suite
PORTVERSION= 0.11.1
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/textproc/py-4suite/files/patch-Lib-Uuid.py b/textproc/py-4suite/files/patch-Lib-Uuid.py
new file mode 100644
index 000000000000..69e40198002a
--- /dev/null
+++ b/textproc/py-4suite/files/patch-Lib-Uuid.py
@@ -0,0 +1,11 @@
+--- Lib/Uuid.py.orig Fri Aug 10 07:28:49 2001
++++ Lib/Uuid.py Mon Jan 7 14:49:45 2002
+@@ -64,7 +64,7 @@
+ newUuid = ''
+ curUuid = uuid
+ for ctr in range(16):
+- num = int(curUuid & 0xF)
++ num = int(curUuid & 0xFF)
+ newChar = chr(num)
+ curUuid = curUuid >> 8
+ newUuid = newChar + newUuid