aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-07-10 15:20:23 +0800
committersat <sat@FreeBSD.org>2007-07-10 15:20:23 +0800
commitf00cb415395042ebb78a3186ff0f8246bff1c69a (patch)
treea00e4a0a99360f09a418619ba4cb9e5fda0c3b2b
parent459cf9629dc77e8d7f8a7e90987377ebf937a9d0 (diff)
downloadfreebsd-ports-gnome-f00cb415395042ebb78a3186ff0f8246bff1c69a.tar.gz
freebsd-ports-gnome-f00cb415395042ebb78a3186ff0f8246bff1c69a.tar.zst
freebsd-ports-gnome-f00cb415395042ebb78a3186ff0f8246bff1c69a.zip
Add port devel/liblogging:
Liblogging is an easy to use, portable, open source library for system logging. WWW: http://www.liblogging.org/ Author: Rainer Gerhards <rgerhards@adiscon.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/liblogging/Makefile40
-rw-r--r--devel/liblogging/distinfo3
-rw-r--r--devel/liblogging/pkg-descr5
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6739b9c2eeda..a92ea8bbb57a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -579,6 +579,7 @@
SUBDIR += libisc
SUBDIR += libixp
SUBDIR += libleaftag
+ SUBDIR += liblogging
SUBDIR += libltdl15
SUBDIR += libmatheval
SUBDIR += libmba
diff --git a/devel/liblogging/Makefile b/devel/liblogging/Makefile
new file mode 100644
index 000000000000..2c6a3a2a15d4
--- /dev/null
+++ b/devel/liblogging/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: liblogging
+# Date created: 9 July 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblogging
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= SF http://download.adiscon.com/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Easy to use system logging library
+
+USE_DOS2UNIX= yes
+USE_LDCONFIG= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/src
+MAKEFILE= makefile
+CFLAGS+= -fPIC
+PLIST_FILES= include/${PORTNAME}.h include/${PORTNAME}-config.h include/srAPI.h \
+ include/syslogmessage.h lib/${PORTNAME}.so lib/${PORTNAME}.so.0
+
+post-extract:
+ @${MV} ${WRKSRC}/config.h ${WRKSRC}/${PORTNAME}-config.h
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|config\.h|${PORTNAME}-config.h|' ${WRKSRC}/*.[ch] \
+ ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|\.a|.so|g;s|[(]AR[)] cru|{CC} ${CFLAGS} -shared -o|'\
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTNAME}.h ${PORTNAME}-config.h \
+ srAPI.h syslogmessage.h ${PREFIX}/include/
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/lib/
+ @${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.0
+
+.include <bsd.port.mk>
diff --git a/devel/liblogging/distinfo b/devel/liblogging/distinfo
new file mode 100644
index 000000000000..281ff5202428
--- /dev/null
+++ b/devel/liblogging/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblogging-0.6.0.zip) = c01c2c674a458e56a908b96db00831d7
+SHA256 (liblogging-0.6.0.zip) = 7af82e60b67c888d0dcd8d1bf44f63800efc647f5b7482253ef44655fc837e5d
+SIZE (liblogging-0.6.0.zip) = 459139
diff --git a/devel/liblogging/pkg-descr b/devel/liblogging/pkg-descr
new file mode 100644
index 000000000000..cd568977ed94
--- /dev/null
+++ b/devel/liblogging/pkg-descr
@@ -0,0 +1,5 @@
+Liblogging is an easy to use, portable, open source library for
+system logging.
+
+WWW: http://www.liblogging.org/
+Author: Rainer Gerhards <rgerhards@adiscon.com>