aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-11-19 15:41:52 +0800
committermadpilot <madpilot@FreeBSD.org>2013-11-19 15:41:52 +0800
commitf08079d3dd06953166a1808bde1ce483da32c485 (patch)
tree02e80b68cbe56aef4a3222a79d340051a999e491
parent0cbb4df10cf37d11f65374b48e5766adf5c35ecc (diff)
downloadfreebsd-ports-gnome-f08079d3dd06953166a1808bde1ce483da32c485.tar.gz
freebsd-ports-gnome-f08079d3dd06953166a1808bde1ce483da32c485.tar.zst
freebsd-ports-gnome-f08079d3dd06953166a1808bde1ce483da32c485.zip
- Update to 1.13
- Various cleanups PR: ports/181886 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
-rw-r--r--games/mahjong/Makefile32
-rw-r--r--games/mahjong/distinfo4
-rw-r--r--games/mahjong/pkg-descr10
3 files changed, 24 insertions, 22 deletions
diff --git a/games/mahjong/Makefile b/games/mahjong/Makefile
index 55beb355a86f..0197b6db0e04 100644
--- a/games/mahjong/Makefile
+++ b/games/mahjong/Makefile
@@ -2,32 +2,29 @@
# $FreeBSD$
PORTNAME= mahjong
-PORTVERSION= 1.12.1
-PORTREVISION= 1
+PORTVERSION= 1.13
CATEGORIES= games net
MASTER_SITES= http://mahjong.julianbradfield.org/Source/%SUBDIR%/
MASTER_SITE_SUBDIR= . Old
DISTNAME= mj-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A networked Mah Jong program, together with a computer player
+COMMENT= Networked Mah Jong program, together with a computer player
LICENSE= GPLv2 # (or later)
-USES= perl5 gmake pkgconfig
+USES= gmake perl5 pkgconfig
USE_GNOME= gtk20
USE_PERL5= build
MAKE_ENV= CCLINK="${CC}" CDEBUGFLAGS="${CFLAGS}" PERL="${PERL}" \
INCLUDES="-I."
-MAN1= xmj.1
-MLINKS= xmj.1 mj-player.1 \
- xmj.1 mj-server.1
-PLIST_FILES= bin/mj-server bin/mj-player bin/xmj
+PLIST_FILES= bin/mj-server bin/mj-player bin/xmj \
+ man/man1/mj-player.1.gz man/man1/mj-server.1.gz \
+ man/man1/xmj.1.gz
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's|^CC|#CC|g ; \
s|^DESTDIR|#DESTDIR|g ; \
s|^CDEBUGFLAGS|#CDEBUGFLAGS|g ; \
@@ -35,17 +32,22 @@ post-patch:
s|^PERL|#PERL|g ; \
s|^INST|#INST|g ; \
s|make |$$(MAKE) |g' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e \
's|SOL_TCP|IPPROTO_TCP|' ${WRKSRC}/sysdep.c
do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
Makefile.in Makefile)
do-install:
-.for file in mj-server mj-player xmj
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin/${file}
+.for i in mj-player mj-server xmj
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} \
+ ${STAGEDIR}${PREFIX}/bin/${i})
+.endfor
+ (cd ${WRKSRC} && ${INSTALL_MAN} xmj.man \
+ ${STAGEDIR}${MANPREFIX}/man/man1/xmj.1)
+.for i in mj-player.1 mj-server.1
+ ${LN} -sf xmj.1 ${STAGEDIR}${MANPREFIX}/man/man1/${i}
.endfor
- ${INSTALL_MAN} ${WRKSRC}/xmj.man ${MANPREFIX}/man/man1/xmj.1
.include <bsd.port.mk>
diff --git a/games/mahjong/distinfo b/games/mahjong/distinfo
index cb156f421af4..efe41ad81120 100644
--- a/games/mahjong/distinfo
+++ b/games/mahjong/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mj-1.12.1-src.tar.gz) = 6066a5e8fb629063313f1383db9c9d775c0f0ba390803f07ac6393cd03f2d0ce
-SIZE (mj-1.12.1-src.tar.gz) = 402341
+SHA256 (mj-1.13-src.tar.gz) = 024a7f5a081a9151ad31e7178b3eeb9a8befab717aad2970775c400a16f76f33
+SIZE (mj-1.13-src.tar.gz) = 411628
diff --git a/games/mahjong/pkg-descr b/games/mahjong/pkg-descr
index 967d06236bac..755a3b5c8666 100644
--- a/games/mahjong/pkg-descr
+++ b/games/mahjong/pkg-descr
@@ -1,7 +1,7 @@
-This is a set of three programs which provide a networked Mah Jong program,
-together with a computer player. Thus the game can be played by four humans, by
-a human and three computer players, or any other combination. There is a server
-program, which handles the game. An X client to allow humans to play naturally,
-and a computer player.
+This is a set of three programs which provide a networked Mah Jong
+program, together with a computer player. Thus the game can be played by
+four humans, by a human and three computer players, or any other
+combination. There is a server program, which handles the game. An X
+client to allow humans to play naturally, and a computer player.
WWW: http://mahjong.julianbradfield.org/