aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2006-09-22 23:06:23 +0800
committerarved <arved@FreeBSD.org>2006-09-22 23:06:23 +0800
commitf450c9190f62c229973316b5edb013499f7585d0 (patch)
tree5205c10b7cfb849d537599c0ca03a464eec23eec
parent34a2c5075f7e3d337b77d3057d8c46e23c52cd42 (diff)
downloadfreebsd-ports-gnome-f450c9190f62c229973316b5edb013499f7585d0.tar.gz
freebsd-ports-gnome-f450c9190f62c229973316b5edb013499f7585d0.tar.zst
freebsd-ports-gnome-f450c9190f62c229973316b5edb013499f7585d0.zip
Add missing dependency on libdnet
PR: 102272 Submitted by: David Adam <zanchey@ucc.gu.uwa.edu.au> Approved by: maintainer timeout (1 month) While here fix a segfault in usage() (*sigh*)
-rw-r--r--net-mgmt/arpscan/Makefile3
-rw-r--r--net-mgmt/arpscan/files/patch-arpscan.c25
2 files changed, 24 insertions, 4 deletions
diff --git a/net-mgmt/arpscan/Makefile b/net-mgmt/arpscan/Makefile
index 8642bcc75a4b..282335ae04d6 100644
--- a/net-mgmt/arpscan/Makefile
+++ b/net-mgmt/arpscan/Makefile
@@ -7,13 +7,14 @@
PORTNAME= arpscan
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://ish.cx/~jason/arpscan/
MAINTAINER= dyeske@yahoo.com
COMMENT= Simple arp scanner
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet
+LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/net-mgmt/arpscan/files/patch-arpscan.c b/net-mgmt/arpscan/files/patch-arpscan.c
index 465a2f1e71f7..c06e55310731 100644
--- a/net-mgmt/arpscan/files/patch-arpscan.c
+++ b/net-mgmt/arpscan/files/patch-arpscan.c
@@ -1,6 +1,16 @@
---- arpscan.c.orig Mon Aug 18 16:54:25 2003
-+++ arpscan.c Mon Mar 22 23:05:40 2004
-@@ -17,6 +17,13 @@
+--- arpscan.c.orig Mon Aug 18 22:54:25 2003
++++ arpscan.c Fri Sep 22 16:55:48 2006
+@@ -8,7 +8,9 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#include <err.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+
+@@ -17,6 +19,13 @@
#define PCAP_TIMEO 20
@@ -14,3 +24,12 @@
struct ether_arp {
struct arp_hdr ea_hdr;
u_int8_t arp_sha[ETH_ADDR_LEN];
+@@ -36,7 +45,7 @@
+ fprintf(stderr, "\teg)\n");
+ fprintf(stderr, "\t %s 172.16.1.11\n", __progname);
+ fprintf(stderr, "\t %s 192.168.1.100-192.168.1.200\n", __progname);
+- fprintf(stderr, "\t %s 172.16.1.41/29\n");
++ fprintf(stderr, "\t %s 172.16.1.41/29\n", __progname);
+ fprintf(stderr, "\n");
+ exit(1);
+ }