aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrodrigo <rodrigo@FreeBSD.org>2014-07-23 21:41:07 +0800
committerrodrigo <rodrigo@FreeBSD.org>2014-07-23 21:41:07 +0800
commitf5bb801d1f35ab02dd5b47c3f64e188954554c30 (patch)
treec66d0d331985bee1ddb772f8c9f6de181eedbcbc
parenta4ab3fd3aabb7946fcd524369cfae44b3d17a522 (diff)
downloadfreebsd-ports-gnome-f5bb801d1f35ab02dd5b47c3f64e188954554c30.tar.gz
freebsd-ports-gnome-f5bb801d1f35ab02dd5b47c3f64e188954554c30.tar.zst
freebsd-ports-gnome-f5bb801d1f35ab02dd5b47c3f64e188954554c30.zip
Fix a minima the plugin breakage introduced by Net::DNS 0.75 and above.
This bug is complex and must be fixed upstream (smokeping)[1]. [1] https://rt.cpan.org/Public/Bug/Display.html?id=96479 PR: ports/192037 Submitted by: feld Reviewed by: rodrigo (maintainer) Approved by: kwm (mentor) MFH: 2014Q3
-rw-r--r--net-mgmt/smokeping/Makefile2
-rw-r--r--net-mgmt/smokeping/files/patch-lib__Smokeping__probes__AnotherDNS.pm20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 9f36a839f7e5..b8a327a6cf75 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -3,7 +3,7 @@
PORTNAME= smokeping
PORTVERSION= 2.6.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
MASTER_SITES= http://oss.oetiker.ch/smokeping/pub/ \
http://smokeping.cs.pu.edu.tw/pub/
diff --git a/net-mgmt/smokeping/files/patch-lib__Smokeping__probes__AnotherDNS.pm b/net-mgmt/smokeping/files/patch-lib__Smokeping__probes__AnotherDNS.pm
new file mode 100644
index 000000000000..ebe95b71a470
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-lib__Smokeping__probes__AnotherDNS.pm
@@ -0,0 +1,20 @@
+--- lib/Smokeping/probes/AnotherDNS.pm.orig 2012-07-09 09:45:46.000000000 +0000
++++ lib/Smokeping/probes/AnotherDNS.pm 2014-07-22 23:07:45.626343897 +0000
+@@ -25,6 +25,8 @@
+ use IO::Select;
+ use Net::DNS;
+
++use constant PACKETSZ => 512;
++
+ sub pod_hash {
+ return {
+ name => <<DOC,
+@@ -95,7 +97,7 @@
+ $elapsed = tv_interval( $t0, $t1 );
+ if ( defined $ready ) {
+ my $buf = '';
+- $ready->recv( $buf, &Net::DNS::PACKETSZ );
++ $ready->recv( $buf, PACKETSZ );
+ my ($recvPacket, $err) = Net::DNS::Packet->new(\$buf);
+ if (defined $recvPacket) {
+ my $recvHeader = $recvPacket->header();