aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-06-30 20:44:35 +0800
committerantoine <antoine@FreeBSD.org>2013-06-30 20:44:35 +0800
commitf5fb8f8adbe59daa63ddc4a9cdc3851329899219 (patch)
treead8f930fc530f1b9cface12f59fcc8a674160cbf
parent45214b4baf8cf4e176e840938e04041751b56cb3 (diff)
downloadfreebsd-ports-gnome-f5fb8f8adbe59daa63ddc4a9cdc3851329899219.tar.gz
freebsd-ports-gnome-f5fb8f8adbe59daa63ddc4a9cdc3851329899219.tar.zst
freebsd-ports-gnome-f5fb8f8adbe59daa63ddc4a9cdc3851329899219.zip
New port: rubygem-packetfu
A mid-level packet manipulation library for Ruby
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-packetfu/Makefile17
-rw-r--r--net/rubygem-packetfu/distinfo2
-rw-r--r--net/rubygem-packetfu/pkg-descr5
4 files changed, 25 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d57e26dab5bc..28e5306ff544 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1049,6 +1049,7 @@
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-open-uri-cached
SUBDIR += rubygem-openid
+ SUBDIR += rubygem-packetfu
SUBDIR += rubygem-pcaprub
SUBDIR += rubygem-rightaws
SUBDIR += rubygem-rightflexiscale
diff --git a/net/rubygem-packetfu/Makefile b/net/rubygem-packetfu/Makefile
new file mode 100644
index 000000000000..bd3d7607a644
--- /dev/null
+++ b/net/rubygem-packetfu/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= packetfu
+PORTVERSION= 1.1.8
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Mid-level packet manipulation library for Ruby
+
+LICENSE= BSD
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-packetfu/distinfo b/net/rubygem-packetfu/distinfo
new file mode 100644
index 000000000000..8d231f2f19be
--- /dev/null
+++ b/net/rubygem-packetfu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/packetfu-1.1.8.gem) = 93b4dfecee59644a1a3ecf9d825f00739c10a6fbd149a7106cc9a812b09e7a12
+SIZE (rubygem/packetfu-1.1.8.gem) = 750080
diff --git a/net/rubygem-packetfu/pkg-descr b/net/rubygem-packetfu/pkg-descr
new file mode 100644
index 000000000000..101331da700c
--- /dev/null
+++ b/net/rubygem-packetfu/pkg-descr
@@ -0,0 +1,5 @@
+PacketFu is a mid-level packet manipulation library for Ruby. With it, users
+can read, parse, and write network packets with the level of ease and fun they
+expect from Ruby.
+
+WWW: https://github.com/todb/packetfu