aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-07 02:47:37 +0800
committerpav <pav@FreeBSD.org>2004-07-07 02:47:37 +0800
commitf9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe (patch)
tree6b1ee2ab2d432562ebef1e8334d1fb27c61ab254
parent659e31d52a0a963e4ef5e5b71e1feabecdbe867b (diff)
downloadfreebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.tar.gz
freebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.tar.zst
freebsd-ports-gnome-f9a1035d93fcbeeb4b9ee26797f9bd3a83de3bbe.zip
Add bygfoot, a football (a.k.a. soccer) management game. Bygfoot allows you to
manage a team by training the players, buying and selling them, contracting loans, maintaining the stadium, etc.
-rw-r--r--games/Makefile1
-rw-r--r--games/bygfoot/Makefile27
-rw-r--r--games/bygfoot/distinfo2
-rw-r--r--games/bygfoot/pkg-descr9
-rw-r--r--games/bygfoot/pkg-plist33
5 files changed, 72 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index f99ea1ac107a..6b737e799a40 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -60,6 +60,7 @@
SUBDIR += bugsquish
SUBDIR += bugsx
SUBDIR += burgerspace
+ SUBDIR += bygfoot
SUBDIR += bzflag
SUBDIR += cardpics
SUBDIR += cgoban
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
new file mode 100644
index 000000000000..39e875b7876f
--- /dev/null
+++ b/games/bygfoot/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bygfoot
+# Date created: 6th July 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bygfoot
+PORTVERSION= 1.4.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Football (soccer) management game
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20 gnometarget
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|;;|;|' ${WRKSRC}/src/windows.c
+
+.include <bsd.port.mk>
diff --git a/games/bygfoot/distinfo b/games/bygfoot/distinfo
new file mode 100644
index 000000000000..1e2e80884c60
--- /dev/null
+++ b/games/bygfoot/distinfo
@@ -0,0 +1,2 @@
+MD5 (bygfoot-1.4.0.tar.bz2) = 6605c8d1fd3b02ef18934b4f2b268d9e
+SIZE (bygfoot-1.4.0.tar.bz2) = 248144
diff --git a/games/bygfoot/pkg-descr b/games/bygfoot/pkg-descr
new file mode 100644
index 000000000000..9a7e90cf07a9
--- /dev/null
+++ b/games/bygfoot/pkg-descr
@@ -0,0 +1,9 @@
+Bygfoot is a football (a.k.a. soccer) management game. Bygfoot allows you to
+manage a team by training the players, buying and selling them, contracting
+loans, maintaining the stadium, etc. You can be promoted or relegated, even
+become a champion. It includes a "team editor" which you can use to create your
+own teams or edit the existing ones. The game is deliberately kept simple
+(though not easy): you only have to keep one eye at your players and another
+at your stadium.
+
+WWW: http://bygfoot.sourceforge.net/
diff --git a/games/bygfoot/pkg-plist b/games/bygfoot/pkg-plist
new file mode 100644
index 000000000000..7476c8a95898
--- /dev/null
+++ b/games/bygfoot/pkg-plist
@@ -0,0 +1,33 @@
+bin/bygfoot
+share/bygfoot/support_files/bygfoot_icon.png
+share/bygfoot/support_files/bygfoot_team_editor_icon.png
+share/bygfoot/support_files/fin_stad.png
+share/bygfoot/support_files/flag_br.png
+share/bygfoot/support_files/flag_de.png
+share/bygfoot/support_files/flag_eng.png
+share/bygfoot/support_files/flag_es.png
+share/bygfoot/support_files/flag_fr.png
+share/bygfoot/support_files/flag_it.png
+share/bygfoot/support_files/flag_pl.png
+share/bygfoot/support_files/flag_ro.png
+share/bygfoot/support_files/get_loan.png
+share/bygfoot/support_files/inc_cap.png
+share/bygfoot/support_files/inc_saf.png
+share/bygfoot/support_files/new_week.png
+share/bygfoot/support_files/pay_loan.png
+share/bygfoot/support_files/preview.png
+share/bygfoot/support_files/text_files/country_br
+share/bygfoot/support_files/text_files/country_de
+share/bygfoot/support_files/text_files/country_eng
+share/bygfoot/support_files/text_files/country_es
+share/bygfoot/support_files/text_files/country_fr
+share/bygfoot/support_files/text_files/country_it
+share/bygfoot/support_files/text_files/country_pl
+share/bygfoot/support_files/text_files/country_ro
+share/bygfoot/support_files/text_files/help
+share/bygfoot/support_files/text_files/player_names
+share/bygfoot/support_files/text_files/teams
+share/bygfoot/support_files/transfers.png
+@dirrm share/bygfoot/support_files/text_files
+@dirrm share/bygfoot/support_files
+@dirrm share/bygfoot