aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-03-12 16:58:27 +0800
committervanilla <vanilla@FreeBSD.org>2001-03-12 16:58:27 +0800
commitf9aec7d239bbb9eeadd9ec6981ddde58585c24a1 (patch)
tree6c6b0f0daae256b187037ff63ee9b13c90e8a642
parenta2674d5eb7268d0435a16291c3afe14a43c4566f (diff)
downloadfreebsd-ports-gnome-f9aec7d239bbb9eeadd9ec6981ddde58585c24a1.tar.gz
freebsd-ports-gnome-f9aec7d239bbb9eeadd9ec6981ddde58585c24a1.tar.zst
freebsd-ports-gnome-f9aec7d239bbb9eeadd9ec6981ddde58585c24a1.zip
Add p5-ORBit, it's perl binding to ORBit library.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ORBit/Makefile31
-rw-r--r--devel/p5-ORBit/distinfo1
-rw-r--r--devel/p5-ORBit/pkg-comment1
-rw-r--r--devel/p5-ORBit/pkg-descr1
-rw-r--r--devel/p5-ORBit/pkg-plist13
6 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aa6b9a4a16b2..a4c1dd0ef8fc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -277,6 +277,7 @@
SUBDIR += p5-LockFile-Simple
SUBDIR += p5-Mac-FileSpec-Unixish
SUBDIR += p5-Make
+ SUBDIR += p5-ORBit
SUBDIR += p5-PV
SUBDIR += p5-Parse-RecDescent
SUBDIR += p5-Penguin
diff --git a/devel/p5-ORBit/Makefile b/devel/p5-ORBit/Makefile
new file mode 100644
index 000000000000..e0b424c7530f
--- /dev/null
+++ b/devel/p5-ORBit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-ORBit
+# Date created: 11 March 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= ORBit
+PORTVERSION= 0.4.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CORBA
+PKGNAMEPREFIX= p5-
+DISTNAME= CORBA-ORBit-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Error.pm:${PORTSDIR}/lang/p5-Error
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= CORBA::ORBit.3 \
+ CORBA::ORBit::Fixed.3 \
+ CORBA::ORBit::LongDouble.3 \
+ CORBA::ORBit::LongLong.3 \
+ CORBA::ORBit::ULongLong.3 \
+ CORBA::ORBit::mapping.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ORBit/distinfo b/devel/p5-ORBit/distinfo
new file mode 100644
index 000000000000..f251ef085f0f
--- /dev/null
+++ b/devel/p5-ORBit/distinfo
@@ -0,0 +1 @@
+MD5 (CORBA-ORBit-0.4.3.tar.gz) = 17910897d32d9bbedad745fe3fa1b94a
diff --git a/devel/p5-ORBit/pkg-comment b/devel/p5-ORBit/pkg-comment
new file mode 100644
index 000000000000..83254afff035
--- /dev/null
+++ b/devel/p5-ORBit/pkg-comment
@@ -0,0 +1 @@
+The perl binding for ORBit
diff --git a/devel/p5-ORBit/pkg-descr b/devel/p5-ORBit/pkg-descr
new file mode 100644
index 000000000000..10f6bed1cc30
--- /dev/null
+++ b/devel/p5-ORBit/pkg-descr
@@ -0,0 +1 @@
+The perl binding for ORBit.
diff --git a/devel/p5-ORBit/pkg-plist b/devel/p5-ORBit/pkg-plist
new file mode 100644
index 000000000000..66018d578d5e
--- /dev/null
+++ b/devel/p5-ORBit/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/Fixed.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/LongDouble.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/LongLong.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/ULongLong.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit/mapping.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/ORBit.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit/ORBit.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA/ORBit
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CORBA
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA/ORBit
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/CORBA