aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2006-12-15 21:29:55 +0800
committernork <nork@FreeBSD.org>2006-12-15 21:29:55 +0800
commitfb74503fba14c7e0cf8a12ae4ef412dc957a4705 (patch)
tree22d52f8069289a7ce33cfcdd2cde2da7ce5a9c70
parent6f2bf0a80c851643f5a6b97d9a613e60663f028f (diff)
downloadfreebsd-ports-gnome-fb74503fba14c7e0cf8a12ae4ef412dc957a4705.tar.gz
freebsd-ports-gnome-fb74503fba14c7e0cf8a12ae4ef412dc957a4705.tar.zst
freebsd-ports-gnome-fb74503fba14c7e0cf8a12ae4ef412dc957a4705.zip
Respect PTHREAD_LIBS.
-rw-r--r--multimedia/libdv/Makefile4
-rw-r--r--multimedia/libdv/files/patch-configure11
2 files changed, 15 insertions, 0 deletions
diff --git a/multimedia/libdv/Makefile b/multimedia/libdv/Makefile
index 8d0e82611d45..fe8acad91efc 100644
--- a/multimedia/libdv/Makefile
+++ b/multimedia/libdv/Makefile
@@ -88,6 +88,10 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|(@REQUIRES_NOPKGCONFIG@)|-L${LOCALBASE}/include \1|' \
${WRKSRC}/libdv.pc.in
+pre-configure:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/multimedia/libdv/files/patch-configure b/multimedia/libdv/files/patch-configure
new file mode 100644
index 000000000000..15393bab6bee
--- /dev/null
+++ b/multimedia/libdv/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Nov 30 12:23:44 2004
++++ configure Sun Dec 10 04:22:48 2006
+@@ -20393,8 +20393,6 @@
+ # FreeBSD and OpenBSD have neither -lpthread nor integrated pthreads in libc.
+ # Instead -pthread is used to the compiler/linker to get pthreads working right.
+ if test x$OS_ARCH = xFreeBSD -o x$OS_ARCH = xOpenBSD; then
+- CFLAGS="$CFLAGS -pthread"
+- CXXFLAGS="$CXXFLAGS -pthread"
+ fi
+
+