aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-10 22:28:22 +0800
committermiwi <miwi@FreeBSD.org>2013-02-10 22:28:22 +0800
commitfd36fd4ae9f23bb6bb083df5263fd4bea887e5f8 (patch)
tree78e1ef8132f396650deae97c2b67e447038906c6
parent735573148d0e262565d00c84097c7ffeccd17bc5 (diff)
downloadfreebsd-ports-gnome-fd36fd4ae9f23bb6bb083df5263fd4bea887e5f8.tar.gz
freebsd-ports-gnome-fd36fd4ae9f23bb6bb083df5263fd4bea887e5f8.tar.zst
freebsd-ports-gnome-fd36fd4ae9f23bb6bb083df5263fd4bea887e5f8.zip
Download-gemist downloads video's from the Dutch uitzending gemist site.
Included tools: ### download-gemist Can download a single episode from the episode URL. ### download-gemist-guide This fetches information from a program page. You can use it download multiple videos. WWW: http://code.arp242.net/download-gemist PR: ports/173567 Submitted by: Martin Tournoij <martin@arp242.net>
-rw-r--r--www/Makefile1
-rw-r--r--www/download-gemist/Makefile29
-rw-r--r--www/download-gemist/distinfo2
-rw-r--r--www/download-gemist/pkg-descr12
4 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 59e62af46c05..a415a9117b80 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -137,6 +137,7 @@
SUBDIR += dokuwiki
SUBDIR += dotclear
SUBDIR += dotproject
+ SUBDIR += download-gemist
SUBDIR += dpsearch
SUBDIR += drood
SUBDIR += drraw
diff --git a/www/download-gemist/Makefile b/www/download-gemist/Makefile
new file mode 100644
index 000000000000..02e3e396c3da
--- /dev/null
+++ b/www/download-gemist/Makefile
@@ -0,0 +1,29 @@
+# Created by: Martin Tournoij <martin@arp242.net>
+# $FreeBSD$
+#
+
+PORTNAME= download-gemist
+PORTVERSION= 1.2
+CATEGORIES= www python
+MASTER_SITES= http://code.arp242.net/download-gemist/downloads/
+
+MAINTAINER= martin@arp242.net
+COMMENT= Download videos from the Dutch uitzending gemist site
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+NO_BUILD= yes
+FETCH_ARGS= -Fpr
+
+PLIST_DIRS= %%DOCSDIR%%
+PLIST_FILES= bin/download-gemist \
+ bin/download-gemist-guide \
+ %%DOCSDIR%%/README.md
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/download-gemist* ${PREFIX}/bin/
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/www/download-gemist/distinfo b/www/download-gemist/distinfo
new file mode 100644
index 000000000000..6d3c53a4c7e9
--- /dev/null
+++ b/www/download-gemist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (download-gemist-1.2.tar.gz) = f27f72aed38e11e69187cfd30f07a545048f40ce52e439457bfbb28219f1d61d
+SIZE (download-gemist-1.2.tar.gz) = 23052
diff --git a/www/download-gemist/pkg-descr b/www/download-gemist/pkg-descr
new file mode 100644
index 000000000000..ae3e04440300
--- /dev/null
+++ b/www/download-gemist/pkg-descr
@@ -0,0 +1,12 @@
+Download-gemist downloads video's from the Dutch uitzending gemist site.
+
+Included tools:
+
+### download-gemist
+Can download a single episode from the episode URL.
+
+### download-gemist-guide
+This fetches information from a program page. You can use it download multiple
+videos.
+
+WWW: http://code.arp242.net/download-gemist